N54Tech.com - International Turbo Racing Discussion
Go Back   N54Tech.com - International Turbo Racing Discussion > Model-Specific Engine Tuning & Modification Discussion > N54
Reload this Page Ordering MOSFET chips for DME Internal Failure, part # FDB14N30TM, right?
Reply
 
Thread Tools Search this Thread Display Modes
(#1)
Old
BeastMode335i's Avatar
BeastMode335i BeastMode335i is offline
Junior Member
 
Posts: 495
Join Date: Dec 2014
Car: 08 E92 335i
Default Ordering MOSFET chips for DME Internal Failure, part # FDB14N30TM, right? - 04-18-2016, 11:07 AM

So I have an MSD80 early 2008 DME, and just did the MHD flash and on my very first pull from 3rd gear, SES started flashing and it started driving horribly.. After reading around I imagine it's my DME that got fried (fan-****in-tastic) and it's the little MOSFET chips that have to be replaced.. I found a local TV Repair person who said he'll do it for $15 and to go ahead and order the chips, but just want to make sure I order the right ones as I heard there are newer revised versions of the MOSFET chips..
Reply With Quote
(#2)
Old
Jt0407 Jt0407 is offline
Junior Member
 
Posts: 303
Join Date: Feb 2015
Car: Bmw
Default 04-18-2016, 12:11 PM

Same thing happened to me. 3rd gear pull and bang! 3 fried mosfets.
Reply With Quote
(#3)
Old
BeastMode335i's Avatar
BeastMode335i BeastMode335i is offline
Junior Member
 
Posts: 495
Join Date: Dec 2014
Car: 08 E92 335i
Default 04-18-2016, 12:45 PM

Quote:
Originally Posted by Jt0407
Same thing happened to me. 3rd gear pull and bang! 3 fried mosfets.
**** sucks right ;/

I just got my car back about 1.5 months ago and it's been running great so I figured since I'm just about FBO (missing FMIC) that I'd throw Stage 1 MHD tune and enjoy the benefits I've been hearing about.. Well yeah, I'm not one of the lucky ones who gets to enjoy such benefits and instead I'm stuck ordering MOSFET chips and without a car again..

Did you fix them yourself? Did you replace coils as well?
Reply With Quote
(#4)
Old
BeastMode335i's Avatar
BeastMode335i BeastMode335i is offline
Junior Member
 
Posts: 495
Join Date: Dec 2014
Car: 08 E92 335i
Default 04-19-2016, 08:23 AM

https://youtu.be/ig1JAS6R4Ik

Injector 1 mosfet is my culprit..
Reply With Quote
(#5)
Old
omarmarji's Avatar
omarmarji omarmarji is offline
Senior Member
 
Posts: 915
Join Date: May 2015
Car: n54 335
Default 04-19-2016, 08:54 AM

damn :/ better than replacing the entire ecu tho


751WHP 688WTQ
JP Works Kit Record
SOLD: E90 335i 751whp 688WTQ
CURRENT: E82 135i (under construction)
Visit my website VaderSolution.com !
Reply With Quote
(#6)
Old
BeastMode335i's Avatar
BeastMode335i BeastMode335i is offline
Junior Member
 
Posts: 495
Join Date: Dec 2014
Car: 08 E92 335i
Default 04-19-2016, 09:32 AM

Quote:
Originally Posted by omarmarji
damn :/ better than replacing the entire ecu tho
Amen dude..!

Found a local TV repair guy who said he'll do it for me for $15 whether I replace just that 1 or replace all 6.. So that's reassuring..
Reply With Quote
(#7)
Old
dlp3719 dlp3719 is offline
Junior Member
 
Posts: 187
Join Date: Jun 2012
Car: 2007 335i
Default 04-19-2016, 09:45 AM

Happened to me about 2.5 years ago and 35k miles ago. I had all 6 replaced at a TV repair shop. No issues since. Ordered the chips from DigiKey.

I believe it was this one.
http://www.digikey.com/product-searc...DB14N30TMCT-ND


2007 n54 e90 sedan (1/07 date), JB4 G5 ISO - Map 3, BMS DCI, BMS Trunk Tank Meth Kit - two nozzle - CM7/CM10, BMS OCC, MHD Trebilia Flash, e60 (5 gallons of 93 and 11 gallons E85), Stage 2 from Fuel-It, VRSF 7" FMIC, N54tuning.com V1 DP, ER Charge Pipe w/Tial BOV, NGK Iridium (one-step colder) plugs, N20 TMAP Sensor, RB turbo inlets, VTT outlets
Reply With Quote
(#8)
Old
veee8's Avatar
veee8 veee8 is offline
Junior Member
 
Posts: 37
Join Date: Apr 2015
Car: BMW
Default 04-19-2016, 12:25 PM

Same thing happened to me right after I bought my 2008 E92. Loaded Stage 1 in there to try it out, made boost and bam fried the coil and mosfet. I ordered the mosfets, but before I had a chance to install them, I found out that I was still covered under the emissions warranty to 8 year 80K miles.
After some back and forth with BMW, they had a hard time believing the DME was bad. They had to try an injector and coil first, they did replace the DME with a brand new MSD81. I was nothing out of pocket.
Reply With Quote
(#9)
Old
BeastMode335i's Avatar
BeastMode335i BeastMode335i is offline
Junior Member
 
Posts: 495
Join Date: Dec 2014
Car: 08 E92 335i
Default 04-19-2016, 12:25 PM

Quote:
Originally Posted by dlp3719
Happened to me about 2.5 years ago and 35k miles ago. I had all 6 replaced at a TV repair shop. No issues since. Ordered the chips from DigiKey.

I believe it was this one.
http://www.digikey.com/product-searc...DB14N30TMCT-ND
Thanks for the input man I appreciate it..

Those are the exact ones I ordered! Did you have any injector or coil issues as well, or did fixing this take care of it all??

Thanks again..!
Reply With Quote
(#10)
Old
veee8's Avatar
veee8 veee8 is offline
Junior Member
 
Posts: 37
Join Date: Apr 2015
Car: BMW
Default 04-19-2016, 01:43 PM

When the mosfet goes, it can take out the coil and or injector.
Reply With Quote
(#11)
Old
dlp3719 dlp3719 is offline
Junior Member
 
Posts: 187
Join Date: Jun 2012
Car: 2007 335i
Default 04-19-2016, 01:47 PM

I guess I got lucky. Paid TV repair guy $30 and it fixed it all. Just dropped the DME back in the car and hooked everything back up. No coil, injector or plug damage. Most expensive part was $60 tow back to the house and hassle of being without a car for a couple of days.


2007 n54 e90 sedan (1/07 date), JB4 G5 ISO - Map 3, BMS DCI, BMS Trunk Tank Meth Kit - two nozzle - CM7/CM10, BMS OCC, MHD Trebilia Flash, e60 (5 gallons of 93 and 11 gallons E85), Stage 2 from Fuel-It, VRSF 7" FMIC, N54tuning.com V1 DP, ER Charge Pipe w/Tial BOV, NGK Iridium (one-step colder) plugs, N20 TMAP Sensor, RB turbo inlets, VTT outlets
Reply With Quote
(#12)
Old
dlp3719 dlp3719 is offline
Junior Member
 
Posts: 187
Join Date: Jun 2012
Car: 2007 335i
Default 04-19-2016, 01:49 PM

At the time my happened I had 85k miles and missed the emissions warranty. I pushed but BMW refused.

N54dme.com was the thing floating around at the time. $500 haha


2007 n54 e90 sedan (1/07 date), JB4 G5 ISO - Map 3, BMS DCI, BMS Trunk Tank Meth Kit - two nozzle - CM7/CM10, BMS OCC, MHD Trebilia Flash, e60 (5 gallons of 93 and 11 gallons E85), Stage 2 from Fuel-It, VRSF 7" FMIC, N54tuning.com V1 DP, ER Charge Pipe w/Tial BOV, NGK Iridium (one-step colder) plugs, N20 TMAP Sensor, RB turbo inlets, VTT outlets
Reply With Quote
(#13)
Old
Jt0407 Jt0407 is offline
Junior Member
 
Posts: 303
Join Date: Feb 2015
Car: Bmw
Default 04-19-2016, 06:28 PM

Make sure to replace all 6.
Reply With Quote
(#14)
Old
BeastMode335i's Avatar
BeastMode335i BeastMode335i is offline
Junior Member
 
Posts: 495
Join Date: Dec 2014
Car: 08 E92 335i
Default 04-19-2016, 06:55 PM

Thanks guys, I'll definitely replace all 6 while in there..

Yah it seems this issue is super common, kind of weird.. btw, my cars at 75k miles and is an 08..
Reply With Quote
(#15)
Old
rathana_v rathana_v is offline
Junior Member
 
Posts: 77
Join Date: Jul 2014
Car: 335i
Default 08-20-2016, 08:45 PM

same thing happend to me too...tonight!!...installed wedge stage 2+ aggressive...did a 3rd gear pull..then bam!! backfire and codes galore...30ba code is one of them...headaches with this car
Reply With Quote
(#16)
Old
Jo335i Jo335i is offline
New Member
 
Posts: 9
Join Date: Sep 2017
Car: Bmw 335i e92 2007
Default 01-19-2018, 07:03 PM

Same thing happened to me. Bmw 335i 2007.after mhd stage 1 stock map my first test drive and it burned mosfets and injectors. Does anybody know a place online from where I can order good quality mosfets that are more resistent?
Reply With Quote
(#17)
Old
Jo335i Jo335i is offline
New Member
 
Posts: 9
Join Date: Sep 2017
Car: Bmw 335i e92 2007
Default 01-19-2018, 07:05 PM

Where can I order good qualituly mosfets that are more resistant than the originals one?? Thanks
Reply With Quote
(#18)
Old
Jo335i Jo335i is offline
New Member
 
Posts: 9
Join Date: Sep 2017
Car: Bmw 335i e92 2007
Default 01-19-2018, 07:05 PM

Where can I order good qualituly mosfets that are more resistant than the originals one?? Thanks
Reply With Quote
(#19)
Old
dlp3719 dlp3719 is offline
Junior Member
 
Posts: 187
Join Date: Jun 2012
Car: 2007 335i
Default 01-19-2018, 07:27 PM

Quote:
Originally Posted by Jo335i
Where can I order good qualituly mosfets that are more resistant than the originals one?? Thanks
https://www.digikey.com/product-deta...MCT-ND/1566830

They don’t need to be more resistant than stock. Stock had a defect. I replaced at 85k and no issue since. 130k now.


2007 n54 e90 sedan (1/07 date), JB4 G5 ISO - Map 3, BMS DCI, BMS Trunk Tank Meth Kit - two nozzle - CM7/CM10, BMS OCC, MHD Trebilia Flash, e60 (5 gallons of 93 and 11 gallons E85), Stage 2 from Fuel-It, VRSF 7" FMIC, N54tuning.com V1 DP, ER Charge Pipe w/Tial BOV, NGK Iridium (one-step colder) plugs, N20 TMAP Sensor, RB turbo inlets, VTT outlets

Last edited by dlp3719; 01-19-2018 at 07:33 PM..
Reply With Quote
(#20)
Old
Jo335i Jo335i is offline
New Member
 
Posts: 9
Join Date: Sep 2017
Car: Bmw 335i e92 2007
Default 01-19-2018, 07:40 PM

Quote:
Originally Posted by dlp3719
https://www.digikey.com/product-deta...MCT-ND/1566830

They donít need to be more resistant than stock. Stock had a defect. I replaced at 85k and no issue since. 130k now.
I have 110.000km on the clock now. Thats what 55k? Give or take.. I am too scared to put back mhd now. I have put index 12 injectors. And new plugs and coils.. Still terrified lol
Reply With Quote
(#21)
Old
MHD's Avatar
MHD MHD is offline
Senior Member
 
Posts: 524
Join Date: Jul 2013
Car: 07 335i AT
Default 01-20-2018, 10:03 AM

Quote:
Originally Posted by Jo335i
I have 110.000km on the clock now. Thats what 55k? Give or take.. I am too scared to put back mhd now. I have put index 12 injectors. And new plugs and coils.. Still terrified lol
It's a msd80 factory hardware issue. You fixed it, you're good to go now.
Reply With Quote
(#22)
Old
Nitrousbird Nitrousbird is offline
Junior Member
 
Posts: 117
Join Date: Jun 2015
Car: '07 335i 6MT
Default 01-26-2018, 05:05 PM

Just tried starting my car yesterday for the first time in a few weeks. Running very rough right away - pulled the DME and the MOSFET for Injector #1 is bad (rest tested good). Just ordered the MOSFETS linked in this thread. I don't have a good soldering station so I'll probably just pay a TV repair shop to fix it.

Nothing like a $1.47 part to keep your car from running.

I used this video: https://www.youtube.com/watch?v=pfHa7rdvRW8
Reply With Quote
(#23)
Old
threethirtyfive threethirtyfive is offline
Junior Member
 
Posts: 318
Join Date: Aug 2013
Car: 335i e90
Default 05-18-2018, 12:30 PM

Anyone ever have this issue but all six mosfets have proper continuity?


'07 e90
Reply With Quote
(#24)
Old
Nitrousbird Nitrousbird is offline
Junior Member
 
Posts: 117
Join Date: Jun 2015
Car: '07 335i 6MT
Default 05-20-2018, 02:29 AM

Quote:
Originally Posted by threethirtyfive
Anyone ever have this issue but all six mosfets have proper continuity?
Yes...had my MOSFET's changed out and had bank 1 fail again minuets later, but they all passed continuity. I ended up swapping to a MSD81.
Reply With Quote
(#25)
Old
threethirtyfive threethirtyfive is offline
Junior Member
 
Posts: 318
Join Date: Aug 2013
Car: 335i e90
Default 05-22-2018, 10:54 AM

Quote:
Originally Posted by Nitrousbird
Yes...had my MOSFET's changed out and had bank 1 fail again minuets later, but they all passed continuity. I ended up swapping to a MSD81.
My CAS is on it's way to be converted to MSD81. I had been having some phantom issues as well so this has probably been a long time coming. I have owned the car since 2011 and went from bone stock warrantied vehicle to full blown e85/PI/TD04.

The last year or so I was having some funky tuning issues but wasn't throwing codes etc. just seemed like something was off. Last time I drove the car was after cleaning up the DME box, went to get some beer and went to start the car to leave the gas station and it was running full on limp mode, but no normal engine error code or CEL for a bit. I attested it to a loose connector.

Place is right outside my neighborhood so I drove it home, adjusted connectors and said to hell with it. Few days later I check and she fires right up, no problems. Decided to let it sit and take a break, few months later I am greeted by the same issue. Finally spitting full on codes for DME failure.

I was when none of my mosfets failed, I knew it was going to be a rabbit hole at that point. Hadn't ever worried about my mosfets so I wasn't even aware of the 81 upgrade. Few hundred bucks, but worth it not to worry or mess with it.


'07 e90
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com