N54Tech.com - International Turbo Racing Discussion
(#1)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default Jb4 Crashes at WOT - 11-14-2019, 08:55 AM

I've had this issue occasionaly for about 2 months now. It really got irritating when it happened mid race with a random Hellcat.

So at WOT, JB4 would either: freeze RPM and boost and put me into what feels like limp mode even though on the app it would say Map 6, or it would stop reading just RPM and cut power.

To fix the issue, I usually just pull over and restart the car or if that doesnt work, pop the hood and re-seat plugs on both sides of the JB4 box. I have the bluetooth facing the driver seat btw.

Is there a wiring/ bluetooth issue? If I went back to a wired setup, would that help?

2009 135i: FBO, RB turbos, E50 tune and meth injection.

I also get the 2ABD code at startup and IAT's rapidly jumping around + or - what the actual IAT is (I'm thinking it's a TMAP sensor issue). But, I dont think that has anything to do with what was said above.
Reply With Quote
(#2)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 11-14-2019, 12:50 PM

Can you get a log? Can you pull codes too, if any after this happens?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#3)
Old
jager335 jager335 is offline
Junior Member
 
Posts: 34
Join Date: Aug 2017
Car: 08' Bmw e92 Msport 335i
Default 11-14-2019, 04:27 PM

You could be over boosting and the jb4 freezes... Sounds like same issue I had. I would check that.
Reply With Quote
(#4)
Old
codesx codesx is offline
Senior Member
 
Posts: 774
Join Date: Feb 2018
Car: 2008 335i Vert (E93, N54)
Default 11-15-2019, 11:04 AM

Quote:
Originally Posted by chonchy123
I also get the 2ABD code at startup and IAT's rapidly jumping around + or - what the actual IAT is (I'm thinking it's a TMAP sensor issue). But, I dont think that has anything to do with what was said above.

Make your car work right, then test pushing it.
If the TMAP or other spits bad info, computers may have a hard time processing it.


--

2008 335i Convertible, E93, N54, A/T (200,000+ km)
Wheels: 322 | Tires: R.275/35r18, F.245/40r18
TUNE: JB4/Trebila | 24 PSI | 100% Meth via dual BM5 | 94 Octane
BMS: JB4, Map 6 | WMI | 5" FMIC | OCC | DCI | Cowel Filters
TMAP: 3.5 barr
xHP Stage 3 (v2.0)
VRSF CP | HKS BOV
RB PCV Valve
NGK 5992 Plugs @ .020

Maintenance:
2018 - A/T Replaced | Plugs | Ign Coils | Walnut Blasting
2019 - Index 12 Injectors | VCG | OFHG & O-rings | Alternator w/ Clutch Pulley | Water Pump & TStat
Reply With Quote
(#5)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 11-25-2019, 11:42 PM

Sorry for the super late reply. Had to to get the pre-*** o2 sensors replaced. Here's a map 7 log. I did notice my HPFP was dropping significantly. I'm running a 10 and 7 meth nozzle setup and surprised it drops that low. Will doing the reset adaptations through JB4 help at all? JB4 didnt crash this time but i still get the fluctuating IAT's.

Also I'm thinking of running 91 for a couple of weeks. Can I just switch to the MHD 91 tune and be done with it? I'd like to get a custom 91 tune later on to get the full capabilities of the mods that I have.
Attached Files
File Type: csv Map 7 Pull After o2 Sensor Instal.csv (18.6 KB, 13 views)
Reply With Quote
(#6)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 11-26-2019, 08:20 AM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Can you get a log? Can you pull codes too, if any after this happens?
Forgot to quote you. Log is in the post above.
Reply With Quote
(#7)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 11-26-2019, 08:48 AM

Quote:
Originally Posted by chonchy123
Sorry for the super late reply. Had to to get the pre-*** o2 sensors replaced. Here's a map 7 log. I did notice my HPFP was dropping significantly. I'm running a 10 and 7 meth nozzle setup and surprised it drops that low. Will doing the reset adaptations through JB4 help at all? JB4 didnt crash this time but i still get the fluctuating IAT's.

Also I'm thinking of running 91 for a couple of weeks. Can I just switch to the MHD 91 tune and be done with it? I'd like to get a custom 91 tune later on to get the full capabilities of the mods that I have.
Hpfp does look pretty tired / at its limit - how old is it?

91 for a few weeks- flash our pump BEF



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#8)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Wink 11-26-2019, 09:14 AM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Hpfp does look pretty tired / at its limit - how old is it?

91 for a few weeks- flash our pump BEF
According to the last owner, it's still the same pump and has never been changed out. Its taken a beating the last year so I figured this would happen sooner or later.

Does everything else look like is running good?

Which flash do I upload? JB4_ IJE0S_PUMP or IJE0S_PUMP_USA? Is there an option for 91 and meth?

Last edited by chonchy123; 11-26-2019 at 09:22 AM..
Reply With Quote
(#9)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 11-26-2019, 10:35 AM

USA

The pump flash is for fueling up to e30ish



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#10)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 11-26-2019, 10:39 AM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
USA

The pump flash is for fueling up to e30ish
Ok, thanks for the help Dave.
Reply With Quote
(#11)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 11-26-2019, 11:27 AM

No worries - enjoy the holiday weekend



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#12)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 11-26-2019, 01:02 PM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
No worries - enjoy the holiday weekend
You too man! Real quick question. I just messed with the meth settings and did a quick log. How is it? Is there any room for more boost? Maybe 1 or 2 psi more? If not that's fine. I don't want to push the car too much. This is on Map 3 91 BEF
Additive 40
Scaling 60
Reply With Quote
(#13)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 11-26-2019, 01:03 PM

Didnt let me post it the first time.
Attached Files
File Type: csv 0_2019-11-26 11_46_38_Map-3.csv (10.2 KB, 13 views)
Reply With Quote
(#14)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 11-26-2019, 01:09 PM

Quote:
Originally Posted by chonchy123
Didnt let me post it the first time.
Hpfp looks better.

Things look to be hanging on, you could bump it up incrementally- 1 psi & see



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#15)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 12-09-2019, 11:15 AM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Hpfp looks better.

Things look to be hanging on, you could bump it up incrementally- 1 psi & see
Alright I haven't changed anything settings wise and gassed the car up to e30 on same pump flash last night.

This morning I did a 3rd gear pull on the freeway and the car went in to limp mode for low meth flow and got codes 2C31 front of *** converter trimming control, 2C32 front of *** converter trimming control, and 2C6C behind *** converter system check. Here's the log of that same pull.

I just replaced both front O2 sensors about 3 weeks ago and reset adaptations.

I noticed the AFR's didnt look right and didn't want to do a low RPM 3rd gear log due to the AFR's, unless it's better for you to look at. Haven't stepped on it since then.
Attached Files
File Type: csv 0_2019-12-09 09_09_25_Map-3.csv (12.2 KB, 13 views)
Reply With Quote
(#16)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 12-09-2019, 01:51 PM

Are you out of meth?

Your trims oh both banks are maxed at 50... that can trigger the trimming control / o2 codes



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#17)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 12-09-2019, 04:11 PM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Are you out of meth?

Your trims oh both banks are maxed at 50... that can trigger the trimming control / o2 codes
Ok. What would be a solution to fix this.
Reply With Quote
(#18)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 12-09-2019, 07:20 PM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Are you out of meth?

Your trims oh both banks are maxed at 50... that can trigger the trimming control / o2 codes
I had more than half of meth in the tank on that pull. It was odd it went to limp mode though. Meth looked like it sprayed normally to me, idk.
Reply With Quote
(#19)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 12-10-2019, 10:06 AM

Quote:
Originally Posted by chonchy123
I had more than half of meth in the tank on that pull. It was odd it went to limp mode though. Meth looked like it sprayed normally to me, idk.
Check your lines / nozzle first. I went back & looked at one of your prior logs, doesnít look like any settings are different. But thereís definitely an issue..letís make sure physically it isnít something first.

The meth low code imo is whatís triggering the o2/ trims maxing trying to add fuel



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#20)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 12-11-2019, 09:21 AM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Check your lines / nozzle first. I went back & looked at one of your prior logs, doesnít look like any settings are different. But thereís definitely an issue..letís make sure physically it isnít something first.

The meth low code imo is whatís triggering the o2/ trims maxing trying to add fuel
Got it. Will check the nozzles today and let you know what happens.
Reply With Quote
(#21)
Old
codesx codesx is offline
Senior Member
 
Posts: 774
Join Date: Feb 2018
Car: 2008 335i Vert (E93, N54)
Default 12-11-2019, 11:04 AM

Make seriously sure your nozzle has the insert completely screwed in to bottom.
Otherwise you can over spray (squirt) the methanol... conceivably the lower resistance to flow could even trigger this... conceivably.

Note: I've had to screw down and tighten 2 of my 3 BM nozzles - a 5 and a 10, while the last 5 was OK. (I spray a 5 and 10 at this time)

I have videos and pics if desired, which show the dramatic change in spray pattern and flow.
I even used to soak my plugs and cause an injector and spark to be disabled periodically, until I took my new nozzles and corrected.


--

2008 335i Convertible, E93, N54, A/T (200,000+ km)
Wheels: 322 | Tires: R.275/35r18, F.245/40r18
TUNE: JB4/Trebila | 24 PSI | 100% Meth via dual BM5 | 94 Octane
BMS: JB4, Map 6 | WMI | 5" FMIC | OCC | DCI | Cowel Filters
TMAP: 3.5 barr
xHP Stage 3 (v2.0)
VRSF CP | HKS BOV
RB PCV Valve
NGK 5992 Plugs @ .020

Maintenance:
2018 - A/T Replaced | Plugs | Ign Coils | Walnut Blasting
2019 - Index 12 Injectors | VCG | OFHG & O-rings | Alternator w/ Clutch Pulley | Water Pump & TStat
Reply With Quote
(#22)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 12-13-2019, 09:36 PM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Check your lines / nozzle first. I went back & looked at one of your prior logs, doesnít look like any settings are different. But thereís definitely an issue..letís make sure physically it isnít something first.

The meth low code imo is whatís triggering the o2/ trims maxing trying to add fuel
Alright, so it turns out I had a leak in between where the line locks into the Tee fitting(bottom side of tee). About 80% was leaking out and there was barely any spraying into the chargepipe. That explains why it goes limp lol.

It seems the fitting itself is failing. Cutting a bit of the line and and inserting it back into the fitting doesnt work. I'll be emailing the vendor I bought it from soon.

Also, I got codes 2A2C and 29E1 followed by misfires on cylinders 4, 5, and 6. The misfires could be due a leak from the vcg that seeps into the area that has progressively gotten worse the last couple weeks. Had a misfire on cyl 5 a month ago, changed all 6 plugs and plug 5 had oil. Then replaced the injector a few days later when the same misfire persisted.

I get a very rough idle that goes away but sometimes comes back while cruising and the car starts to shake. I can delete the codes and SES light but comes back a couple minutes later.

Problem after problem after problem. Hopefully when I change it out itll go away lol.
Reply With Quote
(#23)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 12-13-2019, 10:30 PM

Get the leak fixed- that’ll solve a big chunk of the issues

What index injectors do you have ?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#24)
Old
chonchy123 chonchy123 is offline
New Member
 
Posts: 25
Join Date: May 2019
Car: 2009 BMW 135i
Default 12-13-2019, 10:39 PM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Get the leak fixed- thatíll solve a big chunk of the issues

What index injectors do you have ?
I have index 12's. I'll be diving into the engine tomorrow. I'll keep you updated. I'm crossing my fingers most of the issues will be solved.
Reply With Quote
(#25)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,423
Join Date: Apr 2014
Car: E92 335XI
Default 12-14-2019, 09:48 AM

Sounds good! Fingers crossed



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com