N54Tech.com - International Turbo Racing Discussion
(#1)
Old
acrhalo's Avatar
acrhalo acrhalo is offline
Junior Member
 
Posts: 33
Join Date: Jan 2017
Car: 2017 BMW 440i MPPK
Default B58 MHD Back End Flash Failure and FIX - 12-01-2019, 04:02 PM

OK, so I just wanted to share my experience with flashing the back end on my B58 440i for the first time, the highs and the lows... lol

So, I started it last night. My car has been sitting in the garage for about a month now because I don’t drive it in the snow. I have a CTEK trickle charger for my car but it wasn’t hooked up yet. I had purchased the BMS OBDII Cable with Micro USB, because I had a bad experience with a cheap cable. DON'T WASTE YOUR MONEY. BUY the BMS Cable, your flashing a BMW don’t be cheap! I learned the hard way, lol. So, I'm an Apple guy... To do this flash I had to buy my first Android product (A Samsung Galaxy Tab E). I'll use it in the garage...
So, I read the instructions from MHD, and Terry, clearly rushing, because I missed some steps... I plugged in the tablet and immediately connected to the DME, purchased the MHD flash software ($249), and started flashing my car! Thinking this was going to be easy... The flash went all the way to 88% and then stalled... No errors, it just froze... So, I restarted the tablet and tried to reflash the software again 3-4 times with no luck... Now my car wouldn’t start and every error under the sun was showing on the dash... The radio wouldn’t work, and a ticking sound was coming under the hood from the DME... The kind of ticking noise you get right before she blows... lol
Thankfully I've played with the JB4 for a while, so full panic never really set in. Now the RESERCH. I started reading everything... I immediately plugged in my trickle charger and realized the battery was not above 80%, a lot of people said this was a MUST. I AGREE! I also realized at this time that when I switched the JB4 to MAP 0, that I did not have the OBDII plugged in. I had the cable plugged into my tablet at the time. So, I plugged the JB4 OBDII cable in and flashed the map to 0 correctly. I tried numerous times to flash the DME back to stock or to Stage0 with no success... I also was connected but it always froze, I never received any errors. It would just never get to 100%. I even disconnected the battery multiple time to try and reset the DME. My final thoughts were that the battery just wasn’t charged enough. So, I left the charger for the night and the battery unplugged. Next day... Everything I read said it could possibly be a bad cable, and check the connections. I was fairly confident that my cable was good because it was connecting (I did have a spare as well). However, I unplugged it and plugged it in a few times and really pushed to make sure it was seated correctly. My battery was now above 80% so I attempted again. The first 2 times I had the same kind of failures. This 3rd time I tried changing some of the options that MHD allows you to choose, to make sure it was a fresh copy being downloaded. This time it went to 100%, and the car was perfect again! Thank GOD! As I was cleaning up, I could not remove the OBDII plug? WTF... I noticed that there was a clip in the end that snaps in to make sure that the OBDII is seated correctly. When I pushed it tight I clearly connected it correctly (possibly a reason for the failed flash...).

SUMMERIZE:
Flash froze with no errors. Would not reach 100%

Possible reasons for failure:
Battery not above 80%, and Not plugged in!
JB4 improperly set back to MAP 0?
OBDII Cable not properly seated in connector?

STRONG ADVICE:
Read FULLY the MHD directions, and Terry's instructions on N54Tech before starting. When loading the software folly Terry's direction.
Plug battery in first! Confirm it is above 80% or fully charged.
Don't buy a cheap cord, I only would recommend the BMS Cord or Bimmergeeks OBDII approved cord.
Make sure the cord is seated correctly.
Start the flash with the MHD tuning software on your Android device. Don't use some cheap device with Android software on it. I stuck with Samsung, and was successful with the tablet.
Before starting your vehicle make sure to update your JB4 software and switch (future use d) bit 6 ON.
Wait 30 seconds, start your beast, and enjoy...

Good luck, don't panic, and have fun!
Reply With Quote
(#2)
Old
Payam @ BMS's Avatar
Payam @ BMS Payam @ BMS is offline
Super Moderator
 
Posts: 5,436
Join Date: Oct 2013
Car: e90 335i
Default 12-02-2019, 12:30 PM

Thanks for the tips!


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com