N54Tech.com - International Turbo Racing Discussion
(#1)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default Need some help with Lean Condition - 06-16-2018, 07:31 PM

I keep getting a lean safety with my JB4, but no codes thrown. I've tried resetting adaptations, running map 2 with and without backend flash. I set JB4 to default settings for Menu 10,11,12 today, and when I started to get on it I threw code 30FE (first and only time got SES) Reset and tried again, leaned out but no code. Log below any help would be greatly appreciated!

Setup, JB4, FBO, 93 backend flash, alpina flash, 93 V-power gas. I have done a vacuum leak test and it held 27in with JB4 menu 10 at 5k. Plugs and coils have about 25k on them and Injectors have about 35k on them. My wastegates do rattle a fair amount, but boost seemed fine up until lean conditions.

Im replacing the coils and plugs Tuesday, while also looking around for any signs of boost leak. Anything else that I should be doing or thinking of?

If you want me to try for another log I can.
Attached Files
File Type: csv 2018-06-06 16_36_22.csv (15.1 KB, 25 views)
Reply With Quote
(#2)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 967
Join Date: Jun 2011
Car: 135i N54
Default 06-17-2018, 07:21 AM

Your bank 2 fuel trims are maxing out (bank 1 is also near max) and causing bank 2 to go super lean. Surprised it threw safety 2 and not safety 5. It seemed to correct itself after the map 4 switch. the FOL value is already at max so there may be an issue. Fuel pressures look fine, so maybe O2 sensor? The Fuel-It @ BMS guys could probably help you more with that.

The slow boosting is probably a different issue.
Reply With Quote
(#3)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 25,609
Join Date: Jan 2008
Default 06-17-2018, 09:09 AM

Any codes stored?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#4)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 06-17-2018, 04:52 PM

Quote:
Originally Posted by Terry @ BMS
Any codes stored?
I checked and there was code 3100
Reply With Quote
(#5)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 06-18-2018, 03:24 PM

I replaced Injectors, plugs, and coils today. Plugs 1 and 3 were wet with gas, and the 5th injector was pretty junked up. I reset the lamda adaptations after coding and took her for a spin. She felt good, I logged two runs but still got lean conditions. I'll check for stored codes when I get home. How do these runs look?
Attached Files
File Type: csv 2018-06-18 18_00_20.csv (15.2 KB, 8 views)
File Type: csv 2018-06-18 18_03_23.csv (16.2 KB, 11 views)
Reply With Quote
(#6)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 967
Join Date: Jun 2011
Car: 135i N54
Default 06-18-2018, 03:53 PM

You are still going lean on bank 2, with bank fuel trims maxed out. Sorry I'm not really sure what would cause the big variance it in this case. Maybe O2 sensor(s)? Would be rare, but maybe a boost leak from intake manifold or somewhere affecting one bank more? Might explain the slow spool. Are you running the BMS flash or a custom one?
Reply With Quote
(#7)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 06-18-2018, 03:56 PM

I'm running mhd 93 flash. I still get lean conditions running jb4 alone though.
Reply With Quote
(#8)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 967
Join Date: Jun 2011
Car: 135i N54
Default 06-18-2018, 04:03 PM

Was just thinking, did you check the vac line from the manifold to the DVs? It is separate from the main vac system.
Reply With Quote
(#9)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 06-18-2018, 06:00 PM

Quote:
Originally Posted by Vorsprung_CJB
Was just thinking, did you check the vac line from the manifold to the DVs? It is separate from the main vac system.
Its funny you said that, when doing the work today, I notice oil collecting between cly 5 and 6, and it looks like the Crankcase Breather Blow-By Vent is leaking from the seal. I pulled it off and saw a white flapper in there and tried blowing and sucking (keep it clean lol) to see if the flapper worked and it remained open...is that normal. I have the upgraded RB metal PCV valve and cover and I looked all around the valve cover for any signs of cracks or oil leaks and there was nothing.

I did pull codes and nothing was found under fault, but under shadow faults I got the following;

2fa3
29f5
29f4
2fca
2fda
30ff
2fdb

Last edited by BMWHartgeM3; 06-18-2018 at 06:07 PM..
Reply With Quote
(#10)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 06-20-2018, 07:03 PM

Been driving the car around with JB4 disabled after resetting the adaptations and no check engine lights yet. Seems to be running smooth and strong, but I did a couple of back to back hot starts during work today and I got some smoke while driving off for the first minute or two of driving??

Am I right about the crankcase breather vent valve flap inside broken where I could get it to close with my lungs when I had it pulled out?
Reply With Quote
(#11)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 07-11-2018, 05:30 PM

Update...Did a downshift from 4th to 3rd and didn't have the lean issue during the pull, I attached a log and WDGC seems to be a roller coaster. Any suggestions?
Attached Files
File Type: csv 2018-07-11 20_08_58.csv (6.1 KB, 7 views)
Reply With Quote
(#12)
Old
Payam @ BMS's Avatar
Payam @ BMS Payam @ BMS is offline
Super Moderator
 
Posts: 3,864
Join Date: Oct 2013
Car: e90 335i
Default 07-12-2018, 02:32 PM

The log looks okay to me, the only thing would be to set your open loop to 0. Your trims are way down and pretty rich instead of lean in this latest log. What fuel and BEF are you using?
Attached Images
 


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#13)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 07-12-2018, 02:38 PM

I only run Shell 93 Vpower, and I'm running the pump flash from bimmerboost. That run was normal because I down shifted from 4th to 3rd. If I do a 3-4 pull I always get lean, and I usually hit around 18psi boost.
Reply With Quote
(#14)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 07-12-2018, 07:22 PM

Set Open loop to zero did two runs, the first run I got on it from second and rolled right through to 4th and seemed to run fine, did a 3rd gear pull from 2k and ran lean again?? IDK how it can run fine except when pulling a 3rd gear run. I updated JB4 to 32/12 the latest version then did both runs. Attached both logs for comparison. I checked my FF adaptation after the runs and it adjusted to 150
Attached Files
File Type: csv first_run.csv (11.0 KB, 9 views)
File Type: csv second_run.csv (6.6 KB, 7 views)
Reply With Quote
(#15)
Old
Dave @ Fuel-it!'s Avatar
Dave @ Fuel-it! Dave @ Fuel-it! is offline
Minor Diety
 
Posts: 2,208
Join Date: Apr 2014
Car: E92 335XI
Default 07-12-2018, 11:35 PM

Quote:
Originally Posted by BMWHartgeM3
Set Open loop to zero did two runs, the first run I got on it from second and rolled right through to 4th and seemed to run fine, did a 3rd gear pull from 2k and ran lean again?? IDK how it can run fine except when pulling a 3rd gear run. I updated JB4 to 32/12 the latest version then did both runs. Attached both logs for comparison. I checked my FF adaptation after the runs and it adjusted to 150
FF is maxed - id look for a possible boost / vac leak somewhere

Try resetting your o2 adaptations too.



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#16)
Old
BMWHartgeM3 BMWHartgeM3 is offline
New Member
 
Posts: 12
Join Date: May 2018
Car: e90 N54 335i
Default 07-31-2018, 02:05 PM

Did a boost leak test, found loose lines to oil catch can and oil cap was bleeding a lot of air?? Tightened up lines, and ordered new cap. Ran test again holding down oil cap and everything seemed to hold tight. Replaced fuel pressure regulator since it was leaking, then reset adaptations, still running lean on bank 2. To help narrow it down, It only runs lean on bank 2 under load. If I play with my throttle and get in to it then back off and slowly get back into it she seems to run on the richer side, around 10.8?? Does anything else jump out to anyone?

Also did a rescan for codes and found
29E1 fuel mixture control 2
29E0 fuel mixture control
2C7E Lambda probe behind ***, Trimming control
2C2B Lambda probe in front of *** system control

Last edited by BMWHartgeM3; 07-31-2018 at 06:11 PM..
Reply With Quote
(#17)
Old
Dave @ Fuel-it!'s Avatar
Dave @ Fuel-it! Dave @ Fuel-it! is offline
Minor Diety
 
Posts: 2,208
Join Date: Apr 2014
Car: E92 335XI
Default 07-31-2018, 11:04 PM

Quote:
Originally Posted by BMWHartgeM3
Did a boost leak test, found loose lines to oil catch can and oil cap was bleeding a lot of air?? Tightened up lines, and ordered new cap. Ran test again holding down oil cap and everything seemed to hold tight. Replaced fuel pressure regulator since it was leaking, then reset adaptations, still running lean on bank 2. To help narrow it down, It only runs lean on bank 2 under load. If I play with my throttle and get in to it then back off and slowly get back into it she seems to run on the richer side, around 10.8?? Does anything else jump out to anyone?

Also did a rescan for codes and found
29E1 fuel mixture control 2
29E0 fuel mixture control
2C7E Lambda probe behind ***, Trimming control
2C2B Lambda probe in front of *** system control
A log will help.

But generally- any time Trims max either negative or positive you can throw trimming / mixture codes.



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com