N54Tech.com - International Turbo Racing Discussion
(#1)
Old
BoostinBrian BoostinBrian is offline
New Member
 
Posts: 2
Join Date: Aug 2017
Car: 09 335
Default Car wonít run properly after removing JB4? - 04-21-2018, 07:37 AM

Need help.

Decided to remove my jb4 from my 09 335.

Removed it, no issue. Went to get gas, all good. Started car a few hours later and didnít even make it off my street - surging rpm, no throttle response, dash lit up like crazy. Touch the throttle and nothing would happen.

Double checked all the wiring, looked fine. Checked codes and there were three or four saying throttle body jammed etc. Checked that, looked fine. Started it again, same issue.

Decided to reinstall jb4 just now. Fired it up and it runs better. Notnghreat, but it seems atleast kinda driveable.
What the hell is going on?? Do I need to reset adaptations?? Iíve had the battery unplugged all night. Gonna go start it soon and see how it runs.
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 04-21-2018, 03:12 PM

Turn on accessories, put pedal to the floor for 30 seconds, turn off car for 10 seconds, restart and see if issue goes away.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
BoostinBrian BoostinBrian is offline
New Member
 
Posts: 2
Join Date: Aug 2017
Car: 09 335
Default 04-21-2018, 03:25 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Turn on accessories, put pedal to the floor for 30 seconds, turn off car for 10 seconds, restart and see if issue goes away.


Thanks. With it back installed I went it and reset adaptations and did the gas pedal thing. Car seems to be fine now. Iíll try it again next week after removing it. Thanks!!
Reply With Quote
(#4)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 8,476
Join Date: Apr 2014
Car: E92 335XI
Default 04-22-2018, 09:18 PM

Quote:
Originally Posted by BoostinBrian
Thanks. With it back installed I went it and reset adaptations and did the gas pedal thing. Car seems to be fine now. Iíll try it again next week after removing it. Thanks!!


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com