N54Tech.com - International Turbo Racing Discussion
(#51)
Old
JB4Kat's Avatar
JB4Kat JB4Kat is offline
New Member
 
Posts: 6
Join Date: Apr 2021
Car: E92 335i
Default 04-04-2021, 01:07 PM

Quote:
Originally Posted by lnxmad
I flashed v12.. will report back. I do see v14+ have made changes to 2step/NLS making relay not required.. I do have relay still installed.. not sure if that is related. Looking for a pattern here.
Could you please share the v12 file? I want to roll back to v12 as well, thank you!
Reply With Quote
(#52)
Old
lnxmad lnxmad is offline
New Member
 
Posts: 10
Join Date: Apr 2014
Car: 335xi
Default 04-04-2021, 01:45 PM

Quote:
Originally Posted by airwalker2662
Found it. Just a little backwards engineering to get the 12 firmware from the site. Here is the link: https://s3.us-east-2.amazonaws.com/j..._32_12_T10.hex
It's linked a few posts back
Reply With Quote
(#53)
Old
JB4Kat's Avatar
JB4Kat JB4Kat is offline
New Member
 
Posts: 6
Join Date: Apr 2021
Car: E92 335i
Default 04-04-2021, 01:49 PM

Quote:
Originally Posted by lnxmad
It's linked a few posts back
Oh I saw that, but it doesnít work, every time i click on it, it sends me to a blank page, thatís why I asked, maybe I have to check it on pc, thank you!
Reply With Quote
(#54)
Old
hav's Avatar
hav hav is offline
New Member
 
Posts: 6
Join Date: Jan 2021
Car: E60 535i xDrive
Default 04-11-2021, 11:09 AM

Quote:
Originally Posted by JB4Kat
Well yes please! I updated my jb4 firmware to the latest one a few months ago, since then, my car started throwing low battery codes especially 2DED, as of yesterday, she really freaked me out since itís the first time I saw this error code: 2AB4-DME, internal error, have you ever got this message? And could it mean that my DME is shot? (Hopefully not)
Thank you!

I've never gotten a 2AB4 error, but these cars are known to throw spurious codes when the battery voltage gets low. I'd just clear it out and make sure your battery is fully charged.



Quote:
Originally Posted by lnxmad
I flashed v12.. will report back. I do see v14+ have made changes to 2step/NLS making relay not required.. I do have relay still installed.. not sure if that is related. Looking for a pattern here.

I have an automatic trans so no 2step/NLS installed - so that's definitely not a common thread between our cars nor is it what's causing the drain issue for me.
Reply With Quote
(#55)
Old
hav's Avatar
hav hav is offline
New Member
 
Posts: 6
Join Date: Jan 2021
Car: E60 535i xDrive
Default 04-15-2021, 11:46 AM

I made some progress narrowing this down and I'm hoping some of you other guys (and gals) with this issue can confirm my findings.

I disabled gauge hijacking completely (menu 2 -> 0 and menu 7 -> 0) and left the .14 firmware on my car and I went 5 full days without getting a battery drain warning, checking the car multiple times each day. I then re-enabled gauge hijacking yesterday and both times I started the car after letting it sit for several hours I got the battery drain warning and dreaded 2DED code.

Can a few of you who keep getting low battery warnings also disable gauge hijacking to see if the warnings stop?

Why did I try this? This weekend I backed the car into the garage after a short trip and then shut it off completely by pressing the "Start/Stop" button twice. Even though everything on the dash was dark, I noticed the IAT gauge jump slightly before I got out of the car. I thought I might have imagined it so I sat there for a few minutes and saw it move again. This made me wonder if the JB4 was staying awake and constantly updating the gauges even with the car off.

Some background on my setup: I run boost on fuel (menu 2 -> 1) and IAT on oil (menu 7 -> 3), and this shows the IAT on the MPG gauge since the E60 5-series doesn't have an oil temp gauge in the dash. It's also worth mentioning that I DON'T use stealth gauge mode - my gauges always show boost and IAT regardless of pedal input.
Reply With Quote
(#56)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 33,772
Join Date: Jan 2008
Default 04-16-2021, 09:18 AM

Interesting, might be something to that. I'll look in to it further.

Email me a current log from your car too terry@burgertuning.com


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#57)
Old
lnxmad lnxmad is offline
New Member
 
Posts: 10
Join Date: Apr 2014
Car: 335xi
Default 04-18-2021, 11:56 AM

Great find Hav! I will test this out as I currently have gauge hijack enabled. I can confirm 2-3 weeks on v12 I still have a good battery.
Reply With Quote
(#58)
Old
dmckmc dmckmc is offline
Junior Member
 
Posts: 258
Join Date: Oct 2017
Car: E60 535i
Default 04-24-2021, 05:35 PM

Confirming battery drain with gauge hijack on E60 535i. I don't normally hijack gauges but was curious and experimenting with boost on MPG (oil temp on non 5 series). Left it enabled and parked it approximately 24 hrs. Started car and high battery drain warning light was on. I'm charging the battery now and disabled hijacking. Will follow up.


N54
FBO
E40
JB4
MHD
XHP
Reply With Quote
(#59)
Old
THE BEAST THE BEAST is offline
Demigod
 
Posts: 1,629
Join Date: Apr 2016
Car: 2008 E93
Default 04-24-2021, 07:21 PM

Its crazy how its been almost 2 years now
Reply With Quote
(#60)
Old
RadarContact's Avatar
RadarContact RadarContact is offline
Junior Member
 
Posts: 424
Join Date: Sep 2016
Car: 2010 E60/535i AT ó FBO+WMI
Default 04-24-2021, 08:21 PM

I only hijack Meth on my e60.


--------------------------------------------------------------
2010 535i M-Sport w/Sport AT/6-spd xHP Stage3, Alpine White w/Natural Leather, APEX EC-7 race wheels w/ST Coilovers --- JB4 G5 ISO Trebila (Map-6/BEF) Custom Tune, Custom Meth Setup (link) 25/75%, VRSF 3" free-flow D/Ps, MMPe DCIs, Wagner 1060 Stepped FMIC, VRSF Chargepipe/Tial BOV w/BMS Vac adapter, BMS Oil Cooler Valve
Reply With Quote
(#61)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 33,772
Join Date: Jan 2008
Default 04-27-2021, 11:36 AM

Posted new BETA firmware that seems to have helped with this bug in v15. Load it up and let me know!


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#62)
Old
lnxmad lnxmad is offline
New Member
 
Posts: 10
Join Date: Apr 2014
Car: 335xi
Default 04-27-2021, 09:15 PM

Flashed back to 15 and disabled gauge hijack..no battery drain. Thanks Terry for investigating..I'll flash the beta asap and report back.
Reply With Quote
(#63)
Old
Maximum996's Avatar
Maximum996 Maximum996 is offline
Junior Member
 
Posts: 158
Join Date: Aug 2012
Car: 08 535xi
Default 05-01-2021, 04:52 AM

Quote:
Originally Posted by Terry @ BMS
Posted new BETA firmware that seems to have helped with this bug in v15. Load it up and let me know!
Yes, this seems to have eliminated that high battery drain problem!


08 535Xi - jb4 iso w/mhd flash, Bms dci, AR ********* DP, er cp with forge dv, second *** delete, muffler delete, xhp trans flash, ets fmic, bms oil tstat bypass.
Reply With Quote
(#64)
Old
hav's Avatar
hav hav is offline
New Member
 
Posts: 6
Join Date: Jan 2021
Car: E60 535i xDrive
Default 05-08-2021, 09:43 AM

I've had the new firmware loaded in my car for 2 full weeks and haven't gotten a single battery drain warning. I've let the car sit several days without being started a few times and I'm confident this issue is resolved.

Terry - thanks for taking a look and releasing a fix!
Reply With Quote
(#65)
Old
rickz96 rickz96 is offline
Junior Member
 
Posts: 73
Join Date: Nov 2011
Car: e60 535Xi
Default 05-10-2021, 05:13 AM

This is crazy - I don't know how I missed this thread! I've been chasing this battery drain issue for over a year. I've replaced waterpumps, oil level sensors, traced wires for shorts, replaced IBS sensor.

I'm uploading v15 now and will report back.
Reply With Quote
(#66)
Old
rickz96 rickz96 is offline
Junior Member
 
Posts: 73
Join Date: Nov 2011
Car: e60 535Xi
Default 05-11-2021, 05:32 AM

Quote:
Originally Posted by rickz96
This is crazy - I don't know how I missed this thread! I've been chasing this battery drain issue for over a year. I've replaced waterpumps, oil level sensors, traced wires for shorts, replaced IBS sensor.

I'm uploading v15 now and will report back.

Hi guys, so not sure if I downloaded the right version (installed G5_ISO_32_15_T1), but it did not solve my high battery drain issue with gauge hijack running. Once I turned off gauge hijacking for fuel and mpg (oil); only then did the high battery drain issue go away.

I see the firmware page has been updated as of yesterday. Is there a new version to try?
Reply With Quote
(#67)
Old
hav's Avatar
hav hav is offline
New Member
 
Posts: 6
Join Date: Jan 2021
Car: E60 535i xDrive
Default 05-19-2021, 08:26 PM

Quote:
Originally Posted by rickz96
Hi guys, so not sure if I downloaded the right version (installed G5_ISO_32_15_T1), but it did not solve my high battery drain issue with gauge hijack running. Once I turned off gauge hijacking for fuel and mpg (oil); only then did the high battery drain issue go away.

I see the firmware page has been updated as of yesterday. Is there a new version to try?
The build that fixed the issue for me is G5_ISO_32_16_T6.hex - it's listed on the site as a beta build.

I was still getting battery drain warnings with G5_ISO_32_15_T1 and gauge hijacking enabled but I've been golden after loading the T6 beta!
Reply With Quote
(#68)
Old
RadarContact's Avatar
RadarContact RadarContact is offline
Junior Member
 
Posts: 424
Join Date: Sep 2016
Car: 2010 E60/535i AT ó FBO+WMI
Default 07-21-2021, 05:23 AM

I updated to 16 and STARTED getting the high drain AGAIN…
Problem is, I don’t remember which version I was using prior to updating this time. That version was working for me.
I use gauge hijacking on my 535i only for Meth on the fuel gauge. I don’t need it (I have it chosen on my JB4 display as well). Maybe I’ll try turning that off.

Very frustrating as I’m scared to use my ventilation timers (setting my blowers to run outside air through the car 15 min before I get out of work — lifesaver during Florida summers) due to my battery always reporting low.

// Radar //


--------------------------------------------------------------
2010 535i M-Sport w/Sport AT/6-spd xHP Stage3, Alpine White w/Natural Leather, APEX EC-7 race wheels w/ST Coilovers --- JB4 G5 ISO Trebila (Map-6/BEF) Custom Tune, Custom Meth Setup (link) 25/75%, VRSF 3" free-flow D/Ps, MMPe DCIs, Wagner 1060 Stepped FMIC, VRSF Chargepipe/Tial BOV w/BMS Vac adapter, BMS Oil Cooler Valve
Reply With Quote
(#69)
Old
RadarContact's Avatar
RadarContact RadarContact is offline
Junior Member
 
Posts: 424
Join Date: Sep 2016
Car: 2010 E60/535i AT ó FBO+WMI
Default 07-21-2021, 05:25 AM

Quote:
Originally Posted by dmckmc
Confirming battery drain with gauge hijack on E60 535i. I don't normally hijack gauges but was curious and experimenting with boost on MPG (oil temp on non 5 series). Left it enabled and parked it approximately 24 hrs. Started car and high battery drain warning light was on. I'm charging the battery now and disabled hijacking. Will follow up.
Update?


--------------------------------------------------------------
2010 535i M-Sport w/Sport AT/6-spd xHP Stage3, Alpine White w/Natural Leather, APEX EC-7 race wheels w/ST Coilovers --- JB4 G5 ISO Trebila (Map-6/BEF) Custom Tune, Custom Meth Setup (link) 25/75%, VRSF 3" free-flow D/Ps, MMPe DCIs, Wagner 1060 Stepped FMIC, VRSF Chargepipe/Tial BOV w/BMS Vac adapter, BMS Oil Cooler Valve
Reply With Quote
(#70)
Old
dmckmc dmckmc is offline
Junior Member
 
Posts: 258
Join Date: Oct 2017
Car: E60 535i
Default 07-21-2021, 06:23 AM

Quote:
Originally Posted by RadarContact
Update?

still had trouble, reverted to V. 14 no problems


N54
FBO
E40
JB4
MHD
XHP
Reply With Quote
(#71)
Old
RadarContact's Avatar
RadarContact RadarContact is offline
Junior Member
 
Posts: 424
Join Date: Sep 2016
Car: 2010 E60/535i AT ó FBO+WMI
Default 07-21-2021, 02:34 PM

Quote:
Originally Posted by dmckmc
still had trouble, reverted to V. 14 no problems
Okay, think Iíll try v14 as well. Thanks.

Just gotta figure out where to get that version from the forumÖ


--------------------------------------------------------------
2010 535i M-Sport w/Sport AT/6-spd xHP Stage3, Alpine White w/Natural Leather, APEX EC-7 race wheels w/ST Coilovers --- JB4 G5 ISO Trebila (Map-6/BEF) Custom Tune, Custom Meth Setup (link) 25/75%, VRSF 3" free-flow D/Ps, MMPe DCIs, Wagner 1060 Stepped FMIC, VRSF Chargepipe/Tial BOV w/BMS Vac adapter, BMS Oil Cooler Valve
Reply With Quote
(#72)
Old
SamJ SamJ is offline
Junior Member
 
Posts: 87
Join Date: Dec 2015
Car: BMW 335i
Default 08-26-2021, 11:08 PM

I’ve been having battery drain issues for a year now as well

I’m glad I popped in here to check before I started pulling fuses

So “ The build that fixed the issue for me is G5_ISO_32_16_T6.hex - it's listed on the site as a beta build. ” is the fix or have people had to revert back to v 14?

Last edited by SamJ; 08-26-2021 at 11:13 PM..
Reply With Quote
(#73)
Old
RadarContact's Avatar
RadarContact RadarContact is offline
Junior Member
 
Posts: 424
Join Date: Sep 2016
Car: 2010 E60/535i AT ó FBO+WMI
Default 09-21-2021, 03:20 PM

Quote:
Originally Posted by SamJ
Iíve been having battery drain issues for a year now as well

Iím glad I popped in here to check before I started pulling fuses

So ď The build that fixed the issue for me is G5_ISO_32_16_T6.hex - it's listed on the site as a beta build. Ē is the fix or have people had to revert back to v 14?
I had to go back to v14, and it worked like a champ. Iím never updating again, ever ever ever again.

*Iíve spent years (?) fighting with the battery drain issue. I completely rewired my radar detector because of it. I completely rewired my backup camera because of it. I rewired my tablet power source because of it. Nothing worked. Had no idea that it could have been the JB4, but it was.


--------------------------------------------------------------
2010 535i M-Sport w/Sport AT/6-spd xHP Stage3, Alpine White w/Natural Leather, APEX EC-7 race wheels w/ST Coilovers --- JB4 G5 ISO Trebila (Map-6/BEF) Custom Tune, Custom Meth Setup (link) 25/75%, VRSF 3" free-flow D/Ps, MMPe DCIs, Wagner 1060 Stepped FMIC, VRSF Chargepipe/Tial BOV w/BMS Vac adapter, BMS Oil Cooler Valve
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com