N54Tech.com - International Turbo Racing Discussion
(#1)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default Erratic Boost - PLEASE HELP - 03-18-2021, 02:37 PM

Hi all!

I'm having really weird boost issues with my 08' E90 335i (Auto) and this one has me confused. Mods: JB4 G5 ISO, DCI MAP 5 on 93 Octane

My boost problems started after after a valve cleaning. The valves were spotless when I was finished but once I took it out for a test drive it boost was sluggish and I was consistently only hitting 12 psi max on map 5 when I normally hit 15 psi with 93 Octane. I found that if I switch maps and then switch back to map 5 again I'll see 15 psi again for one or two pulls but then it will incrementally boost down to 12 again.

Fast forward a year later, on a drive home from work I noticed my car is suddenly having issues building more than 5 psi. I'm assuming a big boost leak this time but find nothing. I'm at 110K on the original boost solenoids and found that this could be the cause of my symptoms. I switch them out and notice a HUGE difference. Now I'm seeing 17 psi on map 5 with 93 Octane (usually only see this with E40 mix). Everything seemed fixed. My next test drive I see that the boost is all over the place. On one pull I'll see only 9 psi, the next pull (seconds later) it will be back up to 15+. Then a couple pulls later it's very sluggish and only hitting 9 and then back up again. Once it was so high (18 psi) I get kicked back to map 4. The car just seems unresponsive at partial throttle, even when it's boosting well at WOT.

It's raining today so I'm unable to pull any logs but hopefully I'll be able to post them tomorrow. Has anyone experienced this issue before? Are my solenoids defective (non-OEM)? WG worn out? Is there an issue with the board itself (I understand that can be an issue with the earlier JB4s)

Thanks in advance for any advice you guys can offer. This forum has always been a wealth of information!
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 19,267
Join Date: Oct 2012
Car: 135i
Default 03-19-2021, 10:07 AM

Hi,

Once you upload a log I'll take a look at it.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default 03-19-2021, 03:45 PM

Today the car ran terrible! Extremely slow boost response and only maxing around 7 psi on map 5, with a target of 15+.

Attached are the logs from those 3 pulls.
Attached Files
File Type: csv 210319_1722.csv (6.3 KB, 18 views)
File Type: csv 210319_1724.csv (9.7 KB, 19 views)
File Type: csv 210319_1727.csv (9.2 KB, 16 views)
Reply With Quote
(#4)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default 03-21-2021, 04:58 PM

Started up the car to move out of the garage this morning and it developed a bad misfire (car shaking) just idling for about 30 seconds. CEL came on showing two codes: 2E18 (Ign. Cyl. 1), 29CD (Misfire Cyl. 1).

I just replaced the coil on this cylinder days ago and the plugs only have around 5K miles on them.

Any idea what else to check? Could this somehow be related to my boosting issue?

Last edited by SilverN54; 03-22-2021 at 11:18 AM..
Reply With Quote
(#5)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 19,267
Join Date: Oct 2012
Car: 135i
Default 03-22-2021, 11:10 AM

First step, if you have a G5 board...you need to update your firmware. You are running extremely old firmware. Not so sure that's related but that'd be the first step.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#6)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default 03-22-2021, 11:19 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Hi,

Once you upload a log I'll take a look at it.
Thanks Steve! I uploaded a few logs, let me know what you think.
Reply With Quote
(#7)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 19,267
Join Date: Oct 2012
Car: 135i
Default 03-23-2021, 09:45 AM

Quote:
Originally Posted by SilverN54
Thanks Steve! I uploaded a few logs, let me know what you think.
See my previous post.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#8)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default 04-12-2021, 06:04 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
See my previous post.
Hi Steve,

Sorry I missed your previous post and that it's taken me so long to follow up (work has me super busy).

I updated to the latest firmware today and did 3 pulls. No change in performance and the boost is incredibly laggy. Should I put my G4 board back in and see what happens?
Attached Files
File Type: csv Pull 1.csv (14.4 KB, 11 views)
File Type: csv Pull 2.csv (12.9 KB, 12 views)
File Type: csv Pull 3.csv (13.3 KB, 12 views)
Reply With Quote
(#9)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 19,267
Join Date: Oct 2012
Car: 135i
Default 04-13-2021, 08:07 AM

Something isn't right....did you verify/make the necessary changes to the wiring harness when switching from the G4 to G5 board?

N54Tech.com - International Turbo Racing Discussion - View Single Post - Jb4 G5 Harness Diy



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#10)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default 04-13-2021, 01:51 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Something isn't right....did you verify/make the necessary changes to the wiring harness when switching from the G4 to G5 board?

N54Tech.com - International Turbo Racing Discussion - View Single Post - Jb4 G5 Harness Diy
I switched over to the G5 board when it first came out so it's been running great on G5 for many years. This boost issue just arose out of nowhere and I thought I had it fixed with the new solenoids...but obviously not.

Any chance the new solenoids are bad? (Got them from ECS Tuning)
Reply With Quote
(#11)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default 04-13-2021, 04:29 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Something isn't right....did you verify/make the necessary changes to the wiring harness when switching from the G4 to G5 board?

N54Tech.com - International Turbo Racing Discussion - View Single Post - Jb4 G5 Harness Diy
Another strange observation is that I never get any codes, no 30FF, no CEL, no stored codes, etc. This makes me wonder if it's an electronic fault. If I'm able to find my old G4 board I may just throw it in there to see what happens.
Reply With Quote
(#12)
Old
SilverN54 SilverN54 is offline
New Member
 
Posts: 8
Join Date: Mar 2021
Car: E90 335i
Default 04-20-2021, 10:29 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Something isn't right....did you verify/make the necessary changes to the wiring harness when switching from the G4 to G5 board?

N54Tech.com - International Turbo Racing Discussion - View Single Post - Jb4 G5 Harness Diy
Update - I found my old G4 board and reinstalled it but no improvement. It struggles to build any boost at all. I can clearly hear the turbos spooling so besides a boost leak do you have any other ideas of what could be causing this?
Reply With Quote
(#13)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 19,267
Join Date: Oct 2012
Car: 135i
Default 04-21-2021, 10:41 AM

You've ruled out the JB4 so it's likely a hardware issue of some sort. Sorry, can't really help you with that as it'll require you popping the hood.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com