N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Stevie Stevie is offline
Junior Member
 
Posts: 49
Join Date: Feb 2016
Car: 2008 BMW 535XI
Default Injector problem haaallllpppp - 10-22-2016, 10:36 AM

Well I finally got around to checking on my injectors... and let's just say I indeed have a leaky injector. But please watch the video and provide any insight. Appears the number 6 port is deformed.... hope this isn't the issue https://youtu.be/NAjlBWIPd38
Reply With Quote
(#2)
Old
Impac's Avatar
Impac Impac is offline
Junior Member
 
Posts: 194
Join Date: Jan 2014
Car: 2008 BMW 535i
Default 10-22-2016, 10:57 AM

Take the fuel rail off, pull out the injector make sure the rubber seal and the decoupling element are on correctly and reinstall it, just make sure once you pull it out you reinstall it quickly within 30sec so that the rubber seal dont expend, but since it looks like its out of place anyway you might need a new seal


JB4 G5, DCI, Er CP with HKS Bov, VRSF DP's, BB Race flash
Reply With Quote
(#3)
Old
Stevie Stevie is offline
Junior Member
 
Posts: 49
Join Date: Feb 2016
Car: 2008 BMW 535XI
Default 10-22-2016, 12:53 PM

I've got new seals so I could try that again.. decouplers are installed correctly.. this was me swapping number 1 and number 6 injector to see if the problem replicated. Number 1 injector was seated perfectly fine (which is why I used number 2 in the video) I as long thought it was 10mins to get the injector installed?..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com