N54Tech.com - International Turbo Racing Discussion
(#1951)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-16-2015, 11:09 PM

Quote:
Originally Posted by Nugs
Downloaded the update and the issue of it randomly disconnecting is still there, in fact it rarely stays connected for more than a few minutes.

So far I have
-checked the connection of the usb cable with the JB4
-used two different lighter to USB adapters, and tried both of the lighter positions (armrest and ashtray).
Issue still happens.
Any tips on what I could try troubleshooting next?
Thanks.
At this point you'll need to test it on another device if you have access to one.

Quote:
Originally Posted by volcom8190
can we get a checkbox to disable the warning after the first notice
Quote:
Originally Posted by prelude2perfect
X2. I don't want to disable my wifi everytime I get into my car and it would be nice to just open the app and go
I actually debated adding that in before I submitted it to the App Store. I mean if you just REALLY don't want to turn wifi off, I'll add a toggle in the settings page on the next version. Expect the next version in 2-4 weeks.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1952)
Old
Dirty Dog's Avatar
Dirty Dog Dirty Dog is offline
Junior Member
 
Posts: 224
Join Date: Jan 2011
Car: 135i
Default 03-16-2015, 11:29 PM

Downloaded the latest version of the App on my Iphone 6 plus running the latest Apple iOS software and noticed that the Ignition gauge gets frozen on a set number until you press throttle. Tap the throttle and it changes to a different ignition degree and stays there. The Ignition value use to jump all over the place on previous version which I think is how it's suppose to be on the N54. Engine type is N54 E series.


135i - JB4 15ohm l Mr 5 Intake l AA C@tless ********* l ETS Intercooler l BMS Methanol Injection l Berk Tech Mids l Berk Tech Axleback l BMS OCC l ER CP l Turbosmart BOV's. SOLD

335i DCT - JB4 G5 ISO l AA C@tless ********* l ETS Intercooler l Custom Intake l Meth l BMS E85 Flash l BMS OCC l ER CP l Walbro 255 l Turbosmart BOV's. CURRENT
(#1953)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-16-2015, 11:30 PM

Quote:
Originally Posted by Dirty Dog
Downloaded the latest version of the App on my Iphone 6 plus running the latest Apple iOS software and noticed that the Ignition gauge gets frozen on a set number until you press throttle. Tap the throttle and it changes to a different ignition degree and stays there. The Ignition value use to jump all over the place on previous version which I think is how it's suppose to be on the N54. Engine type is N54 E series.
Are you either:

A) On map 0
B) Looking at Ign 2-6


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1954)
Old
135isuff 135isuff is offline
Junior Member
 
Posts: 58
Join Date: Nov 2014
Car: 135i
Default 03-18-2015, 06:12 PM

do u have the jb4 connect bluetooth kit for android in stock?
(#1955)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-18-2015, 06:14 PM

Quote:
Originally Posted by 135isuff
do u have the jb4 connect bluetooth kit for android in stock?
I have a few left for now. Check the website for details.

Click Here!


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1956)
Old
Ddang06 Ddang06 is offline
Junior Member
 
Posts: 118
Join Date: Nov 2012
Car: 335i coupe 6MT
Default 03-19-2015, 03:12 PM

Every time I launch the app I have to clear device history , it doesn't auto connect for some reason ? I had freezing using the app on my iPad mini , but deleting the app and downloading it again solved that issue .
(#1957)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-19-2015, 03:13 PM

Quote:
Originally Posted by Ddang06
Every time I launch the app I have to clear device history , it doesn't auto connect for some reason ? I had freezing using the app on my iPad mini , but deleting the app and downloading it again solved that issue .
Please give me all of the info as requested in the first post.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1958)
Old
Spxxx's Avatar
Spxxx Spxxx is offline
Senior Member
 
Posts: 711
Join Date: Mar 2014
Car: E92 335i
Default 03-20-2015, 08:36 PM

Note 4
n54 e series
jb4 firmware for backend mhd flash

App will occasionally connext but usually gives me a serial port not available error.any testing done with the new firmware?


M-Sport 135i - N54 - FBO - E60 - Mfactory LSD - MHD - JB4 - SPX Tuned
(#1959)
Old
The Die's Avatar
The Die The Die is offline
Junior Member
 
Posts: 6
Join Date: Aug 2013
Car: 2010 335 Xi
Default 03-21-2015, 01:12 PM

I'm showing them as out of stock. Any ETA on a restock?


-Greg
2010 335xi 6AT | Black Sapphire Metallic | Black Dakota Leather | Alpina B3 Flash | BB Open Flash | JB4 | BMS DCI | Tons more to come...

Live in Central Ohio? Looking to have some coding done? Shoot me a PM.
(#1960)
Old
Spxxx's Avatar
Spxxx Spxxx is offline
Senior Member
 
Posts: 711
Join Date: Mar 2014
Car: E92 335i
Default 03-22-2015, 03:47 PM

Quote:
Originally Posted by Spxxx
Note 4
n54 e series
jb4 firmware for backend mhd flash

App will occasionally connext but usually gives me a serial port not available error.any testing done with the new firmware?
Connects to my windows version as I had to flash the firmware a few times... Mobile app is the version causing issues


M-Sport 135i - N54 - FBO - E60 - Mfactory LSD - MHD - JB4 - SPX Tuned
(#1961)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-22-2015, 04:00 PM

Quote:
Originally Posted by Spxxx
Note 4
n54 e series
jb4 firmware for backend mhd flash

App will occasionally connext but usually gives me a serial port not available error.any testing done with the new firmware?
1) What's different about the JB4 firmware for use with MHD? That shouldn't make a difference at all.

2) These serial port not available issues are virtually always either a poor quality OTG cable or an issue with the user's device. You see that error because the OS is telling my app that it doesn't see a serial port.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1962)
Old
Spxxx's Avatar
Spxxx Spxxx is offline
Senior Member
 
Posts: 711
Join Date: Mar 2014
Car: E92 335i
Default 03-22-2015, 04:05 PM

Quote:
Originally Posted by dmacpro91
1) What's different about the JB4 firmware for use with MHD? That shouldn't make a difference at all.

2) These serial port not available issues are virtually always either a poor quality OTG cable or an issue with the user's device. You see that error because the OS is telling my app that it doesn't see a serial port.
The flash firmware allows for fully passiveness of the jb4 for running standalone flash tunes or for using just the jb for gauges. Terre said there is no difference in the way the jb connects to the software (I thought he responded in this thread but I don't see his post anymore)

Tried 3 different otg cables and examined the jb4 USB wire for issues and all checked the board for bad connections to the USB port.

The device recognizes that there is an otg cable plugged in and the otg cable works fine when flashing through the MHD app from my same phone.


M-Sport 135i - N54 - FBO - E60 - Mfactory LSD - MHD - JB4 - SPX Tuned
(#1963)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-22-2015, 04:23 PM

Quote:
Originally Posted by Spxxx
The flash firmware allows for fully passiveness of the jb4 for running standalone flash tunes or for using just the jb for gauges. Terre said there is no difference in the way the jb connects to the software (I thought he responded in this thread but I don't see his post anymore)

Tried 3 different otg cables and examined the jb4 USB wire for issues and all checked the board for bad connections to the USB port.

The device recognizes that there is an otg cable plugged in and the otg cable works fine when flashing through the MHD app from my same phone.
Well apparently FTDI just recently released an update for their D2XX driver (http://www.ftdichip.com/Drivers/D2XX.htm). I'll include that in the next update and we'll see if that fixes anything.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1964)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-22-2015, 08:23 PM

Quote:
Originally Posted by Spxxx
The flash firmware allows for fully passiveness of the jb4 for running standalone flash tunes or for using just the jb for gauges. Terre said there is no difference in the way the jb connects to the software (I thought he responded in this thread but I don't see his post anymore)

Tried 3 different otg cables and examined the jb4 USB wire for issues and all checked the board for bad connections to the USB port.

The device recognizes that there is an otg cable plugged in and the otg cable works fine when flashing through the MHD app from my same phone.
Just saw your posts on the other thread. So are you saying that you're now having trouble connecting to the Windows interface as well?


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1965)
Old
Spxxx's Avatar
Spxxx Spxxx is offline
Senior Member
 
Posts: 711
Join Date: Mar 2014
Car: E92 335i
Default 03-22-2015, 08:25 PM

Yep, disregard my earlier comments... It was a hardware issue.


M-Sport 135i - N54 - FBO - E60 - Mfactory LSD - MHD - JB4 - SPX Tuned
(#1966)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-22-2015, 08:28 PM

Quote:
Originally Posted by Spxxx
Yep, disregard my earlier comments... It was a hardware issue.
Thanks, that confirmed my suspicions. I'll provide a better error message so people can try to better diagnose these issues themselves. Let me know when you get your new JB4 data cable.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1967)
Old
135isuff 135isuff is offline
Junior Member
 
Posts: 58
Join Date: Nov 2014
Car: 135i
Default 03-23-2015, 07:23 AM

Hi DMAC, was about to order your bluetooth kit but says out of stock, but on this thread it says in stock and that stock status would be listed here. I know answering this question must b annoyin but if you could please I want to order it but be nice to get it soon
(#1968)
Old
The Die's Avatar
The Die The Die is offline
Junior Member
 
Posts: 6
Join Date: Aug 2013
Car: 2010 335 Xi
Default 03-23-2015, 07:31 AM

Quote:
Originally Posted by 135isuff
Hi DMAC, was about to order your bluetooth kit but says out of stock, but on this thread it says in stock and that stock status would be listed here. I know answering this question must b annoyin but if you could please I want to order it but be nice to get it soon
Same here!


-Greg
2010 335xi 6AT | Black Sapphire Metallic | Black Dakota Leather | Alpina B3 Flash | BB Open Flash | JB4 | BMS DCI | Tons more to come...

Live in Central Ohio? Looking to have some coding done? Shoot me a PM.
(#1969)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-23-2015, 10:14 AM

Quote:
Originally Posted by 135isuff
Hi DMAC, was about to order your bluetooth kit but says out of stock, but on this thread it says in stock and that stock status would be listed here. I know answering this question must b annoyin but if you could please I want to order it but be nice to get it soon
Quote:
Originally Posted by The Die
Same here!
Sold the last ones while I was asleep. I'll update this thread when I receive more parts. Sorry guys!


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1970)
Old
prelude2perfect's Avatar
prelude2perfect prelude2perfect is offline
Junior Member
 
Posts: 448
Join Date: Sep 2010
Car: '07 335i
Default 03-23-2015, 11:40 AM

Device: Iphone 5s
OS: 8.1.2
Engine type: N54 E Series
App build: not sure where to find this but the app version is 2.1
Problem experienced: Sometimes when I open the app it will give me a message stating something about it not being able to find my saved bluetooth device. It's a simple fix by going in to settings and clearing the saved device so it can relearn it and works fine afterwards. It happens maybe once every 25 connects or so.


'07 E90 MT Sports Package l FBO l RB Next Gen Plus l JB4 G5 with DPT E85 BEF l N20 MAP Sensor l MMP Inlets l RB Outlets l Custom Exhaust l NLS & 2-Step l MFactory 3.46 LSD l 335is Clutch with MFactory SMFW l Walbro 450 l Direct Port Meth Injection

Best 1/4 ET: 11.4
Best 1.4 Trap: 127.7
(#1971)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-23-2015, 11:45 AM

Quote:
Originally Posted by prelude2perfect
Device: Iphone 5s
OS: 8.1.2
Engine type: N54 E Series
App build: not sure where to find this but the app version is 2.1
Problem experienced: Sometimes when I open the app it will give me a message stating something about it not being able to find my saved bluetooth device. It's a simple fix by going in to settings and clearing the saved device so it can relearn it and works fine afterwards. It happens maybe once every 25 connects or so.
Strange that you're experiencing that on 8.1.2. The way Apple handles the UUIDs for bluetooth devices means an app never sees the actual mac address. The UUIDs for these devices are *supposed* to be static inside each app, but it looks like that functionality isn't working properly. I'm going to be posting an update soon to address this. Basically in the next update, if it can't find your saved device, it will ask you if you want to connect to the nearest one. If you click yes, it will connect and that will be your new saved device.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1972)
Old
Peter @ Pure's Avatar
Peter @ Pure Peter @ Pure is offline
Demigod
 
Posts: 1,688
Join Date: Aug 2013
Car: F20 M135i
Default 03-23-2015, 12:02 PM

FYI I had that can't connect to saved device as well 1st time today. IOS 8.1.2 with latest JB4 mobile.


F21 M140i - 100-200: 5.18 60-130: 5.96
Audi TTRS - 100-200: 4.01 60-130: 4.5
F80 M3 - 100-200: 4.32, 60-130: 4.8
F20 M135i (sold) - 100-200: 6.26 , 60-130: 7.4
peter@pureturbos.eu
peter@pureturbos.com
peter@protuningfreaks.com
pureturbos.eu
(#1973)
Old
ba114's Avatar
ba114 ba114 is offline
Junior Member
 
Posts: 232
Join Date: Jul 2014
Car: 135i 6MT
Default 03-23-2015, 10:43 PM

Quote:
Originally Posted by dmacpro91
iOS or Android? Also, the 0-60 capability seems to be much less accurate on Android. I'm actually debating removing the feature entirely. Ideally if we could get the speed reading through the JB4 (on the other engine types not just the N54), we could have quite accurate 0-60 timing. The GPS refresh rate on mobile devices just isn't that great. I still want to look into some Bluetooth GPS devices, but that has been low on my priority list lately.
Couldnt you force users to set FUD = '4' they want to use timing features?
Would presumably be able to offer a whole wealth of other timing features then too such as 60-130 etc.

Only see this causing issues when users dont get traction.
(#1974)
Old
ac305 ac305 is offline
Junior Member
 
Posts: 61
Join Date: Jan 2015
Car: 435i
Default 03-24-2015, 07:17 AM

Hi guys,

Could use some insight. I read the following codes yesterday from the JB4 mobile app:

102001 - Air Mass, plausibility -- tuner code, ignore
102A22 - No Description found

I sent them in to the BMS guys and they were unable to identify the codes, presumably due to the numbering convention used by the App. It appears that fault code numbering is standardized. The way are presented above by the mobile app does not align with that convention and I unfortunately don't have a BT cable.

Any idea what these codes translate to? As background, I had a Map 4 switch due to running lean (temporarily increased the failsafe running E85) and decided to see if there were any codes. I only spotted these after 'reading codes' immediately after a long pull. Shortly after, codes were gone (presumably erased by the JB4) and car ran fine after failsafe was lowered back down. Can I ignore these codes? The boards seem to indicate that codes that go away are not indicative of a real problem.
(#1975)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 03-24-2015, 11:49 AM

Quote:
Originally Posted by ac305
Hi guys,

Could use some insight. I read the following codes yesterday from the JB4 mobile app:

102001 - Air Mass, plausibility -- tuner code, ignore
102A22 - No Description found

I sent them in to the BMS guys and they were unable to identify the codes, presumably due to the numbering convention used by the App. It appears that fault code numbering is standardized. The way are presented above by the mobile app does not align with that convention and I unfortunately don't have a BT cable.

Any idea what these codes translate to? As background, I had a Map 4 switch due to running lean (temporarily increased the failsafe running E85) and decided to see if there were any codes. I only spotted these after 'reading codes' immediately after a long pull. Shortly after, codes were gone (presumably erased by the JB4) and car ran fine after failsafe was lowered back down. Can I ignore these codes? The boards seem to indicate that codes that go away are not indicative of a real problem.
Please refer to the first post for info regarding support requests.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com