N54Tech.com - International Turbo Racing Discussion
(#3051)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default Opinion? - 05-22-2020, 10:37 PM

Finally, I think the car is working fine, still I would like the AFR to be in the 11s since PI should be working or is it? how do I know if the secondary pump and injector are working? I am using the yellow wire coming out of the PI controller (12v, 2 amp) as the trigger so I hope that should activate the pump. Can you look at the logs and give me any advise ?
Attached Files
File Type: csv 20200522_235139_runs(1).csv (12.4 KB, 112 views)
File Type: csv 20200522_235310_runs(1).csv (14.2 KB, 112 views)


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#3052)
Old
stennyboy stennyboy is offline
New Member
 
Posts: 3
Join Date: Jun 2020
Car: 335i
Default 06-03-2020, 12:17 PM

Hey everyone,

Iím trying to make sure that I have all of the settings correct on a car that I recently purchased. 2008 335i with single turbo 6266. It has JB4 with MHD back end, I reflashed the firmware as well as the MHD to make sure the correct tunes were installed. I also went through on the forums and set everything up the same as what is listed in the general setup of a single turbo car. Everything seems to work great, I just installed the 8.7 psi wastegate springs, and was able to verify that on Map 2 I am getting right at 16.5ish psi at WOT. I have been reading quite a bit to make sure I understand the logging process and what the different parameters mean, and the only thing I am unsure of is the WGDC and FF.

When I look back at logs, my WGDC stays at 0 always until I start to make boost and sometimes it will come up to 8 or 10, the most Iíve ever seen is like 26. From what I read on the forums, it should be at 100 until I reach 75% of my targeted boost, because I have the DWP set at 75. The car runs great but seems to lag a bit down low. I assume maybe it lags because of the single turbo, but I wanted to make sure that I donít have something setup incorrectly. I have verified the solenoid is clicking when the car is off ignition on, and also verified that the solenoid plumbing to the wastegates is correct.
Attached Files
File Type: csv Map2smallerWG_1241.csv (48.1 KB, 96 views)
Reply With Quote
(#3053)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default 06-03-2020, 12:58 PM

post a log when the car is doing about 16 PSI till 7k RPM. I would suggest increase the wastegates spring pressure.


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#3054)
Old
stennyboy stennyboy is offline
New Member
 
Posts: 3
Join Date: Jun 2020
Car: 335i
Default 06-03-2020, 03:07 PM

Quote:
Originally Posted by albertc
post a log when the car is doing about 16 PSI till 7k RPM. I would suggest increase the wastegates spring pressure.

Attached logs of map 2 as well as map 3. I'm not sure what you mean by increasing wastegate spring pressure? If I need more boost I can move up to 4 port solenoid. Not looking to make a ton of boost as I'm on pump gas still.
Attached Files
File Type: csv Map2_6-3-20_1643.csv (12.4 KB, 97 views)
File Type: csv Map3_6-3-20_1649.csv (13.1 KB, 94 views)
Reply With Quote
(#3055)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default 06-03-2020, 06:02 PM

Open the waste gates and increase the spring pressure. I have it at 12 PSI. That could be why map 3 didnt reach its target.


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#3056)
Old
stennyboy stennyboy is offline
New Member
 
Posts: 3
Join Date: Jun 2020
Car: 335i
Default 06-04-2020, 04:59 AM

Quote:
Originally Posted by albertc
Open the waste gates and increase the spring pressure. I have it at 12 PSI. That could be why map 3 didnt reach its target.
I figured it out. FF setting was too low, got it dialed in now and making 20 psi real nice.
Reply With Quote
(#3057)
Old
The915 The915 is offline
New Member
 
Posts: 4
Join Date: Apr 2020
Car: 07 E92
Default What am I doing wrong????? - 06-06-2020, 09:27 AM

Please any advice or help would help. Thanks in advance.
Attached Files
File Type: csv 2019-10-25 14_15_56_Gear-3_Map-2.csv (44.2 KB, 93 views)
Reply With Quote
(#3058)
Old
2many335i 2many335i is offline
New Member
 
Posts: 6
Join Date: Dec 2017
Car: 4 335i
Default Any suggestions? - 06-07-2020, 05:22 PM

Have been working on this for a few weeks, now st/pi/e85. Just added 2x hellcats/radium hanger/an-8 to split an-6. Any help would be great before I grenade this motor.
Attached Files
File Type: csv P30_M6_R1_v6_Fw_136_200607_154259.csv (29.3 KB, 90 views)
File Type: csv P30_M6_R1_v6_Fw_136_200607_154416.csv (23.4 KB, 88 views)


2010 450whp, 499trq for sale
2008 single turbo on the way
Reply With Quote
(#3059)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default 06-07-2020, 05:50 PM

Quote:
Originally Posted by 2many335i
Have been working on this for a few weeks, now st/pi/e85. Just added 2x hellcats/radium hanger/an-8 to split an-6. Any help would be great before I grenade this motor.
I dont understand why the boost target is all over the place, everything else seems ok


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#3060)
Old
2many335i 2many335i is offline
New Member
 
Posts: 6
Join Date: Dec 2017
Car: 4 335i
Default 06-07-2020, 08:01 PM

Quote:
Originally Posted by albertc
I dont understand why the boost target is all over the place, everything else seems ok
That's how the target is in the jb4. I did get a fuel rail pressure sensor signal code 29e2, I am wondering if the base pressure is set too low or if I need to replace the sensor.


2010 450whp, 499trq for sale
2008 single turbo on the way
Reply With Quote
(#3061)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default 06-07-2020, 09:56 PM

The target in my car is flat all the way across the log, and yours isn't, download my logs at the beginning of this page (not the tread )


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#3062)
Old
Phat135's Avatar
Phat135 Phat135 is offline
New Member
 
Posts: 11
Join Date: May 2020
Car: 2012 135i
Default 06-21-2020, 04:26 AM

Hello all, Currently installing a s363 Speedtech Stage 3 external wastegate kit in my 2012 135i. It will be on PI aswell. I’m actually very skeptical about how tuning works with these cars. I currently have mhd installed. Jb4 is in box with a incorrect harness type. I am located in the NorCal area and need ideas to continue. Thanks!
Reply With Quote
(#3063)
Old
rkreimer10 rkreimer10 is offline
Senior Member
 
Posts: 557
Join Date: Feb 2017
Car: 08 535i
Default 06-21-2020, 10:03 AM

Hey all,

I am about to do my first jb4 only single turbo set up. So far all my customers have gone with MHD custom tunes. Maybe I will finally learn to like the jb4. haha

It is just a very simple set up to run on pump gas....

-on3 turbo kit w/ on3 turbo *compressor tapped for boost*
-44mm tial with BLK/BLU 11.60psi springs
-3 port MAC solenoid
-stepped intercooler *oem connections*
-VRSF CP w/hks
-pump gas *stock fuel system*
-high side catch can *VTA*
-jb4 already installed....

I am trying to update the firmware for the jb4 for this single set up, but am having issues seeing any of the firmware files on the iphone.... I am going to try to load them manually from my laptop, but wanted to ask what firmware should I start with.

Once the car is running and logs look ok, I will be installing 2step & anti-lag to the jb4, but I want to get it running properly first.

What firmware would you guys recommend to start????

EDIT*** I am going to start with the 138 file that is listed on the bottom of the first post ***

EDIT EDIT*** I have also never changed any values on a jb4 before so any insight on changing dutybias is appreciated, but I am sure it will be easy to figure out. ***

Last edited by rkreimer10; 06-21-2020 at 10:20 AM..
Reply With Quote
(#3064)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default 06-21-2020, 01:10 PM

Quote:
Originally Posted by rkreimer10
Hey all,

I am about to do my first jb4 only single turbo set up. So far all my customers have gone with MHD custom tunes. Maybe I will finally learn to like the jb4. haha

It is just a very simple set up to run on pump gas....

-on3 turbo kit w/ on3 turbo *compressor tapped for boost*
-44mm tial with BLK/BLU 11.60psi springs
-3 port MAC solenoid
-stepped intercooler *oem connections*
-VRSF CP w/hks
-pump gas *stock fuel system*
-high side catch can *VTA*
-jb4 already installed....

I am trying to update the firmware for the jb4 for this single set up, but am having issues seeing any of the firmware files on the iphone.... I am going to try to load them manually from my laptop, but wanted to ask what firmware should I start with.

Once the car is running and logs look ok, I will be installing 2step & anti-lag to the jb4, but I want to get it running properly first.

What firmware would you guys recommend to start????

EDIT*** I am going to start with the 138 file that is listed on the bottom of the first post ***

EDIT EDIT*** I have also never changed any values on a jb4 before so any insight on changing dutybias is appreciated, but I am sure it will be easy to figure out. ***
From the iPhone app it is literally the firmware #30


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#3065)
Old
rkreimer10 rkreimer10 is offline
Senior Member
 
Posts: 557
Join Date: Feb 2017
Car: 08 535i
Default 06-21-2020, 02:26 PM

Quote:
Originally Posted by albertc
From the iPhone app it is literally the firmware #30
The the phone won't download them or show them once connected. So I will have to manually load it to the phone.

But my question onw is which is the best hex file to start with.

Firmware #30 shows:
N54_G5_MAC_136_T4.hex.

The last hex file on the first page shows:
N54_G5_MAC_138.hex

With all the different hex files, what's the best file to use?

136_T4.hex or 138.hex ?
Reply With Quote
(#3066)
Old
rkreimer10 rkreimer10 is offline
Senior Member
 
Posts: 557
Join Date: Feb 2017
Car: 08 535i
Default 06-21-2020, 02:46 PM

It was connectivity issue with data. Got it to download via the #30 firmware. Now onto set up!
Reply With Quote
(#3067)
Old
rkreimer10 rkreimer10 is offline
Senior Member
 
Posts: 557
Join Date: Feb 2017
Car: 08 535i
Default 06-23-2020, 10:28 PM

Map 1 hit wastegate pressure just fine....

Here is a log in map 2. Boost only made 13.6psi, can anyone take a look at the log. Or should I post the logs somewhere else?
Attached Files
File Type: csv P30_M2_R1_200623_143709.csv (27.0 KB, 82 views)
Reply With Quote
(#3068)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default 06-26-2020, 10:05 AM

Quote:
Originally Posted by rkreimer10
Map 1 hit wastegate pressure just fine....

Here is a log in map 2. Boost only made 13.6psi, can anyone take a look at the log. Or should I post the logs somewhere else?
something happened when the car went from 2nd to 3rd. Check in the app what was the "last safety". Remember you may have to do a few pulls until redline to reach the boost target (JB4 has to learn), make sure the Tracontrol is all the way off.


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#3069)
Old
ncat10 ncat10 is offline
Junior Member
 
Posts: 104
Join Date: May 2012
Car: 335
Default 07-11-2020, 02:34 PM

For all DCT ST owners, XHP has released stage 3 map for 7th speed DCT tranny. So far only E-series have been supported. Today I flashed my car and looks very impressive. They made super fast shifting, Torque limit was increased to 1000nm, improved DSC operation.
https://www.youtube.com/watch?v=qb4W...ature=youtu.be


335I | ST PTE6266GEN2 FFTEC | DCT flashed by XHP Stage3 and upgraded Dodson SSP clutch + Oil pan| X2 oil coolers | tranny cooler | B16 ride control | JB4 + MHD Bef (tuned by Trebilla) | LB Performance | WMI | QUAIFE LSD | Carbon-Ceramic brakes | Akrapovic SlipOn Titanium | Reduced weight flywheel | Synapse BOV | AMS Intercooler | Walbro LPF |
Reply With Quote
(#3070)
Old
Straightboostin Straightboostin is offline
New Member
 
Posts: 1
Join Date: Jul 2020
Car: 2007 335i
Default Set up questions and log review - 07-13-2020, 06:40 PM

Hi guys, hoping to get some feed back on my logs to see if I have everything set up right on the jb4 settings. Also when when I use the anti lag the car hits boost and takes off hard but then drops boost for
a sec then picks back up again. Is there a way to correct this little delay and you can see the dip in the log. Here is a brief mod list, doc race kit with a precision 6466, vrsf 7" IC, bkc intake with PI running 550cc injectors, spool stage 3 pump. Running a jb4 with pi controller and custom mhd back end flash. Also is there any way to increase spool but adjusting the settings in the jb4. Thanks,
Attached Files
File Type: csv 6466 ANTI 1.csv (8.9 KB, 50 views)
File Type: csv 6466 run 14.csv (6.0 KB, 57 views)
File Type: csv 200410_1730.csv (11.2 KB, 57 views)
Reply With Quote
(#3071)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,560
Join Date: Jan 2008
Default 07-14-2020, 03:03 PM

Quote:
Originally Posted by Straightboostin
Hi guys, hoping to get some feed back on my logs to see if I have everything set up right on the jb4 settings. Also when when I use the anti lag the car hits boost and takes off hard but then drops boost for
a sec then picks back up again. Is there a way to correct this little delay and you can see the dip in the log. Here is a brief mod list, doc race kit with a precision 6466, vrsf 7" IC, bkc intake with PI running 550cc injectors, spool stage 3 pump. Running a jb4 with pi controller and custom mhd back end flash. Also is there any way to increase spool but adjusting the settings in the jb4. Thanks,
There is always going to be a small delay when engaging anti-lag to getting full boost so you'll want to time that a bit, let off at the 2nd honk for example.

On boost response could try raising DWP to 80 to see if that gets it spooled up faster.
Attached Images
 


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3072)
Old
MRC-5.56's Avatar
MRC-5.56 MRC-5.56 is online now
New Member
 
Posts: 28
Join Date: Sep 2017
Car: future 335i
Default 07-29-2020, 07:22 AM

Terry,
I went to update my ST firmware via phone app and noticed that the newest FW is N54_G5_MAC_139. I dont see that one listed on the first page of this thread. Are there any significant difference between that FW and 138
Reply With Quote
(#3073)
Old
chawoja06 chawoja06 is offline
New Member
 
Posts: 1
Join Date: Aug 2020
Car: 2010 335xi
Default 08-10-2020, 11:13 AM

Hi, new speedtech ST with GTX3582R gen 2, spool is slow, im assuming due to wastegate opening before hitting target. Not sure where to start with settings in JB4, or if mapping is needed. Thanks for any help!
Attached Files
File Type: csv 3rd gear pull.csv (7.8 KB, 39 views)
File Type: csv 200808_1940.csv (18.2 KB, 37 views)

Last edited by chawoja06; 08-10-2020 at 01:52 PM..
Reply With Quote
(#3074)
Old
mattdrake27 mattdrake27 is offline
New Member
 
Posts: 7
Join Date: Mar 2016
Car: 2008 335i FBO
Default 4 Port MAC boost control - 08-11-2020, 10:19 AM

Hello Terry. I'm seeking some help getting a 4 port MAC solenoid to smoothly control boost. I purchased it from your website last week. Is there any firmware or anything that I need for the 4 port MAC? Log is attached. Thanks in advance.
Attached Files
File Type: csv P30_M5_R1_200811_072147.csv (11.1 KB, 35 views)

Last edited by mattdrake27; 08-11-2020 at 10:29 AM..
Reply With Quote
(#3075)
Old
mattdrake27 mattdrake27 is offline
New Member
 
Posts: 7
Join Date: Mar 2016
Car: 2008 335i FBO
Default 08-11-2020, 11:44 AM

Quote:
Originally Posted by chawoja06
Hi, new speedtech ST with GTX3582R gen 2, spool is slow, im assuming due to wastegate opening before hitting target. Not sure where to start with settings in JB4, or if mapping is needed. Thanks for any help!
I'd try putting DWP to 75 per the default settings on page one. See it that helps. Your gate is opening at 40% of boost target because you have 40 there.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com