N54Tech.com - International Turbo Racing Discussion
(#4751)
Old
Klpaleo Klpaleo is offline
New Member
 
Posts: 9
Join Date: Apr 2019
Car: Honda Accord EXL 1.5 Turbo
Default 08-31-2019, 10:13 AM

I had bought and used the app in my iPhone
Now I changed device to an Android phone and want to re install the app but I don't see how to do this without paying again

Please advise
Reply With Quote
(#4752)
Old
rf30a rf30a is offline
Junior Member
 
Posts: 35
Join Date: Sep 2015
Car: F30 328ix/C300 W205
Default 09-04-2019, 06:17 PM

[QUOTE=Dmac @ BMS/DMD;643564]On iOS or Android? Are you on the latest firmware?]

iOS running latest jb4 firmware.
Reply With Quote
(#4753)
Old
maddog maddog is offline
New Member
 
Posts: 6
Join Date: Sep 2019
Car: 2014 BMW F30 N20 328i
Default would love to see many of these features - 09-10-2019, 05:40 AM

Quote:
Originally Posted by k1kote
Hi, I have several recommendations and good things to implement that could be useful, I hope it's the right thread to post this.

-User Adjustment in the 2nd tab
-The gauges show the highest and/or lowest values ​​reached, example:
*Maximum temperature reached
*IAT minimum temperature reached
-In the case of Boost that shows the frozen Boost peak for 1 second
-Add the variables of "cylinder timing correction" and "misfire count" that can be seen in the VW using the Polarfis, mainly to see them in the log
-More themes and especially one of needles more sober than "Needle Fill"
-The shift light has to be yellow very visible, not red
-To be able to see the logs in metric unit (km/h and C°)
-Programmable visual and audible alerts, example:
*In AFR if the target is 12, outside 11.5 and 12.5 of a visual and/or audible alert only if the X% pedal is
*In Water Temp and Oil Temp above X temperature the gauge appears with a red background
-A map for safe driving that loads no more than 7 psi
-When you leave a log, be selected to know which one you left
-When save changes in User Adjustment the legend that the changes were saved does not appear above the tabs
-Support different languages, I would like Spanish
-Bug: when you are in the list of choosing which variable to see in a gauge, but you go back without choosing a different one, it does not return to the gauges but it shows the Display tab selected but shows the Settings
I would really love to see many of these features (possibly where we can add gauges and set our own min and max settings)

I would also like to see the traditional pressure gauge that measures pressure in the manifold, instead of just positive boost.

Lastly, i noticed that the gear gauge only goes up to 6 for me (i have the 8 speed auto). I recently bought my Jb4 and recently applied the latest firmware.

PS. I really love the convenience of the app. I have an aftermarket Android touchscreen (that replaces the original BMW screen) and i'm using the USB cable to it. It works pretty well (although on rare occasion, i get an error about invalid map selection on app startup)..

********************************
**2014 BMW F30 N20 328i EWG ***
********************************
Reply With Quote
(#4754)
Old
maddog maddog is offline
New Member
 
Posts: 6
Join Date: Sep 2019
Car: 2014 BMW F30 N20 328i
Default 09-10-2019, 11:05 AM

Quote:
Originally Posted by maddog
I would really love to see many of these features (possibly where we can add gauges and set our own min and max settings)

I would also like to see the traditional pressure gauge that measures pressure in the manifold, instead of just positive boost.

Lastly, i noticed that the gear gauge only goes up to 6 for me (i have the 8 speed auto). I recently bought my Jb4 and recently applied the latest firmware.

PS. I really love the convenience of the app. I have an aftermarket Android touchscreen (that replaces the original BMW screen) and i'm using the USB cable to it. It works pretty well (although on rare occasion, i get an error about invalid map selection on app startup)..

********************************
**2014 BMW F30 N20 328i EWG ***
********************************
I attached a pic of my screen with the app
Attached Images
 


*******************************
** 2014 BMW F30 N20 328i EWG **
** JB4 **
*****************************

Last edited by maddog; 09-10-2019 at 11:27 AM.. Reason: Attached pic
Reply With Quote
(#4755)
Old
aliiaki aliiaki is offline
New Member
 
Posts: 1
Join Date: Sep 2019
Car: 2018 rs5
Default 09-20-2019, 05:05 PM

Jb4 Second buddies android but not my Apple. Any quick resolutions to be visible on Bluetooth
Reply With Quote
(#4756)
Old
nextNME's Avatar
nextNME nextNME is offline
Junior Member
 
Posts: 33
Join Date: Jan 2016
Car: 2008 535xi
Default 09-26-2019, 06:14 PM

First time JB4 Mobile user, long time JB4 user... so far I love the app. Auto-log WOT is my favorite. How many log files can/will be stored total?

Randomly on startup the App says the User Settings are corrupt, asks Set Values To Last Saved... not sure why it would be doing that only sometimes? I use JB4 Map1. I have lowered Pid Gain to 15. About 1 week ago I reset the value for FF/Wastegate Adaptation... other than that I pretty much leave settings alone.

I notice that there are only two options for gauge themes? Default (text only) vs. Needle Fill (yellow on blue gauges). I see some examples/tutorials showing a simple black/grey gauge face with white text, surrounded by red or green graduations - is that theme also available?

Only thing is, when I have my sunglasses on, and the tablet sittingin landscape... the polarization of the lenses messes with the screen and I can't see a thing on the tablet. So strange


2008 535xi. BMS DCI. OCC. JB4. MHD BEF. XHP. NGK. BR14.
Reply With Quote
(#4757)
Old
Sean the Mick Sean the Mick is offline
New Member
 
Posts: 5
Join Date: Sep 2019
Car: Q60
Default Help - Firmware update freeze? - 09-30-2019, 05:50 PM

Hey all... noob post, searched and couldn't find this particular problem.. guess I'm special..

Just hooked up unit, try to install the firmware update and just gets stuck on this screen (pic in post) that gives you the option to UPDATE or CANCEL.

Nothing happens when I click update. It's an iPhone ... (please no...there's your first problem jokes from Samsung guys lol )

Thanks in advance
Attached Images
 
Reply With Quote
(#4758)
Old
maddog maddog is offline
New Member
 
Posts: 6
Join Date: Sep 2019
Car: 2014 BMW F30 N20 328i
Default 09-30-2019, 09:39 PM

Quote:
Originally Posted by Sean the Mick
Hey all... noob post, searched and couldn't find this particular problem.. guess I'm special..

Just hooked up unit, try to install the firmware update and just gets stuck on this screen (pic in post) that gives you the option to UPDATE or CANCEL.

Nothing happens when I click update. It's an iPhone ... (please no...there's your first problem jokes from Samsung guys lol )

Thanks in advance
Silly question, did the app establish connection to the JB4 before you tried to update?


*******************************
** 2014 BMW F30 N20 328i EWG **
** JB4 **
*****************************
Reply With Quote
(#4759)
Old
Nordic335IM3's Avatar
Nordic335IM3 Nordic335IM3 is offline
Junior Member
 
Posts: 254
Join Date: Nov 2014
Car: BMW 335I N54
Default JB4 mobile - 10-01-2019, 03:46 AM

anybody else notice delayed needle sweep when starting up ?


E92 N54 2007 (kline)
mods:ER CP + TIAL BOV , MMP IN & OUTlets, BMS CM10 with Ethanol , JB4 mhd BEF(race) , pipesdown + no cats, 5" stepped wagner FMIC , 0.5 mm NGK 95770
öhlins shocks & springs , M3 swaybar front, PCV: Misimoto Ext RB blocked ports lowside , Solid Diff Brace, 20" wheels,android HU,
Reply With Quote
(#4760)
Old
maddog maddog is offline
New Member
 
Posts: 6
Join Date: Sep 2019
Car: 2014 BMW F30 N20 328i
Default 10-01-2019, 04:33 AM

Quote:
Originally Posted by nextNME
First time JB4 Mobile user, long time JB4 user... so far I love the app. Auto-log WOT is my favorite. How many log files can/will be stored total?

Randomly on startup the App says the User Settings are corrupt, asks Set Values To Last Saved... not sure why it would be doing that only sometimes? I use JB4 Map1. I have lowered Pid Gain to 15. About 1 week ago I reset the value for FF/Wastegate Adaptation... other than that I pretty much leave settings alone.

I notice that there are only two options for gauge themes? Default (text only) vs. Needle Fill (yellow on blue gauges). I see some examples/tutorials showing a simple black/grey gauge face with white text, surrounded by red or green graduations - is that theme also available?

Only thing is, when I have my sunglasses on, and the tablet sittingin landscape... the polarization of the lenses messes with the screen and I can't see a thing on the tablet. So strange
I noticed that I get the invalid or corrupt map message when I don't disconnect in the app before disconnecting the phone/tablet itself from the JB4 (in your case, this might be when you move out of Bluetooth range?)


*******************************
** 2014 BMW F30 N20 328i EWG **
** JB4 **
*****************************
Reply With Quote
(#4761)
Old
Sean the Mick Sean the Mick is offline
New Member
 
Posts: 5
Join Date: Sep 2019
Car: Q60
Default 10-01-2019, 02:27 PM

Quote:
Originally Posted by maddog
Silly question, did the app establish connection to the JB4 before you tried to update?
Appreciate the reply... honestly, no stupid question at this point!

Yes... it did establish a connection before the attempted update

I have even tried to download the update into my phone while away from the car and it just stays on that screen

If I delete the JB4 App off my phone and reinstall...I assume since I paid already it won't double charge me. Think I should do that?
Reply With Quote
(#4762)
Old
nextNME's Avatar
nextNME nextNME is offline
Junior Member
 
Posts: 33
Join Date: Jan 2016
Car: 2008 535xi
Default 10-01-2019, 06:03 PM

Quote:
Originally Posted by maddog
I noticed that I get the invalid or corrupt map message when I don't disconnect in the app before disconnecting the phone/tablet itself from the JB4 (in your case, this might be when you move out of Bluetooth range?)
Thank you for the reply. I will try to make sure I disconnect properly before unplugging/turning off. See if that's it.

The photo of your gauges on the android touchscreen - is that your standard theme? What is it called? I like. That's the one I want. Simple yet effective.

Quote:
Originally Posted by Nordic335IM3
anybody else notice delayed needle sweep when starting up ?
My needle sweep at start up is delayed randomly, sometimes almost a good 4sec before it sweeps.

It was randomly doing this prior to the JB4 Mobile App. I have not gone back to the previous firmware version to see if it fixes the problem.

Quote:
Originally Posted by Sean the Mick
Appreciate the reply... honestly, no stupid question at this point!

Yes... it did establish a connection before the attempted update

I have even tried to download the update into my phone while away from the car and it just stays on that screen

If I delete the JB4 App off my phone and reinstall...I assume since I paid already it won't double charge me. Think I should do that?
Can you update the firmware with a PC? Where did you get the hex file from?


2008 535xi. BMS DCI. OCC. JB4. MHD BEF. XHP. NGK. BR14.

Last edited by nextNME; 10-01-2019 at 06:09 PM..
Reply With Quote
(#4763)
Old
maddog maddog is offline
New Member
 
Posts: 6
Join Date: Sep 2019
Car: 2014 BMW F30 N20 328i
Default 10-01-2019, 07:52 PM

Quote:
Originally Posted by nextNME
Thank you for the reply. I will try to make sure I disconnect properly before unplugging/turning off. See if that's it.

The photo of your gauges on the android touchscreen - is that your standard theme? What is it called? I like. That's the one I want. Simple yet effective.
It's the default theme (guage theme 1) in landscape mode


*******************************
** 2014 BMW F30 N20 328i EWG **
** JB4 **
*****************************
Reply With Quote
(#4764)
Old
@BIMMERSRD12 @BIMMERSRD12 is offline
New Member
 
Posts: 1
Join Date: Sep 2019
Car: Bmw 535xi e60
Default 10-01-2019, 10:15 PM

I want installed me jb4 I have bmw 535xi 2007 I want map 3
Reply With Quote
(#4765)
Old
jager335 jager335 is offline
Junior Member
 
Posts: 33
Join Date: Aug 2017
Car: 08' Bmw e92 Msport 335i
Default 10-02-2019, 01:26 AM

Hi

Wondering if anyone can help me? My car has been out of action for 6 months and I tried to load up the jb4 app today and I get a Bluetooth error? It was working fine the last time I used it can anyone help? this is the message I get I have a rev3.6 and iOS 13.

Thanks
Adam
Attached Images
 
Reply With Quote
(#4766)
Old
JamMasta JamMasta is offline
New Member
 
Posts: 19
Join Date: Mar 2017
Car: 335XI
Default iOS 13 BT error - 10-02-2019, 09:54 AM

I have the same error
iOS 13
Error comes up just opening the app, does not even try to connect.
Tried phone reboot wifi BT on/off
Reply With Quote
(#4767)
Old
jager335 jager335 is offline
Junior Member
 
Posts: 33
Join Date: Aug 2017
Car: 08' Bmw e92 Msport 335i
Default 10-02-2019, 10:07 AM

Yeah I tried the same thing I also have updated to iOS 13 and still can't get it to work.
Reply With Quote
(#4768)
Old
nextNME's Avatar
nextNME nextNME is offline
Junior Member
 
Posts: 33
Join Date: Jan 2016
Car: 2008 535xi
Default 10-02-2019, 11:20 AM

Quote:
Originally Posted by maddog
It's the default theme (guage theme 1) in landscape mode
Hmm. Maybe I need to reinstall the app on my tablet... The 2nd Option "Needle Fill" works perfect. But the 1st Default Theme only has text, and is missing the colored graph around the outside of each gauge.
Attached Images
  


2008 535xi. BMS DCI. OCC. JB4. MHD BEF. XHP. NGK. BR14.
Reply With Quote
(#4769)
Old
JamMasta JamMasta is offline
New Member
 
Posts: 19
Join Date: Mar 2017
Car: 335XI
Default 10-02-2019, 05:07 PM

Quote:
Originally Posted by JamMasta
I have the same error
iOS 13
Error comes up just opening the app, does not even try to connect.
Tried phone reboot wifi BT on/off
FIX is to uninstall app and reinstall. Worked for me.
Reply With Quote
(#4770)
Old
Crapo85 Crapo85 is offline
New Member
 
Posts: 1
Join Date: Oct 2019
Car: BMW 335xi
Default 10-02-2019, 06:31 PM

Quote:
Originally Posted by Klpaleo
I had bought and used the app in my iPhone
Now I changed device to an Android phone and want to re install the app but I don't see how to do this without paying again

Please advise
Need help on same thing?
Reply With Quote
(#4771)
Old
jager335 jager335 is offline
Junior Member
 
Posts: 33
Join Date: Aug 2017
Car: 08' Bmw e92 Msport 335i
Default 10-02-2019, 06:45 PM

Quote:
Originally Posted by JamMasta
FIX is to uninstall app and reinstall. Worked for me.
Your a life saver mate haha mine works now also after reinstalling. Thanks for your help.
Reply With Quote
(#4772)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,278
Join Date: Aug 2013
Car: 2008 135i
Default 10-03-2019, 11:32 AM

Quote:
Originally Posted by k1kote
Hi, I have several recommendations and good things to implement that could be useful, I hope it's the right thread to post this.

-User Adjustment in the 2nd tab
-The gauges show the highest and/or lowest values ​​reached, example:
*Maximum temperature reached
*IAT minimum temperature reached
-In the case of Boost that shows the frozen Boost peak for 1 second
-Add the variables of "cylinder timing correction" and "misfire count" that can be seen in the VW using the Polarfis, mainly to see them in the log
-More themes and especially one of needles more sober than "Needle Fill"
-The shift light has to be yellow very visible, not red
-To be able to see the logs in metric unit (km/h and C°)
-Programmable visual and audible alerts, example:
*In AFR if the target is 12, outside 11.5 and 12.5 of a visual and/or audible alert only if the X% pedal is
*In Water Temp and Oil Temp above X temperature the gauge appears with a red background
-A map for safe driving that loads no more than 7 psi
-When you leave a log, be selected to know which one you left
-When save changes in User Adjustment the legend that the changes were saved does not appear above the tabs
-Support different languages, I would like Spanish
-Bug: when you are in the list of choosing which variable to see in a gauge, but you go back without choosing a different one, it does not return to the gauges but it shows the Display tab selected but shows the Settings
Some gauges already support displaying the max value. Simply double-tap on one to find out if it's supported.

Boost value already has a ghosting feature. Are you having a problem with it?

That VW specific value would need to be added in via a firmware update to the JB4 from Terry.

More themes and customizations are in the pipeline, but functionality stuff takes priority over it.

Customizable shift light colors can be added.

Metric graphing could be an option.

Audio alerts are coded up for iOS, but were put on the back burner sometime last year.

Safety map is already there on the JB4.

The top log is always the last one you took.

Not sure what you're referring to with the saved settings alert.

I need to convert all of my in-app text to use a resource file instead so language translation can happen.

I'll check out that bug.

Quote:
Originally Posted by Klpaleo
I had bought and used the app in my iPhone
Now I changed device to an Android phone and want to re install the app but I don't see how to do this without paying again

Please advise
Email into support@jb4connectkit.com

Quote:
Originally Posted by maddog
I would really love to see many of these features (possibly where we can add gauges and set our own min and max settings)

I would also like to see the traditional pressure gauge that measures pressure in the manifold, instead of just positive boost.

Lastly, i noticed that the gear gauge only goes up to 6 for me (i have the 8 speed auto). I recently bought my Jb4 and recently applied the latest firmware.

PS. I really love the convenience of the app. I have an aftermarket Android touchscreen (that replaces the original BMW screen) and i'm using the USB cable to it. It works pretty well (although on rare occasion, i get an error about invalid map selection on app startup)..
I don't believe the JB4 has access to boost pressure in that manner so we only get the positive value.

The JB4 only supports reading up to 6 gears so that will need to be a request for Terry.

Regarding that error, how solid is the cable connection to the device?

Quote:
Originally Posted by aliiaki
Jb4 Second buddies android but not my Apple. Any quick resolutions to be visible on Bluetooth
What error are you getting in JB4 Mobile?

Quote:
Originally Posted by nextNME
First time JB4 Mobile user, long time JB4 user... so far I love the app. Auto-log WOT is my favorite. How many log files can/will be stored total?

Randomly on startup the App says the User Settings are corrupt, asks Set Values To Last Saved... not sure why it would be doing that only sometimes? I use JB4 Map1. I have lowered Pid Gain to 15. About 1 week ago I reset the value for FF/Wastegate Adaptation... other than that I pretty much leave settings alone.

I notice that there are only two options for gauge themes? Default (text only) vs. Needle Fill (yellow on blue gauges). I see some examples/tutorials showing a simple black/grey gauge face with white text, surrounded by red or green graduations - is that theme also available?

Only thing is, when I have my sunglasses on, and the tablet sittingin landscape... the polarization of the lenses messes with the screen and I can't see a thing on the tablet. So strange
As many logs as you can fit on your device's storage.

Please send a pic of where you have your kit installed. Specifically where the power wire from the kit attaches.

iOS has one extra theme over Android currently.

I have the same issue with my S10 and polarized glasses. It's a physics thing so nothing I can do about it unfortunately.

Quote:
Originally Posted by Sean the Mick
Appreciate the reply... honestly, no stupid question at this point!

Yes... it did establish a connection before the attempted update

I have even tried to download the update into my phone while away from the car and it just stays on that screen

If I delete the JB4 App off my phone and reinstall...I assume since I paid already it won't double charge me. Think I should do that?
Email into support3@jb4connectkit.com and we'll get it resolved.

Quote:
Originally Posted by @BIMMERSRD12
I want installed me jb4 I have bmw 535xi 2007 I want map 3
I'm not entirely sure what you're requesting help with.

Quote:
Originally Posted by jager335
Hi

Wondering if anyone can help me? My car has been out of action for 6 months and I tried to load up the jb4 app today and I get a Bluetooth error? It was working fine the last time I used it can anyone help? this is the message I get I have a rev3.6 and iOS 13.

Thanks
Adam
There is an issue with iOS 13 currently. From what we've seen, updating to iOS 13.1 or higher and reinstalling the app fixes the issue.

Quote:
Originally Posted by nextNME
Hmm. Maybe I need to reinstall the app on my tablet... The 2nd Option "Needle Fill" works perfect. But the 1st Default Theme only has text, and is missing the colored graph around the outside of each gauge.
Email into support3@jb4connectkit.com and we'll see what's going on.

Quote:
Originally Posted by Crapo85
Need help on same thing?
Email us: support@jb4connectkit.com


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4773)
Old
Sean the Mick Sean the Mick is offline
New Member
 
Posts: 5
Join Date: Sep 2019
Car: Q60
Default 10-04-2019, 09:37 AM

Appreciate the help, was resolved by uninstalling and reinstalling JB4 app.

Great forum response and support.

Thanks fellas!
Reply With Quote
(#4774)
Old
LeeOrl LeeOrl is offline
New Member
 
Posts: 5
Join Date: Apr 2019
Car: 2013 BMW 335i E93 4/25/13
Default 10-05-2019, 01:00 PM

Quote:
Originally Posted by jager335
Yeah I tried the same thing I also have updated to iOS 13 and still can't get it to work.
with IOS 13 you need to go into the app settings and turn on Bluetooth access for each app. Apple did this because some apps were tracking users without them knowing or something like that i was told
Reply With Quote
(#4775)
Old
LeeOrl LeeOrl is offline
New Member
 
Posts: 5
Join Date: Apr 2019
Car: 2013 BMW 335i E93 4/25/13
Default 10-05-2019, 01:04 PM

'If you are updating to iOS 13 today, please keep in mind...any Application that requires Bluetooth Permissions will have the permissions turned off after the update. You will need to open the app and re-allow the Bluetooth Permissions. Apple is doing this so 3rd party apps can no longer read your location from Bluetooth after you have opted out of location services.'
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 17 (0 members and 17 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com