N54Tech.com - International Turbo Racing Discussion
(#2376)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-16-2019, 08:49 AM

Quote:
Originally Posted by ecko04
Terry, for the fuel-it sensor, if I am using the meth FSB where does the wire wire from the fuel-it sensor go to provide that data to the JB4? The blue wire for the FSB is currently in location 16 where the white wire from the fuel-it would normally go.
It goes in to spot #4 then. Email me for the firmware with that input enabled for the flex fuel input.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2377)
Old
u/tonyv1990 u/tonyv1990 is offline
New Member
 
Posts: 8
Join Date: Jun 2019
Car: Stinger GT
Default DATA LOGS - 07-16-2019, 12:49 PM

from A recent dyno run we ran maps 1-2-3-5 to see how the car behaved and what power was made learning more about the car how ever the Bluetooth disconnected on map1 and map2 runs not sure why this happened but not as concerning as the car only making 345hp and 424tq max and that was on map5
I have attached the logs i was able to get would love any advice
Attached Files
File Type: csv 2019-07-12 16_36_00_Map-5.csv (25.1 KB, 20 views)
File Type: csv 2019-07-12 18_24_44_Map-3.csv (31.0 KB, 23 views)
Reply With Quote
(#2378)
Old
Adamdan Adamdan is offline
Junior Member
 
Posts: 119
Join Date: Sep 2018
Car: Stinger
Default 07-16-2019, 01:50 PM

Quote:
Originally Posted by u/tonyv1990
from A recent dyno run we ran maps 1-2-3-5 to see how the car behaved and what power was made learning more about the car how ever the Bluetooth disconnected on map1 and map2 runs not sure why this happened but not as concerning as the car only making 345hp and 424tq max and that was on map5
I have attached the logs i was able to get would love any advice

That seams low for map 5. I made 375whp on map 2. What kind of octane you running?
Reply With Quote
(#2379)
Old
u/tonyv1990 u/tonyv1990 is offline
New Member
 
Posts: 8
Join Date: Jun 2019
Car: Stinger GT
Default 07-16-2019, 01:52 PM

91 and yeah it only made 328 on map 2 im getting more worried now ha ha
Reply With Quote
(#2380)
Old
RandallK's Avatar
RandallK RandallK is offline
Junior Member
 
Posts: 42
Join Date: Mar 2018
Car: 2018 Kia Stinger GT
Default 07-16-2019, 04:42 PM

Got my catch can today and had it installed in 5 minutes... Thanks Terry!!
Reply With Quote
(#2381)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-16-2019, 05:07 PM

Quote:
Originally Posted by RandallK
Got my catch can today and had it installed in 5 minutes... Thanks Terry!!


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2382)
Old
akim93 akim93 is offline
New Member
 
Posts: 1
Join Date: Jul 2019
Car: Stinger GT
Default 07-16-2019, 08:56 PM

Hello Terry,

I have a few questions that I want to verify with you before I install the JB4 to my 2019 Kia Stinger GT AWD.

1. I ordered the denso spark plugs from your site, but will I need to install those for map 1? I am trying to take it slow first then move on to map 2. I am seeing different answer to where map 1 will be able to run with the factory spark plugs. Once I am comfortable with map 1, I was planning to install the denso spark plugs with gap of .22 then move to map 2.

2. Is it best to be in v8 once I install my jb4?

3. I don't want to go to a Kia dealership to get the spark plugs installed and I also don't trust myself to intall it myself. Do you think it is a good idea to find a good mechanic near my area to install the denso spark plugs? (Even though the mechanic may have not dealth with a stinger before.

4. So map 1 needs to use 91 octane and map 2 needs to use 93 octane?

5. If I ever decide to go back to stock from the jb4 tune then all I have to do is take the JB4 plugs out of the vehicle but the denso plugs would still be in the car. Will it be okay for the denso spark plugs with gap .22 to be in a stock stinger GT?

Thank You Terry
Reply With Quote
(#2383)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-17-2019, 08:27 AM

1) Sometimes map1 works on stock plug gap, sometimes it doesn't.
2) Doesn't really matter. No reason not to run the latest firmware, though.
3) There is a DIY video somewhere around, anyone can do it. Takes an hour or two the first time but maybe 30 min the second.
4) You can run map1 or map2 on 91 octane.
5) Not an issue


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2384)
Old
hamburger1971 hamburger1971 is offline
New Member
 
Posts: 8
Join Date: Jan 2019
Car: 19 Stinger GT1 AWD
Default JB4 freezing - 07-17-2019, 08:54 AM

Hi Terry (and everyone).

This is all regarding a '19 GT1 AWD, running on map 2 with 93 octane.

Last week I noticed some erratic behavior on acceleration (anywhere between 1/2 to full throttle), the car would occasionally 'hiccup' or have a quick drop in power before picking back up. Acceleration was also less linear than it had been. This happened in all drive modes.

I thought it might be bad gas, so I went to a different station for the next tank. Unfortunately, the same funky behavior continued. I tried flashing to v10 from v8, but the checksums didn't match so I went back to v8. I also started using the app to watch gauges and monitor boost while driving to see if I could figure out what's going on.

Whenever I make more than about 10 or 11 pounds of boost, the JB4 display freezes! I try to run logs, but the system will freeze and then record 2 or 3 log sessions rather than just the one. I successfully flashed to v10, but the same thing is happening.

When I run map 0, the car runs a bit smoother but the JB4 still freezes upon hard acceleration.

Any advice on what may be happening, or has anyone experienced similar behavior?

Thanks!

Jeff
Reply With Quote
(#2385)
Old
Payam @ BMS's Avatar
Payam @ BMS Payam @ BMS is offline
Super Moderator
 
Posts: 5,434
Join Date: Oct 2013
Car: e90 335i
Default 07-17-2019, 09:28 AM

Quote:
Originally Posted by hamburger1971
Hi Terry (and everyone).

This is all regarding a '19 GT1 AWD, running on map 2 with 93 octane.

Last week I noticed some erratic behavior on acceleration (anywhere between 1/2 to full throttle), the car would occasionally 'hiccup' or have a quick drop in power before picking back up. Acceleration was also less linear than it had been. This happened in all drive modes.

I thought it might be bad gas, so I went to a different station for the next tank. Unfortunately, the same funky behavior continued. I tried flashing to v10 from v8, but the checksums didn't match so I went back to v8. I also started using the app to watch gauges and monitor boost while driving to see if I could figure out what's going on.

Whenever I make more than about 10 or 11 pounds of boost, the JB4 display freezes! I try to run logs, but the system will freeze and then record 2 or 3 log sessions rather than just the one. I successfully flashed to v10, but the same thing is happening.

When I run map 0, the car runs a bit smoother but the JB4 still freezes upon hard acceleration.

Any advice on what may be happening, or has anyone experienced similar behavior?

Thanks!

Jeff
Would you be able to post any of the logs you captured?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2386)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-17-2019, 09:45 AM

Quote:
Originally Posted by hamburger1971
Hi Terry (and everyone).

This is all regarding a '19 GT1 AWD, running on map 2 with 93 octane.

Last week I noticed some erratic behavior on acceleration (anywhere between 1/2 to full throttle), the car would occasionally 'hiccup' or have a quick drop in power before picking back up. Acceleration was also less linear than it had been. This happened in all drive modes.

I thought it might be bad gas, so I went to a different station for the next tank. Unfortunately, the same funky behavior continued. I tried flashing to v10 from v8, but the checksums didn't match so I went back to v8. I also started using the app to watch gauges and monitor boost while driving to see if I could figure out what's going on.

Whenever I make more than about 10 or 11 pounds of boost, the JB4 display freezes! I try to run logs, but the system will freeze and then record 2 or 3 log sessions rather than just the one. I successfully flashed to v10, but the same thing is happening.

When I run map 0, the car runs a bit smoother but the JB4 still freezes upon hard acceleration.

Any advice on what may be happening, or has anyone experienced similar behavior?

Thanks!

Jeff
I saw that on our development car once when a factory spark plug was damaged. It would send a jolt back through the electrical system that would cause the JB4 to disable itself for electrical safety purposes.

More recently had a similar issue with a WMI customer and a faulty FSB kicking back an electrical surge.

It's likely something electrical or plug related.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2387)
Old
hamburger1971 hamburger1971 is offline
New Member
 
Posts: 8
Join Date: Jan 2019
Car: 19 Stinger GT1 AWD
Default 07-17-2019, 10:45 AM

Thanks, Terry. I have the replacement plugs from you guys. You think that could still be it, or can you think of another weak spot in the electrical system worth checking?

Jeff
Reply With Quote
(#2388)
Old
hamburger1971 hamburger1971 is offline
New Member
 
Posts: 8
Join Date: Jan 2019
Car: 19 Stinger GT1 AWD
Default 07-17-2019, 12:08 PM

Quote:
Originally Posted by Payam @ BMS
Would you be able to post any of the logs you captured?
Hi Payam. The logs seem to be pretty random, but I'm posting the recent few for you to see. If you think it's worthwhile, we can take the discussion offline, hamburger1971 at hotmail dot com. Some are from map 0, some are map 2 - there wasn't always rhyme or reason to when it recorded, and even when I hit 'start logging' the system might not have stopped when I asked. If there are specific scenarios you'd like me to try and get please let me know.

Thanks,

Jeff
Attached Files
File Type: csv 2019-07-16 17_32_59_Map-2.csv (1.7 KB, 21 views)
File Type: csv 2019-07-16 17_33_06_Map-2.csv (4.7 KB, 23 views)
File Type: csv 2019-07-16 17_33_09_Map-2.csv (2.4 KB, 18 views)
File Type: csv 2019-07-16 17_44_30_Map-0.csv (2.4 KB, 24 views)
File Type: csv 2019-07-16 17_44_38_Map-0.csv (5.7 KB, 15 views)
File Type: csv 2019-07-16 19_29_59_Map-0.csv (1.0 KB, 19 views)
File Type: csv 2019-07-16 19_30_03_Map-0.csv (2.4 KB, 19 views)
Reply With Quote
(#2389)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-17-2019, 01:30 PM

Quote:
Originally Posted by hamburger1971
Thanks, Terry. I have the replacement plugs from you guys. You think that could still be it, or can you think of another weak spot in the electrical system worth checking?

Jeff
Only if one was damaged during install or if there was a coil issue. Another test might be to remove OBDII cable all together to see if you can recreate the symptoms on map1.

At any event just email and we'll help you that way, terry@burgertuning.com


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2390)
Old
spyders03's Avatar
spyders03 spyders03 is offline
New Member
 
Posts: 8
Join Date: Jul 2019
Car: 16 SXL
Default 07-17-2019, 03:14 PM

Good evening. I just got the JB4 installed on my 2016 Optima SXL (2.0T), map 1 runs just fine, tried map 2 and it defaulted back to map 0 half way through a 3rd gear pull. Just changed the plugs to the M45XL HKS plugs, running 93 octane. It seemed to hesitate right before (or maybe during) the switch in maps. Any help you can provide would be greatly appreciated. Hopefully the day to log uploads.
Reply With Quote
(#2391)
Old
spyders03's Avatar
spyders03 spyders03 is offline
New Member
 
Posts: 8
Join Date: Jul 2019
Car: 16 SXL
Default 07-17-2019, 03:16 PM

Upload
Attached Files
File Type: csv 2019-07-17 16_31_24 (SXL)_Map-2NEW.csv (10.7 KB, 27 views)
Reply With Quote
(#2392)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-17-2019, 03:38 PM

Quote:
Originally Posted by spyders03
Upload
You exceeded your 20psi boost safety. Raise that to 22psi and log map1 next.
Attached Images
 


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2393)
Old
spyders03's Avatar
spyders03 spyders03 is offline
New Member
 
Posts: 8
Join Date: Jul 2019
Car: 16 SXL
Default 07-17-2019, 03:57 PM

Here's a log from map 1, I'll adjust and take another log on map 1 in a little bit after the adjustment. Seems like it stayed in map 1 the whole time? Not sure if everything else looks ok.
Attached Files
File Type: csv 2019-07-17 16_23_43 (SXL)_Map-1NEWS.csv (8.9 KB, 22 views)

Last edited by spyders03; 07-17-2019 at 05:42 PM..
Reply With Quote
(#2394)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-17-2019, 05:42 PM

Log looks OK, next log do something more like a 1/4 mile style run with shifts.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2395)
Old
Adamdan Adamdan is offline
Junior Member
 
Posts: 119
Join Date: Sep 2018
Car: Stinger
Default 07-17-2019, 06:39 PM

Any info on the self learning map for the stinger?
Reply With Quote
(#2396)
Old
spyders03's Avatar
spyders03 spyders03 is offline
New Member
 
Posts: 8
Join Date: Jul 2019
Car: 16 SXL
Default 07-18-2019, 01:33 PM

Let me know if you need a longer log, didn't have a ton of room this morning. Thanks in advance, we all appreciate your expertise!

P.S. the JB4 in map 2 feels AMAZING!
Attached Files
File Type: csv 2019-07-18 08_43_41 (SXL)_Map-2NEW.csv (6.9 KB, 26 views)
Reply With Quote
(#2397)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-18-2019, 03:00 PM

Quote:
Originally Posted by Adamdan
Any info on the self learning map for the stinger?
We haven't released one yet, but plan to in the future.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2398)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,042
Join Date: Jan 2008
Default 07-18-2019, 03:01 PM

Quote:
Originally Posted by spyders03
Let me know if you need a longer log, didn't have a ton of room this morning. Thanks in advance, we all appreciate your expertise!

P.S. the JB4 in map 2 feels AMAZING!
Timing movement is a bit odd but not sure if it's a logging thing or how it's actually running. Try to grab a couple more logs for comparison.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#2399)
Old
lvthundercat lvthundercat is offline
New Member
 
Posts: 6
Join Date: Jul 2019
Car: Kia Stinger GT AWD
Default 07-19-2019, 12:43 PM

Quote:
Originally Posted by Terry @ BMS
1) Sometimes map1 works on stock plug gap, sometimes it doesn't.
2) Doesn't really matter. No reason not to run the latest firmware, though.
3) There is a DIY video somewhere around, anyone can do it. Takes an hour or two the first time but maybe 30 min the second.
4) You can run map1 or map2 on 91 octane.
5) Not an issue
Hi Terry;

I'm new to this platform and had just received my jb4 w/ BT dongle for a 2019 Stinger GT using stock plugs / stock gap, 91 octane @ 2K ft elevation. Your replies above answered most of my questions. But I got 2 more:

1. Do I need to use/connect the OBD2 plug in order to get the maximum benefit of Map1 & 2? or is the OBD2 plug just for monitoring gauges on the phone?

and

2. If I just got the jb4 (brand new), do I need to worry about any firmware updates at this time? or am I good to go as is - just plug and play?

Thanks.

Chris
Reply With Quote
(#2400)
Old
spyders03's Avatar
spyders03 spyders03 is offline
New Member
 
Posts: 8
Join Date: Jul 2019
Car: 16 SXL
Default 07-19-2019, 12:55 PM

Here's a 1/4 mile style log. Roads were slightly wet so there was some wheel spin down low
Attached Files
File Type: csv 2019-07-18 19_52_11 (SXL)_Map-2.csv (14.0 KB, 17 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 3 (0 members and 3 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com