N54Tech.com - International Turbo Racing Discussion
(#76)
Old
spain4065 spain4065 is offline
Junior Member
 
Posts: 98
Join Date: Aug 2014
Car: e82
Default 03-31-2015, 11:07 PM

Just got done installing my MM inlets this past weekend. Now chasing a boost leak. The install is a bit time consuming, but patience and persistence is the key.
Reply With Quote
(#77)
Old
tjobeid tjobeid is offline
Junior Member
 
Posts: 195
Join Date: Jun 2013
Car: 07 335i coupe
Default 03-31-2015, 11:25 PM

What took you the longest, just curious ? Buy a vacuum pump and check vacuum. I noticed I have a leak on my front turbo today.
Reply With Quote
(#78)
Old
spain4065 spain4065 is offline
Junior Member
 
Posts: 98
Join Date: Aug 2014
Car: e82
Default 03-31-2015, 11:32 PM

Hmm, I'd say getting rear elbow on was a pain without it slipping off and suprisingly the front silver chargepipe to the turbo with the vband clamp didn't want to seat properly once i took it off, might be my boost leak issue. It was the one right beside the front inlet pipe. Only was able to utilize shop for a few hours per day so took a few days trying to fit it in my schedule. Glad that I have two cars so not much stress with it being down. Ordered boost leak tester with built in gauge. Will try it this week and cap off other inlet and let the game begin to find the leak.
Reply With Quote
(#79)
Old
spain4065 spain4065 is offline
Junior Member
 
Posts: 98
Join Date: Aug 2014
Car: e82
Default 03-31-2015, 11:33 PM

Once I get it sorted I will post up some pics of the install process and hopefully some vids. Will dyno soon after...
Reply With Quote
(#80)
Old
Mauricio @ MMP's Avatar
Mauricio @ MMP Mauricio @ MMP is offline
Junior Member
 
Posts: 478
Join Date: Aug 2009
Car: 335i Cp TiAg JB3 DCI
Default 04-01-2015, 08:05 AM

Quote:
Originally Posted by tjobeid
I got mine on the dyno couple days ago with about 10 other n54's. I had the highest numbers out the group that day. I had a boost leak on the dyno also. not hitting my 20psi all the way across. MY front turbo actuator isn't staying shut. May have a bad vacuum line, hopefully turbo isn't already messing up its got under 15k on it.

*** to make things clear. RUN 004 WAS before the intakes****
Also worth noting there was an N54 there with VTT inlets and same mods and fuel as TJs car and TJ made marginally more torque and power, not really worth mentioning but TJ did make the most power there even with a messed up WG actuator on the front turbo


Stock Turbo 500whp 540wtq with MMP inlets
http://mmp-e.com
  • inlets (high flow and one piece silicone)
  • high flow outlets
  • turbo development
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com