N54Tech.com - International Turbo Racing Discussion
(#1)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default New JB4, help - 01-31-2019, 07:44 PM

Good evening,

I bought a JB4 G5 from someone secondhand and when I installed the product, my car was stalling, not driving properly, huge power loss, etc. Granted he did have meth injection, bigger turbos, and other modifications. I found a sheet online to reset the "User Adjustable Settings" but the car was still driving very badly. I have attached the .csv file and will post a pic of the "stock settings" I found online that I changed to. I noticed that under the "Water/Meth Injection" settings, the stock JB4 is supposed to be 40, 60, and 9. Since I don't ave either, I changed them all to "0."

I would like to know what I'm doing wrong or if someone can help walk me through this mess.

Car has upgraded charge pipe and dci. Running hirmware version

Thank you,
Attached Files
File Type: csv 2019_01_31 .csv (7.8 KB, 15 views)
File Type: zip Use this.zip (859.1 KB, 9 views)

Last edited by ykarabala; 01-31-2019 at 09:10 PM..
Reply With Quote
(#2)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 3,486
Join Date: Apr 2014
Car: E92 335XI
Default 01-31-2019, 09:42 PM

Quote:
Originally Posted by ykarabala
Good evening,

I bought a JB4 G5 from someone secondhand and when I installed the product, my car was stalling, not driving properly, huge power loss, etc. Granted he did have meth injection, bigger turbos, and other modifications. I found a sheet online to reset the "User Adjustable Settings" but the car was still driving very badly. I have attached the .csv file and will post a pic of the "stock settings" I found online that I changed to. I noticed that under the "Water/Meth Injection" settings, the stock JB4 is supposed to be 40, 60, and 9. Since I don't ave either, I changed them all to "0."

I would like to know what I'm doing wrong or if someone can help walk me through this mess.

Car has upgraded charge pipe and dci. Running hirmware version

Thank you,
Always tough when the unit is used.

Best advice besides settings to ďdefaultĒ

Youíll want to flash a stock turbo BEF for your correct modifications as wel.

Letís get you back to square 1 & go from there.

Set JB4 to 0- flash the appropriate firmware & correct BEF for your mods



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#3)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 27,786
Join Date: Jan 2008
Default 01-31-2019, 10:03 PM

Worth adding some install photos too, as well as a photo of the JB4 board, so we can double check that if it's not working right off the bat.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#4)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 1,028
Join Date: Jun 2011
Car: 135i N54
Default 02-01-2019, 09:21 AM

Based on your description the previous owner probably had a back-end flash loaded on top of the JB4. I am assuming you are not. Did you check the Menu 4 settings for that? That setting can't be changed in the interface for some reason.
Reply With Quote
(#5)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-01-2019, 11:29 PM

Sorry the pic is hella ****ty. I had to edit it a lot to make it fit. I installed JB4 properly w the arrows facing same direction and color coded.

I changed it to default settings, but the only values I altered were for the water/meth injection as I set those to 0. Is that ok?

How do I flash to stock turbo BEF? Not familiar at all with the BEF.

I recall setting everything to 0/0 a few months back and the issues remained so I removed JB4 again.

Sounds like we're on the right track in regards to the BEF, so thank you so far!
Attached Images
 
Reply With Quote
(#6)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-05-2019, 07:56 PM

Bump
Reply With Quote
(#7)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 27,786
Join Date: Jan 2008
Default 02-05-2019, 08:07 PM

I can't see the install photos, would need a clean full throttle log for any tuning advice.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#8)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 3,486
Join Date: Apr 2014
Car: E92 335XI
Default 02-05-2019, 08:14 PM

Quote:
Originally Posted by ykarabala
Sorry the pic is hella ****ty. I had to edit it a lot to make it fit. I installed JB4 properly w the arrows facing same direction and color coded.

I changed it to default settings, but the only values I altered were for the water/meth injection as I set those to 0. Is that ok?

How do I flash to stock turbo BEF? Not familiar at all with the BEF.

I recall setting everything to 0/0 a few months back and the issues remained so I removed JB4 again.

Sounds like we're on the right track in regards to the BEF, so thank you so far!
Terry is correct on the log.

Here is the link to the BEF Templates:

N54 BimmerBoost MHD Back End Flash Maps - N54Tech.com - International Turbo Racing Discussion

Ensure JB4 is set to ď0Ē & make sure you have the latest firmware installed prior.



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#9)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-16-2019, 03:47 PM

I was able to flash PUMP BEF. I am getting a really bad surge at random times. I am going to attach a few logs. 0/5 4/2 or 4/3 are referring to the active maps while logging. The car was surging in both maps, however, it was also driving fine during other times in both maps. No codes, no CEL or 1/2 CEL.
Attached Files
File Type: csv 0:5 4:3.csv (23.7 KB, 6 views)
File Type: csv 0:5 4:3 SURGE.csv (12.1 KB, 5 views)
File Type: csv 0:5 4:2.csv (14.3 KB, 4 views)
File Type: csv 0:5 4:2 SURGE.csv (24.4 KB, 5 views)
Reply With Quote
(#10)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 3,486
Join Date: Apr 2014
Car: E92 335XI
Default 02-17-2019, 09:29 AM

Quote:
Originally Posted by ykarabala
I was able to flash PUMP BEF. I am getting a really bad surge at random times. I am going to attach a few logs. 0/5 4/2 or 4/3 are referring to the active maps while logging. The car was surging in both maps, however, it was also driving fine during other times in both maps. No codes, no CEL or 1/2 CEL.
Can you get us a WOT log?

What are your menu 11(pedal input)/12 (bade Duty cycle ) settings?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#11)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-17-2019, 11:30 AM

What maps should I use while I log?
Reply With Quote
(#12)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 3,486
Join Date: Apr 2014
Car: E92 335XI
Default 02-17-2019, 11:46 AM

Quote:
Originally Posted by ykarabala
What maps should I use while I log?
Tach set to 4 /2 because you are running the BEF

Map 1 or 2



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#13)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-18-2019, 08:09 PM

I don't know what the hell is going on anymore and I've given up. JB4 won't connect to my Mac anymore so no logs. Regardless of what map I'm in, even 0/0, car still drives like trash. No power, stalls out, surges and bogs a ton then dies. Is there anyone I can send it to, or local to Sacramento, CA area that can check this thing out?

If it means anything... my menu 11 was set to 0. and menu 12 was set to 2.8
Reply With Quote
(#14)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 27,786
Join Date: Jan 2008
Default 02-18-2019, 08:58 PM

As it was a used unit so a good first step would be to just buy a new 2580 chipset from our site for $25, which will have firmware and settings preloaded, and at least restore that all to a known good state. It also replaces the comms in case you static zapped it or something preventing the reconnection.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#15)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-18-2019, 10:27 PM

Tried purchasing but can’t bc of California I’m guessing?

Removed JB4, drove the car again, and it feels great w MHD flashed so my issues are w the used unit

Last edited by ykarabala; 02-18-2019 at 10:53 PM..
Reply With Quote
(#16)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 3,486
Join Date: Apr 2014
Car: E92 335XI
Default 02-19-2019, 10:22 PM

Quote:
Originally Posted by ykarabala
Tried purchasing but canít bc of California Iím guessing?

Removed JB4, drove the car again, and it feels great w MHD flashed so my issues are w the used unit
Letís get you the new chip- shoot an email to sales@burgertuning.com



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#17)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-21-2019, 11:19 PM

Email sent, thank you!
Reply With Quote
(#18)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 3,486
Join Date: Apr 2014
Car: E92 335XI
Default 02-22-2019, 09:02 AM

Quote:
Originally Posted by ykarabala
Email sent, thank you!



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#19)
Old
ykarabala ykarabala is offline
New Member
 
Posts: 9
Join Date: Jan 2019
Car: 2007 335i
Default 02-22-2019, 10:19 AM

Was told that I am unable to receive it because I live in California.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2018, N54tech.com