N54Tech.com - International Turbo Racing Discussion
(#1)
Old
paulm.'s Avatar
paulm. paulm. is offline
New Member
 
Posts: 9
Join Date: Apr 2016
Car: e60 M5 e90 335i
Angry pure turbos issues ?? - 12-12-2016, 03:20 PM

i have just installed the pure stage 2 turbos and after arround 300 km i see oil coming out of the exhaust and oil under the car , anyone else experienced this ? what should be done and what could the issue be ?
Reply With Quote
(#2)
Old
Pure Turbos's Avatar
Pure Turbos Pure Turbos is offline
Junior Member
 
Posts: 495
Join Date: Jan 2014
Car: '70 E9 Turbo, '88 M5, '11 335d
Default 12-12-2016, 03:25 PM

Quote:
Originally Posted by paulm.
i have just installed the pure stage 2 turbos and after arround 300 km i see oil coming out of the exhaust and oil under the car , anyone else experienced this ? what should be done and what could the issue be ?
Oil under the car? Sounds like an oil leak. Possibly even an install problem. Damaged o-ring? Did an experienced tech install the turbos? Are the turbos still boosting and performing properly? Have you emailed or called us yet? We are here if you need help.
Reply With Quote
(#3)
Old
paulm.'s Avatar
paulm. paulm. is offline
New Member
 
Posts: 9
Join Date: Apr 2016
Car: e60 M5 e90 335i
Default 12-12-2016, 03:33 PM

Quote:
Originally Posted by Pure Turbos
Oil under the car? Sounds like an oil leak. Possibly even an install problem. Damaged o-ring? Did an experienced tech install the turbos? Are the turbos still boosting and performing properly? Have you emailed or called us yet? We are here if you need help.
I will have it checked and update you. It was installed by a professional. My tuner jack must have contacted you by now. And I have no doubts that you will be there to support. Thanks
Reply With Quote
(#4)
Old
Pure Turbos's Avatar
Pure Turbos Pure Turbos is offline
Junior Member
 
Posts: 495
Join Date: Jan 2014
Car: '70 E9 Turbo, '88 M5, '11 335d
Default 12-12-2016, 03:35 PM

Quote:
Originally Posted by paulm.
I will have it checked and update you. It was installed by a professional. My tuner jack must have contacted you by now. And I have no doubts that you will be there to support. Thanks
OK sounds good.
Reply With Quote
(#5)
Old
J_hynson J_hynson is offline
Junior Member
 
Posts: 34
Join Date: Jun 2014
Car: 2007 335I sedan
Default 12-12-2016, 05:00 PM

Ive never heard of this being an issue when it comes to Pure. Installed plenty and never this kind of problem. Im banking on installation error. It is more common than not that a "proffesional" will over look oil hoses, Orings, Corrosion on water side, cleaning of mating surfaces etc. Wouldnt hurt to jack the car up, remove the belly pan and give it a look. this way you know who is at fault and not what the person who installed it tells you

Last edited by J_hynson; 12-12-2016 at 05:05 PM..
Reply With Quote
(#6)
Old
AbacusRacingN54 AbacusRacingN54 is offline
Junior Member
 
Posts: 303
Join Date: Aug 2014
Car: 07 335i
Default 12-12-2016, 05:24 PM

Sounds like an o-ring issue
Reply With Quote
(#7)
Old
kabbanib kabbanib is offline
New Member
 
Posts: 28
Join Date: Oct 2016
Car: bmw 335 e92 n54 fbo+meth+pure stage 2
Default 12-13-2016, 12:06 AM

I had pure stage 2 , with 5k and no problems knock on wood check the installation and the oil lines
Reply With Quote
(#8)
Old
FCobra94 FCobra94 is offline
Junior Member
 
Posts: 147
Join Date: Feb 2014
Car: '07 E90 335i
Default 12-13-2016, 08:32 AM



Not sure what the purpose of creating this thread was before checking for obvious leaks first and/or taking it back to the guy that actually did the work.
Reply With Quote
(#9)
Old
Marlinman's Avatar
Marlinman Marlinman is offline
Junior Member
 
Posts: 316
Join Date: Jul 2014
Car: 335i coupe 2010
Default 12-13-2016, 09:22 AM

The purpose of the thread was most likely to poll experienced users for any information that he could gather and possibly present to said "guy" that did the work. This would be apparent from the replies he received from the MANUFACTURER and from what it sounds like, another experienced installer (hynson). The point is to help out!
Reply With Quote
(#10)
Old
FCobra94 FCobra94 is offline
Junior Member
 
Posts: 147
Join Date: Feb 2014
Car: '07 E90 335i
Default 12-13-2016, 09:51 AM

Quote:
Originally Posted by Marlinman
The purpose of the thread was most likely to poll experienced users for any information that he could gather and possibly present to said "guy" that did the work. This would be apparent from the replies he received from the MANUFACTURER and from what it sounds like, another experienced installer (hynson). The point is to help out!
Oops, sorry; guess I missed that.

OP: since your car started leaking oil after the new set of turbos went on, have the shop check all connections that either feed or drain oil to said turbos.

Hope that helps.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com