JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
Ladd Ladd is offline
New Member
 
Posts: 17
Join Date: May 2021
Car: 2010 E92 335i N54
Default Keep getting kicked to map4 only at WOT hpfp issue? - 08-19-2021, 05:27 AM

Hi all,

First of all the model and mods are:

2010 E92 335i N54

No cats
DCI
CP+BOV
MHD PUMP BEF + JB4 on Map5


So I keep getting kicked to map4 once I hit WOT, I can ease into the pull and everything feels good but once I go 100% pedal it almost instantly cuts the boost to 8psi map4 and flashes the turn signals on the dash 2 or 3 times. I literally get a better pull if i go like 60-80% throttle and never WOT. Im not good at reading logs so any help would be greatly appreciated, I think I caught it on this log. Thanks!
Attached Files
File Type: csv P32_M5_R7_210819_0729.csv (71.0 KB, 51 views)
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 08-19-2021, 09:42 AM

Your bank one O2 sensor is not reading correctly...you will need to resolve that issue before continuing or you risk blowing a motor.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
Ladd Ladd is offline
New Member
 
Posts: 17
Join Date: May 2021
Car: 2010 E92 335i N54
Default 08-19-2021, 10:09 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Your bank one O2 sensor is not reading correctly...you will need to resolve that issue before continuing or you risk blowing a motor.
Okay thank you I will get those ordered right away, because this is my daily driver do you think it will be alright to drive easy for a few days while I wait for the sensors or should I completely avoid driving immediately?
Reply With Quote
(#4)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 08-19-2021, 10:38 AM

I personally wouldn't drive it in that condition. There is nothing regulating the fuel/AFR's on bank 1 at this time.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#5)
Old
Ladd Ladd is offline
New Member
 
Posts: 17
Join Date: May 2021
Car: 2010 E92 335i N54
Default 08-19-2021, 10:51 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
I personally wouldn't drive it in that condition. There is nothing regulating the fuel/AFR's on bank 1 at this time.
Okay thanks Steve, I appreciate it.
Reply With Quote
(#6)
Old
Ladd Ladd is offline
New Member
 
Posts: 17
Join Date: May 2021
Car: 2010 E92 335i N54
Default 08-19-2021, 11:28 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
I personally wouldn't drive it in that condition. There is nothing regulating the fuel/AFR's on bank 1 at this time.
Just to clarify before I order, this would be the precat sensor so a Bosch 17098 sensor would be what im looking for?

Also here are the codes I was throwing this morning on my commute:

2A12: DTML tank leakage (had this code since I bought car)
29F3: Faulty Low Pressure Fuel Sensor (had this code for at least a month)
2C9F: Lambda probe heating behind *** 2, input signal (also had this code since I bought the car)
2DED: Power management, standby current control (new code as of a few days ago)
2C31: Lambda probe in front of ***, trimming control (new as of a couple days ago)
2C2B: Lambda probe in front of ***, system check (new as of a couple days ago)


UPDATE: So I started watching my Trims on my jb4 and noticed that Trims1 was stuck at 25 while Trims2 would fluctuate. I shut off the car, got some gas, turned the car back on and drove away, Trims1 now worked and fluctuated with Trims2 but after about 5minutes got locked at 25 again. Could this be a loose connection causing it to work intermittently?

Last edited by Ladd; 08-19-2021 at 01:30 PM..
Reply With Quote
(#7)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 08-20-2021, 11:03 AM

Hard to say but that is your issue. Could be a bad O2 (pre-***) sensor, short, swapped sensors, etc.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#8)
Old
Ladd Ladd is offline
New Member
 
Posts: 17
Join Date: May 2021
Car: 2010 E92 335i N54
Default 08-24-2021, 06:38 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Hard to say but that is your issue. Could be a bad O2 (pre-***) sensor, short, swapped sensors, etc.
So I found that if I just clear the codes on my Jb4 app while driving the code will go away for awhile and Trims1 will work. Sometimes lasts 2min sometimes 30min, but everytime I clear it works.

I had the bank 1 pre-*** sensor replaced with a new Bosch replacement yesterday and drove it for about 5min and 2C31 code is back? I clear codes, goes away for 10 mins, came back. Reset adaptations, cleared, came back again.

Is it possible that the Low Fuel Pressure Sensor code is related/causing this? I really don't know what to do. Appreciate any help anyone can offer.

On a side note, 2C9F post-*** code was fixed by plugging in a sensor that was found unplugged and hanging
Reply With Quote
(#9)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 08-24-2021, 09:33 AM

No...that's not due to the LPFP sensor, you'll need to find the root cause of the issue. Still sounds like an O2 sensor related issue to me.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2022, JB4tech.com