N54Tech.com - International Turbo Racing Discussion
(#1)
Old
suchtragedy's Avatar
suchtragedy suchtragedy is offline
Junior Member
 
Posts: 93
Join Date: Apr 2016
Car: 2013 335i
Default N55 PWG + BMS PI w/ Meth | Log review please! - 05-09-2019, 12:50 PM

Hey guys,

Just got done with install of BMS PI controller for direct port meth setup. I was previously running PWG ISO + CP meth kit but converted back to integrated and flashed to N55_F_PWG_INT_13_T1.hex. With so many changes I am somewhat lost on how to tune this beast again so basically reset everything to default starting parameters for the most part. Since this firmware is so different than the PWG ISO I was running I am not really sure which things are adjustable and which you leave alone for auto learning.

BMS PI controller configured with 30A relay with signal from controller to the meth pump, so no FSB any longer. Let me know if any questions, logs attached and mods up to date in signature if needed.

Thanks!
Attached Files
File Type: csv 2019-05-08 19_45_27 (F30N55)_Map-5.csv (19.0 KB, 25 views)
File Type: csv 2019-05-08 19_46_25 (F30N55)_Map-5.csv (11.6 KB, 23 views)




2013 335i F30 N55 PWG | JB4 + MHD BEF + xHP Stg3 | Pure Stage 2 + FBO | BMS PI controller + Meth | Fuel-It! Stg2 LPFP

Last edited by suchtragedy; 05-09-2019 at 12:54 PM.. Reason: spellings
Reply With Quote
(#2)
Old
T_H_O_M_A_S T_H_O_M_A_S is offline
Junior Member
 
Posts: 147
Join Date: Oct 2017
Car: M135ix
Default 05-09-2019, 03:21 PM

i would send a mail to trebila on this forum , he could make you a decent BEF for your car , your logs now are all over the place

this was my log after he made a BEF for my car , i'm pwg too which is always a bit harder
Attached Images
 


M135i PWG , FBO , PS2 , LPFP st2 , HDP6 custom for N55 , wedge MHD mapping , XHP AT8

Last edited by T_H_O_M_A_S; 05-09-2019 at 03:29 PM..
Reply With Quote
(#3)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,540
Join Date: Jan 2008
Default 05-09-2019, 03:27 PM

Something is wrong with the flash, WGDC is way too high causing over boosting.

Running our off the shelf BEF? Which one?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#4)
Old
suchtragedy's Avatar
suchtragedy suchtragedy is offline
Junior Member
 
Posts: 93
Join Date: Apr 2016
Car: 2013 335i
Default 05-09-2019, 05:35 PM

Quote:
Originally Posted by Terry @ BMS
Something is wrong with the flash, WGDC is way too high causing over boosting.

Running our off the shelf BEF? Which one?
It's MHD stage 2 flash right now (flashed to enable xHP trans flash) but I can flash the latest BMS BEF and relog and see if that narrows it down to the flash or not.




2013 335i F30 N55 PWG | JB4 + MHD BEF + xHP Stg3 | Pure Stage 2 + FBO | BMS PI controller + Meth | Fuel-It! Stg2 LPFP
Reply With Quote
(#5)
Old
suchtragedy's Avatar
suchtragedy suchtragedy is offline
Junior Member
 
Posts: 93
Join Date: Apr 2016
Car: 2013 335i
Default 05-10-2019, 02:23 PM

New log attached, stuff I changed:
1. Flashed JB4 FW to INT_13_T1 again
2. Flashed to BMS BEF PWG2_Race5 in MHD
3. Lowered default wastegate position and FF values

New log is short but there's not much difference. I am going to try an older PWG firmware on the JB4 next to see if it's an issue with the duty cycle learning or something.
Attached Files
File Type: csv 2019-05-10 08_58_43 (F30N55)_Map-5.csv (9.2 KB, 20 views)




2013 335i F30 N55 PWG | JB4 + MHD BEF + xHP Stg3 | Pure Stage 2 + FBO | BMS PI controller + Meth | Fuel-It! Stg2 LPFP
Reply With Quote
(#6)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,449
Join Date: Apr 2014
Car: E92 335XI
Default 05-13-2019, 12:03 AM

Quote:
Originally Posted by suchtragedy
New log attached, stuff I changed:
1. Flashed JB4 FW to INT_13_T1 again
2. Flashed to BMS BEF PWG2_Race5 in MHD
3. Lowered default wastegate position and FF values

New log is short but there's not much difference. I am going to try an older PWG firmware on the JB4 next to see if it's an issue with the duty cycle learning or something.
I canít open the log, can you re-upload?

Thanks 🙏🏼



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#7)
Old
suchtragedy's Avatar
suchtragedy suchtragedy is offline
Junior Member
 
Posts: 93
Join Date: Apr 2016
Car: 2013 335i
Default 05-13-2019, 07:16 AM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
I canít open the log, can you re-upload?

Thanks 🙏🏼
Log reattached. I think I have something physical to chase down. My thoughts are vacuum pressure converter, waste gate actuator, vacuum line itself, or bad diverter valve. Anything else I missed? I wouldn't think boost leak because I'd expect high WGDC and low boost with a leak and my logs show low or zero WGDC.
Attached Files
File Type: csv 2019-05-10 08_58_43 (F30N55)_Map-5.csv (10.6 KB, 11 views)




2013 335i F30 N55 PWG | JB4 + MHD BEF + xHP Stg3 | Pure Stage 2 + FBO | BMS PI controller + Meth | Fuel-It! Stg2 LPFP

Last edited by suchtragedy; 05-13-2019 at 07:20 AM.. Reason: Log reattached
Reply With Quote
(#8)
Old
suchtragedy's Avatar
suchtragedy suchtragedy is offline
Junior Member
 
Posts: 93
Join Date: Apr 2016
Car: 2013 335i
Default 05-15-2019, 10:23 AM

Update: Found my issue. I have a V1 board and previously running PWG ISO firmware and cut the diode. When I switched back I resoldered the diode but apparently either did a poor job or the diode/board is faulty.

I cut the diode again and flashed back to PWG ISO and reset everything and boost and WGDC all seem to work again. I'm going to relog as soon as I can either repair my v1 board or get a v2 board.




2013 335i F30 N55 PWG | JB4 + MHD BEF + xHP Stg3 | Pure Stage 2 + FBO | BMS PI controller + Meth | Fuel-It! Stg2 LPFP
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2018, N54tech.com