N54Tech.com - International Turbo Racing Discussion
(#1)
Old
phil1320 phil1320 is offline
Junior Member
 
Posts: 175
Join Date: Jul 2016
Car: 2011 335is
Default Car running rough / doesnt stay on - 06-07-2017, 08:23 AM

Hey guys,

Before I start digging into things and taking everything apart, I wanted to know what different "things" can cause my symptoms, potential things to check, and any help/advice I can get.

My mods are in my sig. I just installed the Fuel It stage 3 pump (using a 15psi Hobbs switch) and AD-E PI kit using an AIC6 (flash only) and MHD. The car sat for about a month to two while I did everything (I was not motivated and had other things come up and I wanted to make 100% sure of the wiring being setup correctly). The battery was pretty weak so I charged it some before retuning the car and left it on a charger during the process. I heard the LPFP running during the tuning, but only hear it sometimes when the door is opened or the car is locked/unlocked.

I started the car for the first time and it ran really, really rough. Almost like it was cammed and also had a long crank before it finally fired up (signs of bad HPFP). First few times it wouldn't even start. Finally, it idled out fine and then was idling normal. As soon as I would barely tap the gas, the car would choke and die (like its not getting fuel). I tried this a couple times and the same scenario happened or it didn't even start at all. I thought maybe the battery was too weak and everything was not getting full power. Got a new one, and the long crank was gone, but the same symptoms with running rough, then eventually running smooth, and then dying with any press of the pedal were still present. There was a few occasions where the engine fan would turn on as well (weird?) as the car shut off.

The very last time I tried this, I was able to check the fuel pressure. LPFP pressure was around 80 and so was rail pressure. This leads me to believe my HPFP took a dump however it was fine before hand. Is this just a coincidence? I did get some codes:

29F1 - DME: Fuel pressure, plausibility
2CFB - DME: Throttle-valve adaptation value
2D09 - DME: THROTTLE.

^ Those were on one occasion.

2A2B - DME: Mixture control
2A2C - DME: Mixture control 2

^ those were another.

To me, it sounds like the possible causes from most to least plausible is:

1) HPFP
2) LPFP
3) Wiring
4) Tune

Does anyone have any other suggestions or ideas? Ken said something might not be hooked up and Steve from Fuel It said to double check the install. Everything looks right to me and as I said I've heard the LPFP run and its showing 8X.XX psi?

Thank you all in advance!


2011 335is DCT | DocRace 6266 | HPF Gen 2 3.5" Exhaust | Stett Stage 2 Oil Cooler | CSF Aluminum Radiator | AD-E 1000 HP IC | Fuel-It Stage 3 Pump | AD-E PI | MFactory LSD | MFactory Axles | YCW Coilovers | SSP Spec R | M4 Flywheel
Reply With Quote
(#2)
Old
natedog7700's Avatar
natedog7700 natedog7700 is offline
Legend
 
Posts: 1,289
Join Date: Dec 2013
Car: 2007 bmw 335i e90 auto
Default 06-07-2017, 04:01 PM

Rail pressure should be WAY more than 80psi. Thats at least one problem right there. LPFP should be around there though


BMW 335i
RB's 550whp
2000 Camry
2000 LS1 T56 Camaro

Koenigsegg Agera R - SOLD
Lamborghini Huracan - SOLD
2014 Bugatti Veyron - SOLD
2012 Ferrari 458 Italia - SOLD
Reply With Quote
(#3)
Old
phil1320 phil1320 is offline
Junior Member
 
Posts: 175
Join Date: Jul 2016
Car: 2011 335is
Default 06-08-2017, 05:17 AM

Yea that's why I'm thinking it is the HPFP I just thought it was a weird coincidence.

When the HPFP is getting ready to fail, does it show signs of going in and out of lean conditions ?


2011 335is DCT | DocRace 6266 | HPF Gen 2 3.5" Exhaust | Stett Stage 2 Oil Cooler | CSF Aluminum Radiator | AD-E 1000 HP IC | Fuel-It Stage 3 Pump | AD-E PI | MFactory LSD | MFactory Axles | YCW Coilovers | SSP Spec R | M4 Flywheel
Reply With Quote
(#4)
Old
JB4OFF JB4OFF is offline
Junior Member
 
Posts: 121
Join Date: Nov 2016
Car: 340i
Default 06-08-2017, 05:51 AM

HPFP is going to **** and will most likely take LPFP with it
Reply With Quote
(#5)
Old
phil1320 phil1320 is offline
Junior Member
 
Posts: 175
Join Date: Jul 2016
Car: 2011 335is
Default 06-08-2017, 06:02 AM

LPFP is brand new stage 3 from Fuel It and the car has "ran" for a total of maybe 2 minutes. Do you think that would have done damage to the LPFP with no load ?


2011 335is DCT | DocRace 6266 | HPF Gen 2 3.5" Exhaust | Stett Stage 2 Oil Cooler | CSF Aluminum Radiator | AD-E 1000 HP IC | Fuel-It Stage 3 Pump | AD-E PI | MFactory LSD | MFactory Axles | YCW Coilovers | SSP Spec R | M4 Flywheel
Reply With Quote
(#6)
Old
JB4OFF JB4OFF is offline
Junior Member
 
Posts: 121
Join Date: Nov 2016
Car: 340i
Default 06-08-2017, 07:41 AM

So this happened after the LPFP install? Maybe there's a leak somewhere. Could be why fuel pressure is so low. Doubt anything is wrong with LPFP
Reply With Quote
(#7)
Old
phil1320 phil1320 is offline
Junior Member
 
Posts: 175
Join Date: Jul 2016
Car: 2011 335is
Default 06-08-2017, 08:15 AM

Yes. Car is running this way after the LPFP and PI install. Before it was fine except for one or two long crank starts but when the car was sitting for a while (battery was weak) and the injectors had been removed.

I have a feeling it has to be HPFP and it just happened as a coincidence. I'm going to check again today but I want to say both the rail pressure and lpfp pressure were 84 psi. So seems like either the HPFP got disconnected by accident or completely dead as the LPFP is the only pump providing fuel pressure. If the injectors were bad, rail pressure should still read correctly since the fuel goes to the rail first and then injectors, correct? I don't have much experience with DI engines.


2011 335is DCT | DocRace 6266 | HPF Gen 2 3.5" Exhaust | Stett Stage 2 Oil Cooler | CSF Aluminum Radiator | AD-E 1000 HP IC | Fuel-It Stage 3 Pump | AD-E PI | MFactory LSD | MFactory Axles | YCW Coilovers | SSP Spec R | M4 Flywheel
Reply With Quote
(#8)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,440
Join Date: Oct 2012
Car: 135i
Default 06-08-2017, 08:46 PM

Post logs of attempted startup...that is the best place to start.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#9)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,164
Join Date: Apr 2014
Car: E92 335XI
Default 06-08-2017, 11:29 PM

Do as Steve suggested & post log on startup.

Seeing that you just had parts installed- I'd also double check all physical connections.

It's not uncommon for the HPFP to take a dump for no apparent reason.



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#10)
Old
phil1320 phil1320 is offline
Junior Member
 
Posts: 175
Join Date: Jul 2016
Car: 2011 335is
Default 06-13-2017, 09:16 AM

http:// d a t a z a p .me/u/phil1320/rough-idle?log=0&data=3-22

There is the log of the startup. The rail pressure looks fine now. Steve said for me to check the vent lines so I'm going to do that tonight. Any other things it could be?


2011 335is DCT | DocRace 6266 | HPF Gen 2 3.5" Exhaust | Stett Stage 2 Oil Cooler | CSF Aluminum Radiator | AD-E 1000 HP IC | Fuel-It Stage 3 Pump | AD-E PI | MFactory LSD | MFactory Axles | YCW Coilovers | SSP Spec R | M4 Flywheel
Reply With Quote
(#11)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,440
Join Date: Oct 2012
Car: 135i
Default 06-13-2017, 09:32 PM

Please post the CSV file...



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#12)
Old
phil1320 phil1320 is offline
Junior Member
 
Posts: 175
Join Date: Jul 2016
Car: 2011 335is
Default 06-16-2017, 01:35 PM

The CSV file is too large by about 6 kb I did a log long enough to show the start, the rough idle, it smoothing out for a bit, and then me giving it a small rev and it dying.

I've emailed you the CSV steve. Hoping to get this figured out. My car has been down for 4-5 months because of whatever issue this is :/ First 3 months was me just being lazy and not working on it so that's on me haha


2011 335is DCT | DocRace 6266 | HPF Gen 2 3.5" Exhaust | Stett Stage 2 Oil Cooler | CSF Aluminum Radiator | AD-E 1000 HP IC | Fuel-It Stage 3 Pump | AD-E PI | MFactory LSD | MFactory Axles | YCW Coilovers | SSP Spec R | M4 Flywheel
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com