N54Tech.com - International Turbo Racing Discussion
(#1)
Old
glorentz glorentz is offline
New Member
 
Posts: 11
Join Date: Jul 2018
Car: e61
Default New Member and New turbos but running issue - 09-14-2018, 06:19 PM

Cars - 2008 e61 auto with 45k.

Mods- chargepipes, Rb turbo ones, inlets , custom intercooler, burger air filters, jb4, kw coilovers and m5 brakes

My issue- I just installed the turbos and upgraded my jb4( just purchased) to the newest version car was down for 6 weeks while waiting for parts. I had to change the battery and water pump at this time. Running map 1 93 octane

After the install and test drive car feels like its fighting back like a stutter or hesitation. It threw a code for the level sensor malfunction and threw a transmission error on the display but no actually codes. I used a scan tool and jb4 to register the battery.

I have no idea where to go next - Air fuel is at 20 at idle ? - Boost leak? Voltage ? Trans? Can a level sensor fault cause a drivability concer?

I appreciate any help
Reply With Quote
(#2)
Old
JuniorB JuniorB is offline
Junior Member
 
Posts: 303
Join Date: Mar 2016
Car: 2007 e60 5 series
Default 09-14-2018, 06:39 PM

If you had no codes prior, start with the battery, make sure it's holding volts and do a load test 24hrs after the car is off
Reply With Quote
(#3)
Old
glorentz glorentz is offline
New Member
 
Posts: 11
Join Date: Jul 2018
Car: e61
Default 09-15-2018, 08:30 AM

Went out this morning to look into battery issues, started the car and eveeything in the cluster was going nuts. Every fault coming up, trans, wiper suspension ext.

Pull the covers find water in the trunk the foam that holds the modules is soaked. So im guessing this is my issue.

I contact the dealer about the campaign and I missed it by 19 days. I am have to call Bmw of america Monday. I got the car is Febuary so i never heard of the lawsuit. Any advice on how to go about it would be great.

Only fault that is current is ride height control I can not communicate with the module so I assume its dead from the water.

Car still feels like its fighting me I am hoping its all related
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com