JB4tech.com - International Turbo Tuning Discussion
(#1476)
Old
Jm335i Jm335i is offline
New Member
 
Posts: 6
Join Date: Aug 2021
Car: 09 e93 335i
Default 03-14-2022, 06:07 PM

I did try it without the blue wire but had the same results. I'll try the flex bef I didn't think I needed it with a custom tune??
Thanks for all the help it's much appreciated.
Reply With Quote
(#1477)
Old
JonEQuest JonEQuest is offline
Junior Member
 
Posts: 43
Join Date: Mar 2019
Car: 2008 335i Convertible
Default 04-13-2022, 02:56 PM

How do I tell if I need the extra chip to utilize port injection with my JB4? I have had a used JB4 for a couple of years now and I was able to add the bluetooth adapter and it has worked great. But last month I added port inject with a BMS controller and my tuner says my port injection doens't seem to be turning on.
Reply With Quote
(#1478)
Old
THE BEAST THE BEAST is offline
Demigod
 
Posts: 1,725
Join Date: Apr 2016
Car: 2008 E93
Default 04-13-2022, 03:27 PM

Quote:
Originally Posted by JonEQuest
How do I tell if I need the extra chip to utilize port injection with my JB4? I have had a used JB4 for a couple of years now and I was able to add the bluetooth adapter and it has worked great. But last month I added port inject with a BMS controller and my tuner says my port injection doens't seem to be turning on.
Post a log to see what's going on.
I would think your tuner could tell you what he sees in the log though.
Reply With Quote
(#1479)
Old
JonEQuest JonEQuest is offline
Junior Member
 
Posts: 43
Join Date: Mar 2019
Car: 2008 335i Convertible
Default 04-13-2022, 03:32 PM

Quote:
Originally Posted by THE BEAST
Post a log to see what's going on.
I would think your tuner could tell you what he sees in the log though.
I am using Trebila, the one you recommended. He has had me set all the parameters and a BEF but says the PI is still not coming on. So far he has looked at logs and we are adjusting the fuel Bias up incrementally. I will be trying 80 soon when I get my car back together. I am swapping a trans cooler this week.
Reply With Quote
(#1480)
Old
THE BEAST THE BEAST is offline
Demigod
 
Posts: 1,725
Join Date: Apr 2016
Car: 2008 E93
Default 04-13-2022, 03:34 PM

Quote:
Originally Posted by JonEQuest
I am using Trebila, the one you recommended. He has had me set all the parameters and a BEF but says the PI is still not coming on. So far he has looked at logs and we are adjusting the fuel Bias up incrementally. I will be trying 80 soon when I get my car back together. I am swapping a trans cooler this week.
David knows his stuff with JB4. If he says you need a chip....u need a chip
Reply With Quote
(#1481)
Old
THE BEAST THE BEAST is offline
Demigod
 
Posts: 1,725
Join Date: Apr 2016
Car: 2008 E93
Default 04-13-2022, 03:39 PM

Quote:
Originally Posted by JonEQuest
How do I tell if I need the extra chip to utilize port injection with my JB4? I have had a used JB4 for a couple of years now and I was able to add the bluetooth adapter and it has worked great. But last month I added port inject with a BMS controller and my tuner says my port injection doens't seem to be turning on.
Btw, it's not an "extra" chip...it is to update to the latest chip. You replace one with the other.
Open up the JB4 and post a pic. Terry or someone will be able to see if you have the updated or outdated chip.
Reply With Quote
(#1482)
Old
JonEQuest JonEQuest is offline
Junior Member
 
Posts: 43
Join Date: Mar 2019
Car: 2008 335i Convertible
Default 04-13-2022, 04:01 PM

Quote:
Originally Posted by THE BEAST
Btw, it's not an "extra" chip...it is to update to the latest chip. You replace one with the other.
Open up the JB4 and post a pic. Terry or someone will be able to see if you have the updated or outdated chip.
I know it is a chip swap. So far Trebila has not said I need the chip but I am also looking for solutions. My JB4 was used when I bought it over 2 years ago so it may need a ROM chip update. I just updated the firmware as well. Just trying to make sure there is not some obvious reason it wouldn't work.
Reply With Quote
(#1483)
Old
THE BEAST THE BEAST is offline
Demigod
 
Posts: 1,725
Join Date: Apr 2016
Car: 2008 E93
Default 04-13-2022, 04:12 PM

Quote:
Originally Posted by JonEQuest
I know it is a chip swap. So far Trebila has not said I need the chip but I am also looking for solutions. My JB4 was used when I bought it over 2 years ago so it may need a ROM chip update. I just updated the firmware as well. Just trying to make sure there is not some obvious reason it wouldn't work.
The log would shed some light on the situation.
Or post a pic as I said.
Reply With Quote
(#1484)
Old
tmal's Avatar
tmal tmal is offline
Junior Member
 
Posts: 38
Join Date: Jun 2016
Car: BMW E92 335i
Default 04-23-2022, 04:04 PM

How can I temporarly disable PI if switch from E85 to normal gas? Already flashed pump flash and set meth flow to 0 and still see meth flow in my logs and fuel trim variance error.


2008 E92 335i AT - MMP1k's, MMP inlets/outlets, FMIC WAGNER EVO3, TMAP 3.5 Bar - PRW Stage 2+ LPFP - JB4 g5 - MHD BEF
Reply With Quote
(#1485)
Old
JonEQuest JonEQuest is offline
Junior Member
 
Posts: 43
Join Date: Mar 2019
Car: 2008 335i Convertible
Default 04-25-2022, 01:20 PM

Quote:
Originally Posted by THE BEAST
The log would shed some light on the situation.
Or post a pic as I said.
I swapped in the chip and the PI is definitly working. I ran a light bulb so I can see when/if my secondary fuel pump kicks on as well. The first time it triggered when I was about 1/2 mile from my house the increased fuel pressure blew apart my fuel regulator and left me stranded. It was a "new" aftermarket regulator I got off Amazon.com. Luckily I saved my old one and just swapped it back in. The port injection seems to come on as it should under heavy throttle. Unfortunately I also have a failing transmission so when it tries to downshift rapidly I get transmission errors. I still need to get to a road where I can do some data pulls for Trebila.
Reply With Quote
(#1486)
Old
Stprez Stprez is offline
New Member
 
Posts: 9
Join Date: May 2022
Car: 07 e90 335i
Default Forward facing manifold port injection help - 05-03-2022, 08:36 AM

Been piecing my kit together:
So far I have:
JB4 AIC
NP Boosted forward facing manifold with fuel rail
Precision race works PI fuel line
“Extending my own wires and vacuum line”
Making customer Charge pipe

Car already has dual 520 LPFPs and hobb switch

“My question is selecting injectors”
After much research I’m seeing EV14 42mm 550/750 injectors seem to be what most run however I found really good local deal on some Deatschwerks 95lb(1000cc) ev14 “48mm” universal injectors ….

Can I run them fitment wise maybe 1/4 spacers on rail brackets
Can I de-tune them enough for my application??
Reply With Quote
(#1487)
Old
JonEQuest JonEQuest is offline
Junior Member
 
Posts: 43
Join Date: Mar 2019
Car: 2008 335i Convertible
Default 05-03-2022, 09:34 AM

I can tell you that I have the 750-cc injectors and they may be slightly oversized. I am currently down to 30 for fuel bias. I am definitly NOT an expert on this but bigger may not be better.
Reply With Quote
(#1488)
Old
Stprez Stprez is offline
New Member
 
Posts: 9
Join Date: May 2022
Car: 07 e90 335i
Default 05-03-2022, 10:00 AM

Quote:
Originally Posted by JonEQuest
I can tell you that I have the 750-cc injectors and they may be slightly oversized. I am currently down to 30 for fuel bias. I am definitly NOT an expert on this but bigger may not be better.
Yes sir I feel the same way it’s just the price deal and availability at the moment… how about we change up The focus more to the height/size of the injector because I’m finding a lot of local LS injectors that are ev14 48 mm tall instead of the 42 mm size that most of the PI Kits come with…. Will they fit ���� “note I have a forward facing manifold with standard fuel rail

Last edited by Stprez; 05-03-2022 at 10:07 AM..
Reply With Quote
(#1489)
Old
themechanic@hotmail.ca themechanic@hotmail.ca is offline
New Member
 
Posts: 3
Join Date: May 2022
Car: 2008 335xi
Default 05-16-2022, 07:44 PM

Quote:
Originally Posted by ffwturbo
Disregard the relay
I have the same controller is the blue wire used to trigger the pump relay?
Attached Images
 
Reply With Quote
(#1490)
Old
themechanic@hotmail.ca themechanic@hotmail.ca is offline
New Member
 
Posts: 3
Join Date: May 2022
Car: 2008 335xi
Default N54 pi controller pump relay trigger - 05-16-2022, 08:12 PM

Quote:
Originally Posted by ffwturbo
Hi Terry,

I don't have a orange or thick yellow wire, but I do have a blue one. Is this where I can connect the secondary fuel pump?
I also don’t have the thick yellow or orange wire. My controller only has one yellow wire but it also has a blue wire. Is that blue wire used to trigger the pump relay for the meth pi pump or do I need to use a 15psi hobbs switch
Attached Images
 
Reply With Quote
(#1491)
Old
spinto1987@gmail.com spinto1987@gmail.com is offline
New Member
 
Posts: 15
Join Date: Feb 2022
Car: 335 n54
Default 05-19-2022, 10:01 AM

Hello . I'm close to installing port injection. 750cc + jb4 controller.

At this minute I'm with wmi jb4

I understand how it is wired. But I don't understand how to configure it.

Is there a starting point configuration? my initial goal is approximately 580 whp.- 600whp is with 17t turbos

Last edited by spinto1987@gmail.com; 05-19-2022 at 02:55 PM..
Reply With Quote
(#1492)
Old
spinto1987@gmail.com spinto1987@gmail.com is offline
New Member
 
Posts: 15
Join Date: Feb 2022
Car: 335 n54
Default Please help - 05-22-2022, 10:29 AM

Hello everyone.

finally i was able to install all the jb4 kit
fsb meth , pi controller jb4, 2step relay

*** 335 n54 turbos 17t Automatic zf 6hp -index 12, Pi phoenix with 750 cc injectors - walbro 450 lph ***

I have a serious configuration problem ***

When I activate "external output" "1" the car does not let me accelerate more than 2500 rpm. start 2 step relay . if i disable it everything works fine
How do I correctly activate the relay?

On the other hand, when I go to wot in the second gear at 6xxx rpm, it starts to fail as if it were very rich.

Could SOMEONE help me with a basic configuration so that it does not fail?

* I would like to be able to leave the wmi fsb functional in the future. with an injector only to cool. The orange cable of the Pi controller should go directly to the 12v of the wmi pump? *

My configuration is the following BEF RACE - MAP 6 - 750cc PI

14.1 - - 50
15 - - 50
16 - - 50
17 - 50 - 50
19 - 50 - 50
20 - 50 - 52
22 - 50 - 54
23 - 50 - 56
23 - 50 - 58
23 - 50 - 60
23 - 50 - 62
19 - 50 - 64

boost safe 30 - Dwp 48 - Pid gain 25 - auto shift boost redux 60 - FF / ADAP 101 - FOL 0

** WMI CONFIG

boost 0
signal scaling 99
min flow 0

External output

enabled 0
min rpm 2500
max rpm 7200
everything else in 0
Attached Files
File Type: csv 1.csv (5.4 KB, 17 views)
Reply With Quote
(#1493)
Old
Stprez Stprez is offline
New Member
 
Posts: 9
Join Date: May 2022
Car: 07 e90 335i
Default 05-30-2022, 07:50 PM

Quote:
Originally Posted by JonEQuest
I can tell you that I have the 750-cc injectors and they may be slightly oversized. I am currently down to 30 for fuel bias. I am definitly NOT an expert on this but bigger may not be better.
Kit has been fully installed in the car for over two weeks now and I have yet to get the port injection to work

Recheck the wiring multiple times
it has the JB4 Port injection controller
I have tried multiple different settings from different forms
Fuel enrichment reads but the trim levels go to max
Zero on the wmi
(no water meth kit is installed Just looking for reading from the port injection)
Yellow wire is on pin 9
White wire on pin 15 db5
Purple wire with the black wire adapted on Pin 21
I open the unit up to check for power and the green light blinks
I have tried meth scaling on 99 and 100
Fuel bias at 50 all the way down
Boost additive 75
Menu eight on the JB4 set to 0

I have also replaced my JB4 board thinking that was the issue and yes both of them work with my anti-lag

The duty bias adjust itself to 50 after multiple test runs

I do not have an ethanol sensor yet so I didn’t change any of those settings
Running HPI 650 injectors the positive side seems to be opposite of the port injection but injector should fire the same on both positive and negative side which I tested them to make sure🤷🏽*♂️
I even taped in a lightbulb to the injector harness which I have yet to see anything happen.

Huge fail trying to upload the screenshots from my iPhone maybe you can decipher these🤦🏽*♂️🤦🏽*♂️
Meth Prime/Purge
Boost Additive (0-75)
Signal Scaling (0-100)
Min Flow Boost (PSI)
External Output
Purge
75
100
2.0
Enabled
Min RPM
Max RPM
Min TPS
Min Gear
Min Advance
Min AFR
O
0
0.0
0.0
Ethanol Setup
BitO: JB4 2/3 FlexFuel Input
Bit1: JB4 14/15/16
FlexFuel Input
Bit2: DTML FlexFuel Input
Bit3: DTML WMI Input
CANCEL
SAVE

Default Wastegate Pos
PID Gain
Auto Shift Boost Redux
FF/Wastegate Adaption
Fuel Open Loop
Meth Safety Mode (0-3)
Meth Trigger Mode (0-3)
Max Boost 1st
Max Boost 2nd
Max Boost 3rd
Future Use A
TAP Setting
6-Cyl Timing Logging (0-6)
18A0S = 4, IJEOS = 5
dIl LTE
29.0
75
25
60
137
60
0
0
0.0
0.0
0.0
Options
Bit O: Disable Wheel Controls
Bit 1: Disable WG Adaption
CANCEL
SAVE
Attached Files
File Type: csv P30_M6_R1_220530_193728.csv (23.3 KB, 12 views)
File Type: csv P30_M6_R1_220530_212344.csv (15.9 KB, 9 views)
Reply With Quote
(#1494)
Old
temperamental's Avatar
temperamental temperamental is offline
Junior Member
 
Posts: 97
Join Date: Apr 2009
Car: 335i
Default 05-30-2022, 10:38 PM

@Stprez
Are you running hybrid turbos or a big single turbo?


JB4 Flex Fuel //MMP Stage 3 turbos//Custom Exhaust/BMS DCI//FMIC/KW suspension//Fuel-it Pi & Fuel it stage 4/BMS OCC's and too much to mention
Reply With Quote
(#1495)
Old
Stprez Stprez is offline
New Member
 
Posts: 9
Join Date: May 2022
Car: 07 e90 335i
Default 05-31-2022, 05:39 AM

Big Single
Dual 520 lpfp
Reply With Quote
(#1496)
Old
temperamental's Avatar
temperamental temperamental is offline
Junior Member
 
Posts: 97
Join Date: Apr 2009
Car: 335i
Default 05-31-2022, 12:54 PM

Looks like you got the wiring sorted but Double check the purple wire connection to #21 on the jb4 grey subconnector and the yellow wire to the tmap.

Consider logging on a lower map? The hpf struggles after 5000rpms.


JB4 Flex Fuel //MMP Stage 3 turbos//Custom Exhaust/BMS DCI//FMIC/KW suspension//Fuel-it Pi & Fuel it stage 4/BMS OCC's and too much to mention
Reply With Quote
(#1497)
Old
Stprez Stprez is offline
New Member
 
Posts: 9
Join Date: May 2022
Car: 07 e90 335i
Default 05-31-2022, 06:26 PM

Quote:
Originally Posted by temperamental
Looks like you got the wiring sorted but Double check the purple wire connection to #21 on the jb4 grey subconnector and the yellow wire to the tmap.

Consider logging on a lower map? The hpf struggles after 5000rpms.
No luck at all I even went back and hardwired the purple and black wire that go into number 21
The only WMI signal I see is it randomly flickers 1-2 on the gauge and that all you see on the logs


E90 ST/PI Dual 520 lpfp …slaugtamatic struggle for power😩😩
Reply With Quote
(#1498)
Old
Stprez Stprez is offline
New Member
 
Posts: 9
Join Date: May 2022
Car: 07 e90 335i
Default 06-01-2022, 08:33 AM

Quote:
Originally Posted by temperamental
Looks like you got the wiring sorted but Double check the purple wire connection to #21 on the jb4 grey subconnector and the yellow wire to the tmap.

Consider logging on a lower map? The hpf struggles after 5000rpms.
Still having no luck anyway you can post a screenshot of all of the settings on your JB4… I know the basic ones you’re supposed to change but maybe something else is wrong in my settings
I have been running Jb4/mhd backend and the big single for four years now and I’m just deciding to go to port injecction… I really don’t want to feel like I’ve wasted a whole bunch of money I had to miss something along the way🤔🤔… it could be possible that the port injection controller could be defective are there any other ways of testing it other than the blinking green light inside

I’m also wondering if I’m having issues with my high-pressure fuel pump I’m not getting any codes but just before I put the port injection on I started having a lot of high trim issues… I do have a spare used fuel pump laying around I’m debating on dropping in


E90 ST/PI Dual 520 lpfp …slaugtamatic struggle for power😩😩
Reply With Quote
(#1499)
Old
temperamental's Avatar
temperamental temperamental is offline
Junior Member
 
Posts: 97
Join Date: Apr 2009
Car: 335i
Default 06-01-2022, 05:55 PM

The main settings are:
Meth scaling to 99 or 100.
Steering wheel menu 8 to zero.
All Fuel Bias starting at 50 and after a log you can scale Fuel Bias in the rpm range where the Hpf pump is struggling.
All DB bias starting off at 50.

Choose the apprpriate Port injection BEF.

I think the single turbo firmware has a setting in FUD bit 3 that may have to be enabled?

There are no additional settings or options unless you scale Pi with flex fuel which is set in the ethanol settings.

The wiring are straight forward:
Red goes to ECU green connector or to Jb4 power wire. I chose to connect to the Jb4 red power wire.
Black goes to ground - make sure this cable has a, solid ground.
Purple to pin 21 jb4 grey subconnector - counted from the female side.
Yellow to pin 9 on jb4 usb cable Db9.
White to pin 15 on jb4 Db25 connector.
The newer Pi boxes have a thick orange wire to trigger a secondary fuel pump etc... I use mine to trigger the Fuelit stage 4 pump through a relay.

If Pi is working you should see corresponding signals in your log in the Fuel enrichment and meth column.

In the (iat) column you will see intake temps lowering when port injection flows.

There is not much else to check. You can email Steve at Fuelit directly, he is normally very helpful with these technical fuel
related issues/problems.


JB4 Flex Fuel //MMP Stage 3 turbos//Custom Exhaust/BMS DCI//FMIC/KW suspension//Fuel-it Pi & Fuel it stage 4/BMS OCC's and too much to mention

Last edited by temperamental; 06-02-2022 at 01:46 AM.. Reason: Added the Orange wire connection
Reply With Quote
(#1500)
Old
Stprez Stprez is offline
New Member
 
Posts: 9
Join Date: May 2022
Car: 07 e90 335i
Default 06-01-2022, 06:53 PM

Quote:
Originally Posted by temperamental
The main settings are:
Meth scaling to 99 or 100.
Steering wheel menu 8 to zero.
All Fuel Bias starting at 50 and after a log you can scale Fuel Bias in the rpm range where the Hpf pump is struggling.
All DB bias starting off at 50.

Choose the apprpriate Port injection BEF.

I think the single turbo firmware has a setting in FUD bit 3 that may have to be enabled?

There are no additional settings or options unless you scale Pi with flex fuel which is set in the ethanol settings.

The wiring are straight forward:
Red goes to ECU green connector or to Jb4 power wire. I chose to connect to the Jb4 red power wire.
Black goes to ground - make sure this cable has a, solid ground.
Purple to pin 21 jb4 grey subconnector - counted from the female side.
Yellow to pin 9 on jb4 usb cable Db9.
White to pin 15 on jb4 Db25 connector.

If Pi is working you should see corresponding signals in your log in the Fuel enrichment and meth column.

In the (iat) column you will see intake temps lowering when port injection flows.

There is not much else to check. You can email Steve at Fuelit directly, he is normally very helpful with these technical fuel
related issues/problems.
Currently running JB4_IJE0S_ST_E85_PI.bin (DME was swapped to IJE0S 3 yrs ago) (on3 turbo kit ceramic ball bearing 3years strong no shaft play🤷🏽*♂️)

I will check the FUD bit 3 once I get back to my garage after work tomorrow I started login with my tablet instead of my phone and it doesn’t like to upload logs online but I’ll keep trying


Is it a possible chance the anti-lag chip needs to be replaced I mean mine works perfectly with rolling anti-lag and I also bought a new JB4 G5 board just last week that came with the chips in it


E90 ST/PI Dual 520 lpfp …slaugtamatic struggle for power😩😩
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2022, JB4tech.com