N54Tech.com - International Turbo Racing Discussion
(#1)
Old
theshanestation theshanestation is offline
New Member
 
Posts: 15
Join Date: Oct 2020
Car: 2020 Kia Forte5 GT
Default Jb4 causing limp mode after flash - 10-07-2020, 05:59 AM

Hi all, this is my first post here.
I tried sending this via email directly to Burger, but so far it's radio silence:


I just installed the JB4 tuner 2 days ago on my 2020 Kia Forte GT, purchased from a dealer up here in Canada.

On day 1 I had Bluetooth connection issues.

With the way I placed it in the engine bay I thought that maybe the signal was being blocked.

It seemed the blue wire to the bluetooth was a little short, not allowing me to route the transmitter well, so I lengthened the blue wire a bit.

Connection was still flaky.

Then I tried bending the pins a little on the connector and it seemed to resolve the issue.

Gauges on the app worked and I was able to change maps.
I drove around a bit and everything was fine.
Did not do any logs.

On day 2 I tried to update the firmware.
This is when the real trouble started.
Initially, it looked like the flash to the new firmware 21/16/5 (JB4_P21_KIAV22.hex) was good.

1. Connected to JB4
2. Selected file
3. Moved phone directly beside the unit to get 100% green signal
4. Flashed
5. Checksum OK

But from then on the car would immediately go into limp mode collision warning, traction and check engine lights activated.

My first reaction was to change to a different flash. But I am no longer able to connect to the unit via Bluetooth. The handshake is never successful. I tried disabling all other nearby bluetooth connections (like phone to car), without success.

I tested voltage at the blue wire and am getting just shy of 5volts constantly.

As soon as I disconnect the JB4 from the car, everything goes back to normal. I tried connecting and disconnecting 3-4 times with always the same results:

JB4 connected to car = limp mode + unable to connect via Bluetooth.

Please help!

Shane.


2020 Forte5 GT
CAI
JB4

Location: Montreal, Canada
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com