JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
hardparker hardparker is offline
Junior Member
 
Posts: 64
Join Date: Nov 2017
Car: F25
Default OBD connector missing RPM socket 3 - 02-28-2018, 10:09 PM

I installed my PI setup today. Turns out my 4-pin Molex connector on the OBD cable doesn't have pin 3 socketed with a female electrical connection. So, there's no way to source RPM for the PI controller. I ordered up a new OBD cable from BMS, assuming it's got pin 3 wired as it should.

I had a really difficult time trying to get the pin installed in the Molex on the harness side. Seems straight forward, with a spring retainer on the metal pin body, and catch tab in the Molex body. No go. Eventually, it broke from fatigue of trying too many times, right where the crimp meets the pin body. I need to know the exact pin name and type to try to source one in town. Molex... what?

Finally, my E85 sensor is wired to pin 3 on the DB25, with bits 0 and 5 enabled, FUA set to 58, but I don't see E85 displayed in app. I'm running ISO 10T6 on an F25.

Last edited by hardparker; 03-01-2018 at 10:42 AM..
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 03-01-2018, 11:40 AM

You'll need to contact BMS for another pin and would suggest sending a copy of your user adjustment settings to JB4mobile support for the ethanol input. Could be a software issue.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
madrrio madrrio is offline
Junior Member
 
Posts: 36
Join Date: Sep 2016
Car: 335i M sport
Default 03-02-2018, 03:45 PM

Quote:
Originally Posted by hardparker
I installed my PI setup today. Turns out my 4-pin Molex connector on the OBD cable doesn't have pin 3 socketed with a female electrical connection. So, there's no way to source RPM for the PI controller. I ordered up a new OBD cable from BMS, assuming it's got pin 3 wired as it should.

I had a really difficult time trying to get the pin installed in the Molex on the harness side. Seems straight forward, with a spring retainer on the metal pin body, and catch tab in the Molex body. No go. Eventually, it broke from fatigue of trying too many times, right where the crimp meets the pin body. I need to know the exact pin name and type to try to source one in town. Molex... what?

Finally, my E85 sensor is wired to pin 3 on the DB25, with bits 0 and 5 enabled, FUA set to 58, but I don't see E85 displayed in app. I'm running ISO 10T6 on an F25.
talking to Donnie about this right now on email... let me know if you get anything before I do.

Thanks
Reply With Quote
(#4)
Old
hardparker hardparker is offline
Junior Member
 
Posts: 64
Join Date: Nov 2017
Car: F25
Default 03-02-2018, 09:39 PM

I got my port injection working after ordering a new "OBDII CABLE WITH JB4 SIDE CONNECTOR FOR RETROFIT" from burgertuning.com It did, indeed, have the pin 3 electrical socket terminal. I salvaged one of the pins from the old connector for the male side for pin 3. But if anyone needs one, the connector is a Molex 43020-0400 on the harness side, and the male pins are 0430310001.

I'll be troubleshooting my E85 sensor next. Any valid input would be appreciated. I'm fairly certain it's wired properly with black to ground, red to switched 12V and white to JB4 DB25 pin 3. Just need to know if bits other than 0 and 5 are required in the app. What about FUA 58?
Reply With Quote
(#5)
Old
madrrio madrrio is offline
Junior Member
 
Posts: 36
Join Date: Sep 2016
Car: 335i M sport
Default 03-03-2018, 09:19 AM

Quote:
Originally Posted by hardparker
I got my port injection working after ordering a new "OBDII CABLE WITH JB4 SIDE CONNECTOR FOR RETROFIT" from burgertuning.com It did, indeed, have the pin 3 electrical socket terminal. I salvaged one of the pins from the old connector for the male side for pin 3. But if anyone needs one, the connector is a Molex 43020-0400 on the harness side, and the male pins are 0430310001.

I'll be troubleshooting my E85 sensor next. Any valid input would be appreciated. I'm fairly certain it's wired properly with black to ground, red to switched 12V and white to JB4 DB25 pin 3. Just need to know if bits other than 0 and 5 are required in the app. What about FUA 58?
Those are the settings I'm running. Try latest firmware.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2022, JB4tech.com