N54Tech.com - International Turbo Racing Discussion
(#1)
Old
pherfurth pherfurth is offline
New Member
 
Posts: 4
Join Date: Jun 2019
Car: N54 135i
Default N54 HELP, can not solve this problem - 09-30-2021, 06:15 PM

I have a n54 135i fbo, jb4, MHD back end flash.

The car runs great when just normal driving. When applying 100% throttle there is almost no power coming in and a few seconds into the run the jb4 switches the map from map 2, to map 4.

I today replaced the coil packs and spark plugs using delphi and ngk 1 step colder plugs.
I also removed the vanos solenoids to give them a cleaning.
This did nothing to solve the issue. I took the car for a test drive and it did the same thing while I was logging, no power and a switch to map 4.
I am almost out of ideas as to what it can be and need someone who is better at reading logs than I am to help.

I have attached the log in a csv file. I never let my foot off the throttle I had the car in manual shift mode
Attached Files
File Type: csv 9.30.2021 data log .csv (33.7 KB, 20 views)
Reply With Quote
(#2)
Old
Dwifter Dwifter is offline
New Member
 
Posts: 16
Join Date: Apr 2021
Car: 2008 335i
Default 09-30-2021, 07:07 PM

I'm having the same issue. My car still acts up if I disable the jb4 and drive on a stock tune or with mhd
Reply With Quote
(#3)
Old
THE BEAST THE BEAST is offline
Demigod
 
Posts: 1,629
Join Date: Apr 2016
Car: 2008 E93
Default 09-30-2021, 07:23 PM

Quote:
Originally Posted by pherfurth
I have a n54 135i fbo, jb4, MHD back end flash.

The car runs great when just normal driving. When applying 100% throttle there is almost no power coming in and a few seconds into the run the jb4 switches the map from map 2, to map 4.

I today replaced the coil packs and spark plugs using delphi and ngk 1 step colder plugs.
I also removed the vanos solenoids to give them a cleaning.
This did nothing to solve the issue. I took the car for a test drive and it did the same thing while I was logging, no power and a switch to map 4.
I am almost out of ideas as to what it can be and need someone who is better at reading logs than I am to help.

I have attached the log in a csv file. I never let my foot off the throttle I had the car in manual shift mode
02 in bank 1 maybe ?
Codes ?
Reply With Quote
(#4)
Old
pherfurth pherfurth is offline
New Member
 
Posts: 4
Join Date: Jun 2019
Car: N54 135i
Default 09-30-2021, 07:23 PM

Same I switch to map 4 which is the stock tuning and the car runs fine, just no power comparative
Reply With Quote
(#5)
Old
pherfurth pherfurth is offline
New Member
 
Posts: 4
Join Date: Jun 2019
Car: N54 135i
Default 09-30-2021, 07:52 PM

The only codes that come up are the 2FBE code, and the 2DED code
Reply With Quote
(#6)
Old
Cannon @ BMS Cannon @ BMS is offline
Junior Member
 
Posts: 82
Join Date: Sep 2021
Car: Evo VIII
Default 10-01-2021, 08:45 AM

Looks like bank 1 is going very lean. Try resetting adaptions and run another log in map 4. If it appears that the car begins running lean again over time, may need to replace bank 1 upstream o2.
https://imagizer.imageshack.com/img923/4594/Z5FwRJ.jpg
Upload 3rd or 4th gear log from 2k to redline at wide open throttle with traction control off


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#7)
Old
pherfurth pherfurth is offline
New Member
 
Posts: 4
Join Date: Jun 2019
Car: N54 135i
Default ran another log - 10-01-2021, 06:11 PM

I have attached the new log below in csv file.
I also used my Bavarian technic cable to run a diagnostic on the car. It showed that my fuel pumps and injectors were all seemingly running fine. Maybe my problem is the o2 sensors, or maybe a boost solenoid ? Any further help is beyond greatly appreciated
Attached Files
File Type: csv 10.1.21 log map 4 .csv (28.5 KB, 14 views)
Reply With Quote
(#8)
Old
Cannon @ BMS Cannon @ BMS is offline
Junior Member
 
Posts: 82
Join Date: Sep 2021
Car: Evo VIII
Default 10-04-2021, 09:23 AM

Most likely an O2 sensor, swapped O2 sensors, or O2 connections.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com