N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Trickcruiser's Avatar
Trickcruiser Trickcruiser is offline
Senior Member
 
Posts: 515
Join Date: Oct 2009
Car: 335i
Default Evil1 - 6466 26lb dyno day - 11-20-2017, 08:48 AM

Well, I think this is the last video of the Evil 1 that i will be able to claim... Matt, the new owner, took her to a local (TX) dyno day on Saturday and she did well!


First pull she actually blew the tires off on the rollers! Man card achievement unlocked!

https://www.youtube.com/watch?v=RhdHsWafQrQ



637/533 at 26lbs the street map with the AC on (read mixed feedback on this robbing power or not).





Next up is going to be all his project. With the Fuel Return from Fuel-It and support from BMS and EMP, I expect him to get 7-750whp out of it!!


Reply With Quote
(#2)
Old
THE BEAST THE BEAST is offline
Legend
 
Posts: 1,103
Join Date: Apr 2016
Car: 2008 E93
Default 11-20-2017, 10:11 AM

Damn nice !
Reply With Quote
(#3)
Old
ShocknAwe ShocknAwe is offline
Senior Member
 
Posts: 767
Join Date: Sep 2012
Car: 135i
Default 11-20-2017, 12:05 PM

Which kit/fuel was this again?


2010 135i M-Sport 6MT Jet Black
N54 | Build Thread
Reply With Quote
(#4)
Old
Trickcruiser's Avatar
Trickcruiser Trickcruiser is offline
Senior Member
 
Posts: 515
Join Date: Oct 2009
Car: 335i
Default 11-20-2017, 12:08 PM

Quote:
Originally Posted by THE BEAST
Damn nice !
Thanks

Quote:
Originally Posted by ShocknAwe
Which kit/fuel was this again?
Fuel-it stage 3 and basic PI with BMS controller.
100% e85


Reply With Quote
(#5)
Old
psixtc's Avatar
psixtc psixtc is offline
Junior Member
 
Posts: 30
Join Date: Aug 2017
Car: 135i
Default 11-20-2017, 01:58 PM

I'm glad you shared this Tony!

The dyno day was mostly Camaros and Vettes, but the Evil1 surprised the hell out of every person there. It was actually one of the highest HP runs of the day (highest was 681hp from Camaro SS 1LE w/LSA blower and meth).
I'm lucky to have such a solid starting point, especially being my DD, but plan on having a little more fun with it after the holidays.
I'm curious about the e85 content at the local stations , so the analyzer will be added with the fuel return system. I'll add ethanol content data to future posts once that's installed.

My biggest wish is that there were more 1/4mi tracks out here (North Dallas) to see what she'll do. I guess I'm stuck with 1/8mi for now.
Reply With Quote
(#6)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,841
Join Date: Jan 2008
Default 11-20-2017, 04:18 PM

Nice start! Log?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#7)
Old
AbacusRacingN54 AbacusRacingN54 is offline
Junior Member
 
Posts: 303
Join Date: Aug 2014
Car: 07 335i
Default 11-20-2017, 06:11 PM

Big props for using SAE correction. Bet that’s real fun to drive
Reply With Quote
(#8)
Old
Trickcruiser's Avatar
Trickcruiser Trickcruiser is offline
Senior Member
 
Posts: 515
Join Date: Oct 2009
Car: 335i
Default 11-20-2017, 07:05 PM

Quote:
Originally Posted by Terry @ BMS
Nice start! Log?
Attached is the log from the last pull. Looks pretty solid to me!
Any feedback is always appreciated.
Attached Files
File Type: csv 2017-11-18 11_03_18 RunFile_004.csv (11.0 KB, 47 views)


Reply With Quote
(#9)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 11-20-2017, 07:28 PM

Nice...

Lower FOL to 40 and make sure the secondary pump is kicking on.




Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#10)
Old
psixtc's Avatar
psixtc psixtc is offline
Junior Member
 
Posts: 30
Join Date: Aug 2017
Car: 135i
Default 11-21-2017, 01:55 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Nice...

Lower FOL to 40 and make sure the secondary pump is kicking on.

Thanks for the feedback Steve. I'll give that a shot.

And thanks for attaching the log Tony!
Reply With Quote
(#11)
Old
Trickcruiser's Avatar
Trickcruiser Trickcruiser is offline
Senior Member
 
Posts: 515
Join Date: Oct 2009
Car: 335i
Default 11-21-2017, 02:05 PM

Quote:
Originally Posted by psixtc
Thanks for the feedback Steve. I'll give that a shot.

And thanks for attaching the log Tony!
Matt, I put the secondary LPFP on a small LED in the vent of the P3 vent gauge. It should light up around 15lbs. This was done because the Hobbs was stuck or something. After threading it in and back out it worked again. Might want to consider replacing that switch if it is not working again...


Reply With Quote
(#12)
Old
psixtc's Avatar
psixtc psixtc is offline
Junior Member
 
Posts: 30
Join Date: Aug 2017
Car: 135i
Default 11-21-2017, 02:24 PM

Quote:
Originally Posted by Trickcruiser
Matt, I put the secondary LPFP on a small LED in the vent of the P3 vent gauge. It should light up around 15lbs. This was done because the Hobbs was stuck or something. After threading it in and back out it worked again. Might want to consider replacing that switch if it is not working again...
you sold me junk

Kidding. I'll check the switch and probably order a new one since it has a history of acting up. I don't remember seeing the LED illuminate recently, but I'll pay more attention on the next trip down the tollway.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com