N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Souprah Souprah is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335xi 6mt
Default Bank 1 leaning out (Map 4 kickback) and cannot figure out why - 07-23-2019, 02:45 AM

https://***********/u/souprah/bank-1...log=0&data=1-4

Iím kinda stuck here with a Bank 1 lean condition.

Car drives around normally fine, but as soon as it sees boost above stock bank one just goes super lean.

1. Thought it would be injectors, so I replaced bank 1 injectors with good injectors and same thing. I was running open ******** while this happened so I figured it could have been because of that and I did start getting a ďLambda bank 2 trimm controlĒ code.

2. Put exhaust back on and replaced both Primary O2ís and still the same issue (no more code though).

3. I then swapped bank 1 and 2 injectors to see if it would atleast move banks and no change in logs. Bank 1 still leans out.

4. Then I swapped coils from bank 1 and bank 2 and same thing (All Delphi). Gonna check plugs out tomorrow but it wouldnít make sense as to why plugs would cause a lean condition. They are NGKís with about 3,000 miles on them.

Didnít think it would be this deep of an issue. Only thing I can think of to do next is check out MOSFETS and maybe swap out the secondary o2ís?

Any help would be appreciated! Log posted above

Mods:
07 XI 6spd
FBO
VRSF 7ĒHD
Walbro 450 running e60
JB4 with e85 BEF
VRSF DPís
BMS DCI
Stock turbos
Reply With Quote
(#2)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,133
Join Date: Apr 2014
Car: E92 335XI
Default 07-23-2019, 12:20 PM

Hey can you just upload the CSV file? We don't use 3rd party host sites for log viewing.

Thanks!



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#3)
Old
Souprah Souprah is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335xi 6mt
Default 07-24-2019, 10:15 AM

Oops sorry! Yeah forsure I will do that once I get to my laptop. Thanks!

Update: So far I reflashed the e85 backend flash and I am running straight 93. Bank 1 seems fine right now and the car isnít leaning out in bank 1 under WOT. Gonna try to add some e85 and see if anything changes!

Also going to check my mosfets just to be safe but hopefully car will be fine now. Doubtful since I really didnít fix anything but we will see!
Reply With Quote
(#4)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,133
Join Date: Apr 2014
Car: E92 335XI
Default 07-24-2019, 09:55 PM

Quote:
Originally Posted by Souprah
Oops sorry! Yeah forsure I will do that once I get to my laptop. Thanks!

Update: So far I reflashed the e85 backend flash and I am running straight 93. Bank 1 seems fine right now and the car isnít leaning out in bank 1 under WOT. Gonna try to add some e85 and see if anything changes!

Also going to check my mosfets just to be safe but hopefully car will be fine now. Doubtful since I really didnít fix anything but we will see!



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#5)
Old
Souprah Souprah is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335xi 6mt
Default 07-29-2019, 01:09 PM

*2 Years Later*

Here is the CSV file! Car was running great for a few days and then I got one random map 4 kickback. Still have not checked MOSFETS but will be doing that tonight!

Let me know what you think thanks again
Attached Files
File Type: csv 719 bank 1 lean.csv (11.8 KB, 20 views)
Reply With Quote
(#6)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,133
Join Date: Apr 2014
Car: E92 335XI
Default 07-29-2019, 10:28 PM

Did you add e85?

Afr still looks off, and you get some bank to bank variations



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#7)
Old
Souprah Souprah is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335xi 6mt
Default 08-12-2019, 11:16 AM

I finally added some e85 and have been driving the car around. No more problems really. Still makes me wonder why my car was doing it before. Going to go ahead and pull through with the Trebila tune hoping the car stays healthy. Here are a few more recent logs I have of the car!
Attached Files
File Type: csv 2-3 pull trebila.csv (9.9 KB, 10 views)
File Type: csv 2019-08-07 20_47_19 (diag bank 1)_Map-5 34 pull 30 to 120mph.csv (20.4 KB, 13 views)
File Type: csv 2019-07-31 e60 3rd pull.csv (8.2 KB, 16 views)
Reply With Quote
(#8)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 6,133
Join Date: Apr 2014
Car: E92 335XI
Default 08-12-2019, 01:17 PM

Enable 6cyl timing

And over next few days monitor both banks afr



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com