N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Mid_Night_F20 Mid_Night_F20 is offline
Junior Member
 
Posts: 37
Join Date: Mar 2017
Car: Bmw 125i F20
Default BMW N20 motor - stalling/hesitating @ idle - 09-30-2017, 12:50 AM

Hi guys,

Running the N20 motor and after installing a full turboback ******* exhaust the car is sometimes stalling & often hesitating at idle while stationary with Drive gear selected and foot on the brake. In neutral all runs smooth.

The idle seems to be a bit too low also - 650-700 rpm.

Has anybody experienced this? Any solution?

Appreciate any advice !
Reply With Quote
(#2)
Old
Aekdbrich Aekdbrich is offline
New Member
 
Posts: 20
Join Date: Feb 2018
Car: 2014 328xi F30
Default 05-02-2018, 08:55 PM

Quote:
Originally Posted by Mid_Night_F20
Hi guys,

Running the N20 motor and after installing a full turboback ******* exhaust the car is sometimes stalling & often hesitating at idle while stationary with Drive gear selected and foot on the brake. In neutral all runs smooth.

The idle seems to be a bit too low also - 650-700 rpm.

Has anybody experienced this? Any solution?

Appreciate any advice !
Did you figure this out? Having the same issue now
Reply With Quote
(#3)
Old
Mid_Night_F20 Mid_Night_F20 is offline
Junior Member
 
Posts: 37
Join Date: Mar 2017
Car: Bmw 125i F20
Default 05-02-2018, 09:25 PM

Quote:
Originally Posted by Aekdbrich
Did you figure this out? Having the same issue now
Nah mate, but I'm hearing its to do with no back pressure due to a ******* exhaust.

Few options I'm still considering are to:

Add a highflow *** to your system/ get a catted ** to provide some back pressure for the turbo

or

Get the new BM3 tune which allows you to adjust your idle speed, maybe the tune itself might offer more idle stability itself? I'm just not sure yet if I wanna switch from JB4 to BM3, need some dyno results before I make a decision.

For now just ride with your aircon on, its raises the idle a bit

let me know how you go
Reply With Quote
(#4)
Old
Aekdbrich Aekdbrich is offline
New Member
 
Posts: 20
Join Date: Feb 2018
Car: 2014 328xi F30
Default 05-02-2018, 09:40 PM

Quote:
Originally Posted by Mid_Night_F20
Nah mate, but I'm hearing its to do with no back pressure due to a ******* exhaust.

Few options I'm still considering are to:

Add a highflow *** to your system/ get a catted ** to provide some back pressure for the turbo

or

Get the new BM3 tune which allows you to adjust your idle speed, maybe the tune itself might offer more idle stability itself? I'm just not sure yet if I wanna switch from JB4 to BM3, need some dyno results before I make a decision.

For now just ride with your aircon on, its raises the idle a bit

let me know how you go
My issue may be a little different. I am currently running BM3, but am having issues when the car is at a stop under load. It'll idle low, around 600 and then misfire, placing me into limp mode. I've replaced coils and plugs. I suspect it to be an injector or the Vanos Solenoids. It's time for me to head to the mechanic and hopefully we get it figured. It's been driving me nuts.
Reply With Quote
(#5)
Old
Mid_Night_F20 Mid_Night_F20 is offline
Junior Member
 
Posts: 37
Join Date: Mar 2017
Car: Bmw 125i F20
Default 05-02-2018, 10:00 PM

I see, what happens when you flash it back to stock tune?

Could be different issue to mine I guess, all I know is that mine has started after the full exhaust was fitted, could be O2 sensor related which a flash tune should fix on mine?

sorry can't offer too much help..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com