N54Tech.com - International Turbo Racing Discussion
(#1)
Old
stormchaser7's Avatar
stormchaser7 stormchaser7 is offline
New Member
 
Posts: 15
Join Date: Jan 2015
Car: 135I
Default Misfires on multiple cylinders on WOT - 01-08-2016, 11:53 AM

Had the water pump go out on me at 73k. I have an aftermarket warranty so I took it to the dealer. They diagnosed misfires on cylinders 5 and 6. They opted to swap fuel injectors - no charge. Got the car back and it still misfires on WOT. They changed the coils on 5&6 and it still didn't fix the issue. Now I get misfires on 3,5,6. I am thinking HPFP. Pulled my JB4 before taking it in so I can't run any logs right now but I would put it back in and log if it helps diagnose the issue. What should I be looking for in the log? HPFP values?
Reply With Quote
(#2)
Old
stormchaser7's Avatar
stormchaser7 stormchaser7 is offline
New Member
 
Posts: 15
Join Date: Jan 2015
Car: 135I
Default 01-08-2016, 12:41 PM

Fault codes I'm getting:

Mixture Control: mixture too lean 0029E0
Throttle angle - intake manifold Vacuum 002D2E
Misfire detection cylinder 3 in 2 firing order 0029CF
Misfire Cyl. 5 0029D1
Misfire Cyl. 6 0029D2
Misfire detection error summation 0029CC
Mixture control 2: mixture too lean 0029E1
Reply With Quote
(#3)
Old
Rushan's Avatar
Rushan Rushan is offline
Legend
 
Posts: 1,188
Join Date: May 2014
Car: 335i E92 2009
Default 01-08-2016, 12:46 PM

Just question, they replaced the injectors and coded it or just replaced the injector ?


09 E92 335i - Hot-Climate Middle East package, M Sports suspension, 19" Rims, 6AT fully built internals, bushings, raybestos clutches and sonnax with xHP stage 3, Differential lockdown, New RB Turbo CHRA, JB4 - Map 3 70 adder with N20 TMAP - MHD BMS Race Flash with Tuned Duty Bais and PID - BMS Oil Cooler Valve - RB PCV - K&N DCI - AFE Air Scoops - 98 Super Fuel - WAGNER FMIC - 3" down's, RB Inlets- BMS charge pipe With Tial BOV - BMS Meth Kit with FSB, 30/70 Water/Meth on CM12 nozzle
Reply With Quote
(#4)
Old
stormchaser7's Avatar
stormchaser7 stormchaser7 is offline
New Member
 
Posts: 15
Join Date: Jan 2015
Car: 135I
Default 01-08-2016, 12:49 PM

They replaced all 6 injectors and coded them to the car. They are the latest injectors. Priors were original to the engine (2010) Had walnut blast done in Novemver
Reply With Quote
(#5)
Old
psychosinmylobby psychosinmylobby is offline
Junior Member
 
Posts: 216
Join Date: Nov 2013
Car: 07 e92
Default 01-08-2016, 12:57 PM

The 5 and 6 misfires stayed in 5 and 6. Sounds cylinder specific, it maybe plugs. How long have had the plugs?

Logs can tell HPFP pressure under load which can show it going out:

http://www.e90post.com/forums/showthread.php?t=1120250
Specifically FP H and FP L:
http://www.n54tech.com/forums/showthread.php?t=21269
Reply With Quote
(#6)
Old
stormchaser7's Avatar
stormchaser7 stormchaser7 is offline
New Member
 
Posts: 15
Join Date: Jan 2015
Car: 135I
Default 01-08-2016, 01:30 PM

plugs were done in last June along with a complete set of new coils
Reply With Quote
(#7)
Old
Rushan's Avatar
Rushan Rushan is offline
Legend
 
Posts: 1,188
Join Date: May 2014
Car: 335i E92 2009
Default 01-09-2016, 01:15 AM

The best way to plug back your JB and get a log which can really make things easier to troubleshoot on what's going on before the misfire


09 E92 335i - Hot-Climate Middle East package, M Sports suspension, 19" Rims, 6AT fully built internals, bushings, raybestos clutches and sonnax with xHP stage 3, Differential lockdown, New RB Turbo CHRA, JB4 - Map 3 70 adder with N20 TMAP - MHD BMS Race Flash with Tuned Duty Bais and PID - BMS Oil Cooler Valve - RB PCV - K&N DCI - AFE Air Scoops - 98 Super Fuel - WAGNER FMIC - 3" down's, RB Inlets- BMS charge pipe With Tial BOV - BMS Meth Kit with FSB, 30/70 Water/Meth on CM12 nozzle
Reply With Quote
(#8)
Old
stormchaser7's Avatar
stormchaser7 stormchaser7 is offline
New Member
 
Posts: 15
Join Date: Jan 2015
Car: 135I
Default 01-11-2016, 11:13 PM

Installed the JB4 and logged a few pulls. No engine misfires this time. Roads were wet so I only did a short run. Let me know if you find anything that looks out of sorts. TIA
Attached Files
File Type: zip 2016-01-11 21_28_6.zip (44.1 KB, 65 views)
Reply With Quote
(#9)
Old
omarmarji's Avatar
omarmarji omarmarji is offline
Senior Member
 
Posts: 912
Join Date: May 2015
Car: n54 335
Default 01-12-2016, 12:01 AM

I had this problem , my o2 sensor was lose , but I ended up changing them both to fix it (upstream )


751WHP 688WTQ
JP Works Kit Record
SOLD: E90 335i 751whp 688WTQ
CURRENT: E82 135i (under construction)
Visit my website VaderSolution.com !
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com