N54Tech.com - International Turbo Racing Discussion
(#1)
Old
e36bmer e36bmer is offline
New Member
 
Posts: 25
Join Date: Jul 2014
Car: 2011 135i
Default S55, Pure S2 turbos - No boost after hard pulls - 07-16-2020, 11:01 AM

Hi, I have an S55 with Pure stage 2 turbos. First, I feel like the turbo lag is way more than I would expect. Second, it keeps going into a limp mode with no boost when I do a hard pull, but I get no codes thrown or anything. When I power off and on, then things go back to normal until the next time I floor it. I would appreciate any help on the topic. I don't see anything jump out to me in the logs or in the stock ECU. I've updated to the latest firmware. I also hooked up MHD to try to see if this car has a BEF or some other tune on it already.

Can I get some help to see if there is anything I can look into to fix this?



Attached Files
File Type: csv P4_M2_R5_200716_1209.csv (41.5 KB, 29 views)


2013 X5M - MCB/Black, JB4, Dual CM10 Meth, Velos Stage 2+, Kinugawa Compressor Wheels (Mine)

2011 135i - AW/TerraCotta, JB4, MHD BEF, FBO, DCT (Wifey)

2005 M3 - Interlagos Blue / Black ZCP, all kinds of goodies (Toy)
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,360
Join Date: Jan 2008
Default 07-16-2020, 11:30 AM

What fuel, mods, etc? Boost itself seems fine.

Set duty bias to 50 across the board, pid gain to 20
Attached Images
 


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
e36bmer e36bmer is offline
New Member
 
Posts: 25
Join Date: Jul 2014
Car: 2011 135i
Default 07-16-2020, 11:39 AM

Quote:
Originally Posted by Terry @ BMS
What fuel, mods, etc? Boost itself seems fine.

Set duty bias to 50 across the board, pid gain to 20
Do you see in the second pull where boost drops to essentially nothing but target is still the same at 22 or so?

Running 93 pump., Bms intakes, BMS charge ***** (but stock j pipe), JB4, free flow VSRF dowpipes, Akrapovic full exhaust, CSF intercooler and heat exchanger.


2013 X5M - MCB/Black, JB4, Dual CM10 Meth, Velos Stage 2+, Kinugawa Compressor Wheels (Mine)

2011 135i - AW/TerraCotta, JB4, MHD BEF, FBO, DCT (Wifey)

2005 M3 - Interlagos Blue / Black ZCP, all kinds of goodies (Toy)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com