N54Tech.com - International Turbo Racing Discussion
(#1)
Old
mojo20032004 mojo20032004 is offline
Junior Member
 
Posts: 391
Join Date: Dec 2014
Car: e90 335i
Default Throttle body codes after mosfet replaced - 07-25-2019, 09:42 AM

Had all 6 mosfets replaced since 1 2 3 got fried after 12yrs on my 07 335i. Installed ecu, put battery cable back on and then went inside car to clear dme codes via mhd, as well as other parameters. Started the car and has a very choppy idle. Turned car off reset codes once again and throttle values, press gas for 30 seconds to relearn and still nothing. Codes will NOT clear with either jb4, mhd or battery reset. I havent tried Bav tool yet.

Pulled codes 2cf9,2cfa, 2d09, 2d1d
2cf9. -Throttle valve potentiometer 1
2cfa Throttle valve potentiometer 2
2cfb. Throttle valve adaption value
2d09. Throttle
2d1d. Accelerator-pedal module pedal, position sensor 1 voltage supply

Checked throttle body main power connection, it was on, removed it and blew inside it and reconnected, no diffrence. Pulled battery cable off for 10min, no diffrence. Rechecked ecu connection, everything is fine


Is my throttle body magically taking a dump after mosfets got replaced? I did drive it home maybe 2 miles after mosfets fried as I was around the corner from the house. Car does have 103k and had valve cleaning down around the 70k marker


2007 e90 335i
Hexon turbos
Fbo with Cpi tuned at e55
Jsr Custom tuned
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com