JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default Map 1 Log review help!!! - 05-15-2019, 07:11 AM

Just need a little bit of help reviewing this log. The JB4 settings I'm using are the only ones that will get the car to not overboost and kick me back to Map 4.

My Mods:

E30 mix
VSRF DCI
Charge Pipe Upgrade w/ Tial BOV
JB4 G5 w/ MHD BEF (w/ adjusted Fuel Table)
3" ***

And by adjusted, I just changed the fuel table to be a little more rich. Not personally comfortable with shooting for low 12s up top for an AFR on pump gas or anything less than an E50 mix. Just personal preference.
Attached Files
File Type: csv 2019-05-04 11_15_47_Map-1 pid25_wgdc60.csv (10.7 KB, 153 views)
Reply With Quote
(#2)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 1,337
Join Date: Jun 2011
Car: 135i N54
Default 05-15-2019, 09:05 AM

Weird log. Your PWM i just a bottomed out line with no adjustment. Not even sure how you are getting any boost control. Are the big negative duty bias adjustments to try and reduce something? Feels like it is having a hard time opening the WG enough to dial in boost.

Maybe check Menu 4 to make sure it didn't get changed from the BEF setting, kinda reminds me of that being set wrong.

Stock turbos? Any other changes to the car recently?
Reply With Quote
(#3)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-15-2019, 10:40 AM

The duty bias is set so low because when I had the stock settings in the JB4 and was running on Map 5, it would kick me back to Map 4 and my WGDC would bottom out. Before the BEF it did not do this, but I'm using the pump gas BEF, just running a slightly richer fuel table than the one provided. And yes, its stock turbos. No other changes to the car recently. Should I go back to stock settings and run Map 4 or Map 1 and post that log?
Reply With Quote
(#4)
Old
Dave @ BMS's Avatar
Dave @ BMS Dave @ BMS is online now
Super Moderator
 
Posts: 8,522
Join Date: Apr 2014
Car: E92 335XI
Default 05-15-2019, 09:36 PM

Quote:
Originally Posted by KikRox268
The duty bias is set so low because when I had the stock settings in the JB4 and was running on Map 5, it would kick me back to Map 4 and my WGDC would bottom out. Before the BEF it did not do this, but I'm using the pump gas BEF, just running a slightly richer fuel table than the one provided. And yes, its stock turbos. No other changes to the car recently. Should I go back to stock settings and run Map 4 or Map 1 and post that log?
Stock settings (double check) & lets see map 1 logs


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#5)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-16-2019, 07:16 AM

So I changed all the settings back to default and I took a log on Map 1 and on Map 4. I triple checked to make sure that it is on 4/2, which it is. So now my thinking is, does 4/4 work as intended? If so, that means I could load a flash only tune while using the JB4 guages and datalogging correct? And if I can't do that, then load my stock map and go back to 4/3 and see if the problem persists? Car seems to hit 18psi regardless of which map the Jb4 is on. Map 4 target is 8 psi, car hits way more boost than that. Or I'm not quite understanding the relationship of the BEF to the JB4, which I'm currently researching but not finding the exact answer that I'm looking for. Logs are attached for both.
Attached Files
File Type: csv 2019-05-15 17_39_27_Map-1.csv (6.9 KB, 140 views)
File Type: csv 2019-05-15 19_16_52_Map-4.csv (9.6 KB, 131 views)

Last edited by KikRox268; 05-16-2019 at 09:08 AM..
Reply With Quote
(#6)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 1,337
Join Date: Jun 2011
Car: 135i N54
Default 05-16-2019, 08:17 AM

Massive overboost. Something is set wrong between JB4 and the flash because your boost is following the flash target, not the JB4 target. Maybe try flashing back to stock and using 4/3 as the next test.
Reply With Quote
(#7)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-16-2019, 09:10 AM

Quote:
Originally Posted by Vorsprung_CJB
Massive overboost. Something is set wrong between JB4 and the flash because your boost is following the flash target, not the JB4 target. Maybe try flashing back to stock and using 4/3 as the next test.
Definitely going to do that today and see what happens. Will post logs either today or tomorrow depending on time. Also, does the 4/4 setting work as intended??? Everything I've read so far states that you can't run a flash tune with the JB4 installed.
Reply With Quote
(#8)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-16-2019, 05:04 PM

So it's definitely an issue with the BEF . Attached is a Map 1 log.
Attached Files
File Type: csv 2019-05-16 18_40_48_Map-1.csv (9.4 KB, 132 views)
Reply With Quote
(#9)
Old
Dave @ BMS's Avatar
Dave @ BMS Dave @ BMS is online now
Super Moderator
 
Posts: 8,522
Join Date: Apr 2014
Car: E92 335XI
Default 05-16-2019, 10:33 PM

Quote:
Originally Posted by KikRox268
So it's definitely an issue with the BEF . Attached is a Map 1 log.
This looks better

I think your LPFP sensor may be shot BTW- value is pegged at 49psi

Which BEF did you load prior?


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#10)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 04:11 AM

This is the BEF that I used (JB4_IJE0S_PUMP_USA.bin) and it's always read that on the JB4 datalogs, but not on the MHD datalogs I have, but even on those I noticed that, although it's within the limits, it is still on the lower end. I just looked at my MHD logs and they all read 56 psi for my LPFP.
Reply With Quote
(#11)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 584
Join Date: Jun 2017
Car: 07 E90 335i
Default 05-17-2019, 05:26 AM

Quote:
Originally Posted by KikRox268
This is the BEF that I used (JB4_IJE0S_PUMP_USA.bin) and it's always read that on the JB4 datalogs, but not on the MHD datalogs I have, but even on those I noticed that, although it's within the limits, it is still on the lower end. I just looked at my MHD logs and they all read 56 psi for my LPFP.
Make sure you have the right DME, you could possibly have a MSD80 which could mean you would need to use I8A0S.

When you connect to MHD it usually tells you which DME you have

In your log it shows firmware 32/14/0, Engine OBDII / All Other

latest firmware is 32/14/2 , engine usually shows E Series - N54

Do you have a OBD cable plugged in at the same time running JB4


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#12)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 07:04 AM

According to the MHD I have the IJE0S. When I first got the car I tried to load my brothers custom tune from his 335i and couldn't and he has an I8A0S. I'll update the firmware to the most recent and see if that changes it from OBD II to E series. And no, I only hook my OBD up if I'm using my MHD for something, other than that, that cable stays unplugged and in my glove box. As far as my JB4 setup goes, I'm using the data cable to an OTG adapter to my tablet that is mounted on my dash.
Reply With Quote
(#13)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 07:38 AM

Quote:
Originally Posted by Haynpunch
Make sure you have the right DME, you could possibly have a MSD80 which could mean you would need to use I8A0S.

When you connect to MHD it usually tells you which DME you have

In your log it shows firmware 32/14/0, Engine OBDII / All Other

latest firmware is 32/14/2 , engine usually shows E Series - N54

Do you have a OBD cable plugged in at the same time running JB4
Where can you find 32/14/2? I followed the instructions exactly as posted in the sticky and that file updates my firmware to 32/14/0.
Reply With Quote
(#14)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 584
Join Date: Jun 2017
Car: 07 E90 335i
Default 05-17-2019, 08:03 AM

Here

Latest Firmware


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#15)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 08:17 AM

Quote:
Originally Posted by Haynpunch

That's the exact one I downloaded and installed. I even deleted my old hex file just to eliminate confusion and when I flashed my JB4 then checked the firmware number it still was 32/14/0. Maybe someone from the JB4 crew or yourself could e-mail me the hex file???
Reply With Quote
(#16)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 1,337
Join Date: Jun 2011
Car: 135i N54
Default 05-17-2019, 08:47 AM

The /0 means you have a G4 board... Is your JB4 really old or used? If you loaded a G5 ISO firmware on an old board that would explain the issues.
Reply With Quote
(#17)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 08:57 AM

It was on the car when I bought it so I'm gonna go with used and old lol. Before I updated the current firmware I only had 8 or 9 menus for my steering controls. Now I have all of them.
Reply With Quote
(#18)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 1,337
Join Date: Jun 2011
Car: 135i N54
Default 05-17-2019, 09:10 AM

Sounds like it was either G4 or a G5 non-ISO. I don't recall how those show up exactly, but G5 ISO displays as */2. If you pull it and open it, we could identify it based on the circuit board. If it is a non-ISO, you could cut the diodes and use it properly with current firmware. If it is G4 you can get a control unit upgrade for only $150 and re-use the harness.
Reply With Quote
(#19)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 10:01 AM

I'll do that once I get home. Is there anything in particular that I'm looking for?
Reply With Quote
(#20)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 584
Join Date: Jun 2017
Car: 07 E90 335i
Default 05-17-2019, 10:37 AM

how to tell the diff with jb4 g5 vs none g5 board


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#21)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 584
Join Date: Jun 2017
Car: 07 E90 335i
Default 05-17-2019, 10:40 AM

Quote:
Originally Posted by Vorsprung_CJB
but G5 ISO displays as */2.
I didn't know this

learn something new everyday!!


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#22)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 10:46 AM

Quote:
Originally Posted by Haynpunch
Thanks!! I'll have a look as soon as I get home. From those pictures it looks like the G5 board has an extra IC chip that the G4 board doesn't have.
Reply With Quote
(#23)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 04:25 PM

So the pic I took is, says the file is too big, but I opened my jb4 and its definitely a G4 model. So the only thing I can do is buy a G5 board correct?
Reply With Quote
(#24)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 584
Join Date: Jun 2017
Car: 07 E90 335i
Default 05-17-2019, 04:43 PM

Quote:
Originally Posted by KikRox268
So the pic I took is, says the file is too big, but I opened my jb4 and its definitely a G4 model. So the only thing I can do is buy a G5 board correct?
If you resize the pic it'll upload

Yes you will need to purchase the G5 ISO board if you have the G4. I think its about 175$ but don't quote me on that


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#25)
Old
KikRox268 KikRox268 is offline
Junior Member
 
Posts: 33
Join Date: Apr 2019
Car: 2008 E90 335i
Default 05-17-2019, 04:46 PM

Well damn lol!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2022, JB4tech.com