N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default JB4 and a battery problem - 01-16-2021, 03:41 AM

Hello everyone, I'm new on the forums.

I just installed the JB4 on my N63 (550ix 2011), and I started to have a drained battery after that. Has anyone had any similar experiences with the JB4? Can the JB4 somehow block the car going to sleep?

I have double checked every connection.

Thank you in advance.



- Antti -
Reply With Quote
(#2)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 01-18-2021, 11:06 AM

I'm hoping someone could share a thought, Terry maybe... ?
Reply With Quote
(#3)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is online now
Tuner
 
Posts: 33,845
Join Date: Jan 2008
Default 01-18-2021, 04:11 PM

I had someone else email me something similar recently. If you disconnect OBDII, does this prevent it from coming up? If so I'll need to dig in to the CANbus side in the latest firmware to see what changed to cause it. Post up a JB4 log here too so I can see your specific firmware version and settings.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#4)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 01-19-2021, 12:34 AM

Thank you for the response!

Ok I disconnected the JB4 and I'll look at it for couple of days if the draining message comes up. If it doesn't, I'll reconnect the JB4 and make a log for you.

Does it matter how long/short the log is? Do i need to make some pulls etc. for it, or can you see everything needed from it even if the car stands still? Sorry I'm new to this.

- Antti -
Reply With Quote
(#5)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is online now
Tuner
 
Posts: 33,845
Join Date: Jan 2008
Default 01-19-2021, 07:04 PM

Disconnect the OBDII, not the JB4 itself.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#6)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 01-23-2021, 10:37 AM

Well I had the JB4 completely disconnected for few days and didn't get any battery drain. Now I reconnected the JB4 TMAP sensors but left the OBD2 unplugged. My version doesn't have the BCM connectors (non-TU). I'll report how it goes from now.

Last edited by Anzafin; 01-23-2021 at 10:43 AM..
Reply With Quote
(#7)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 01-25-2021, 01:57 AM

Two days JB4 TMAPs connected without driving, no battery drain. Now I connected the OBD2. We'll see.
Reply With Quote
(#8)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is online now
Tuner
 
Posts: 33,845
Join Date: Jan 2008
Default 01-25-2021, 09:58 AM

Once we confirm it's OBDII related I'll start digging around for possible causes.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#9)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 01-25-2021, 10:43 AM

Nice.

So, if it drains the battery, what do I need to do? You need a log and the firmware version? What kind of log do you need?

Antti
Reply With Quote
(#10)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is online now
Tuner
 
Posts: 33,845
Join Date: Jan 2008
Default 01-25-2021, 02:07 PM

Email me a log and reminder to go through the firmware. terry@burgertuning.com


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#11)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 01-26-2021, 04:02 AM

Got an immediate battery drain warning after one night with the JB4 OBD2 connected.

I read the codes and there was a code for TMAP sensor short circuit and a reduced engine power, but I believe these were there due the TMAPs connected but the OBD2 not connected (and I have turned the ignition on few times to see if there's a battery drain warning). I deleted them and they didn't come back now with the OBD2 connected and engine running.
I did a log (engine idling after a cold start) and sent it to you. Just tell me if you need something else.

Antti

Last edited by Anzafin; 01-26-2021 at 04:09 AM..
Reply With Quote
(#12)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 02-03-2021, 09:37 AM

Update if anyone's interested...

I dare to say the battery drain problem is now solved, thanks to Terry.
The Active Sound option (behind the BC button with JB4) was ON, and for some reason that didn't let the car go to sleep. Maybe my car doesn't have this active sound function/module, and the JB4 continuosly tried to search for this function. Maybe...
I hope the issue is solved, we'll see. Big thanks to Terry for his help!

- Antti -
Reply With Quote
(#13)
Old
Alexe70 Alexe70 is offline
New Member
 
Posts: 13
Join Date: Mar 2021
Car: 2013 x5 50i
Default 03-28-2021, 12:21 PM

[QUOTE=Anzafin;680837]Update if anyone's interested...

I dare to say the battery drain problem is now solved, thanks to Terry.
The Active Sound option (behind the BC button with JB4) was ON, and for some reason that didn't let the car go to sleep. Maybe my car doesn't have this active sound function/module, and the JB4 continuosly tried to search for this function. Maybe...
I hope the issue is solved, we'll see. Big thanks to Terry for his help!

- Antti -[/QUOT


so did that fix your problem? And how exactly did you fix it? I have had the the same problem with my x5 50i. If I don't disabled the jb4 (map0). it will completely kill my battery over night.
Reply With Quote
(#14)
Old
Anzafin Anzafin is offline
New Member
 
Posts: 10
Join Date: Jan 2021
Car: F10 550ix 2011
Default 03-28-2021, 12:49 PM

Quote:
Originally Posted by Alexe70


so did that fix your problem? And how exactly did you fix it? I have had the the same problem with my x5 50i. If I don't disabled the jb4 (map0). it will completely kill my battery over night.
Well I got it fixed for a while, but it seems the drainage problem has returned. However, the battery is now draining even with JB4 disconnected, so I'm leaning towards a bad battery.

What I did earlier with the JB4, I turned OFF the Active Sound from the JB4 menu. After that the battery seemed to hold the voltage, but like I said, it's back now, even with the JB4 disconnected.

- Antti -
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com