N54Tech.com - International Turbo Racing Discussion
(#1)
Old
MyN54isSlow MyN54isSlow is offline
New Member
 
Posts: 9
Join Date: Oct 2020
Car: E92 335i 6MT
Unhappy WTF is my rail pressure doing? Is this normal? - 10-13-2020, 05:07 AM

Yesterday, after driving to work, upon parking and letting the car idle a for a minute, rail pressure shot up from ~700 to ~2000psi. I’ve got a log here: *********** | E92Dave | WTF is my rail pressure doing? Is this completely normal? Found it a little odd.

Edit: Spike at the end is me blipping throttle to see if it would drop, it did.

Last edited by MyN54isSlow; 10-13-2020 at 05:21 AM..
Reply With Quote
(#2)
Old
MyN54isSlow MyN54isSlow is offline
New Member
 
Posts: 9
Join Date: Oct 2020
Car: E92 335i 6MT
Default 10-13-2020, 11:38 PM

Does anybody know?
Reply With Quote
(#3)
Old
Bmw335turbo's Avatar
Bmw335turbo Bmw335turbo is offline
Junior Member
 
Posts: 118
Join Date: Dec 2019
Car: 335
Default 10-14-2020, 05:48 AM

Quote:
Originally Posted by MyN54isSlow
Does anybody know?
Maybe something in the line?


Reply With Quote
(#4)
Old
08 335Ci's Avatar
08 335Ci 08 335Ci is offline
Junior Member
 
Posts: 177
Join Date: Dec 2012
Car: 08 335Ci
Default 10-14-2020, 10:02 AM

Quote:
Originally Posted by MyN54isSlow
Yesterday, after driving to work, upon parking and letting the car idle a for a minute, rail pressure shot up from ~700 to ~2000psi. Iíve got a log here: *********** | E92Dave | WTF is my rail pressure doing? Is this completely normal? Found it a little odd.

Edit: Spike at the end is me blipping throttle to see if it would drop, it did.
Normal operating range is 1500 to 2000 PSI. I'd be more concerned about the 700 PSI.


No matter how fast I go there's always someone slower in front of me.

You can lead a horse to water but you can't make him Jet Ski.

'10 E92 335 M Sport, JB-4 G5 ISO, 3" CPE Charge pipe, WMI w/dual CM 5 nozzles, 3.5 Tmap, ARM Relocated Inlets (don't do it), VSRF Outlet, BEF, Front Strut Brace, SS brake lines, Drilled and Slotted Rotors, Anti-lag, OCC. Escort Max 360

Totaled by a careless driver:
'08 E92 335, M sport option
Reply With Quote
(#5)
Old
MyN54isSlow MyN54isSlow is offline
New Member
 
Posts: 9
Join Date: Oct 2020
Car: E92 335i 6MT
Default 10-14-2020, 01:30 PM

Quote:
Originally Posted by 08 335Ci
Normal operating range is 1500 to 2000 PSI. I'd be more concerned about the 700 PSI.
1500-2000 is normal at WOT. At idle ~700 is what it should be at.
Reply With Quote
(#6)
Old
MyN54isSlow MyN54isSlow is offline
New Member
 
Posts: 9
Join Date: Oct 2020
Car: E92 335i 6MT
Default 10-14-2020, 01:30 PM

Quote:
Originally Posted by Bmw335turbo
Maybe something in the line?
Was a thought of mine since I removed the rail for the vcg recently
Reply With Quote
(#7)
Old
08 335Ci's Avatar
08 335Ci 08 335Ci is offline
Junior Member
 
Posts: 177
Join Date: Dec 2012
Car: 08 335Ci
Default 10-14-2020, 04:06 PM

Quote:
Originally Posted by MyN54isSlow
1500-2000 is normal at WOT. At idle ~700 is what it should be at.
If you know better, why are you asking? And I have 1500 psi at idle.


No matter how fast I go there's always someone slower in front of me.

You can lead a horse to water but you can't make him Jet Ski.

'10 E92 335 M Sport, JB-4 G5 ISO, 3" CPE Charge pipe, WMI w/dual CM 5 nozzles, 3.5 Tmap, ARM Relocated Inlets (don't do it), VSRF Outlet, BEF, Front Strut Brace, SS brake lines, Drilled and Slotted Rotors, Anti-lag, OCC. Escort Max 360

Totaled by a careless driver:
'08 E92 335, M sport option
Reply With Quote
(#8)
Old
MyN54isSlow MyN54isSlow is offline
New Member
 
Posts: 9
Join Date: Oct 2020
Car: E92 335i 6MT
Default 10-14-2020, 04:36 PM

Quote:
Originally Posted by 08 335Ci
If you know better, why are you asking? And I have 1500 psi at idle.
Did you even read my question? Iím asking not what it should be, but if anyone has an idea as to why it is not what it should be. I can start the car, hpfp immediately goes to ~2200 as it should, and after about a minute or two comes down to ~700 like it should. After driving the car, and observing pressures are exactly how they should be, when I go to park it, if I park and let it idle for a little bit, the pressure will shoot from ~700 to ~2000. When I first noticed it, it would hold that ~2000 until I blip the throttle and it would come down for a few seconds and go back up. Today upon parking at work, it went up to ~2000 but then started fluctuating between ~2000 and ~700. As for yours being 1500 at idle, idk what to tell ya, there are countless threads on here stating it should be ~700 at idle and increase with load, being at 1500-2000 at WOT.
Reply With Quote
(#9)
Old
MyN54isSlow MyN54isSlow is offline
New Member
 
Posts: 9
Join Date: Oct 2020
Car: E92 335i 6MT
Default 10-14-2020, 05:59 PM

Well out of a long shot the other day I threw in some LiquiMoly Jectron to see if maybe something was stuck in the line or who knows. Just got home from work, let it idle and the rail pressure never shot up this time. Not sure if it was just this once or not. Gonna take a log when I get to work in the morning.

Last edited by MyN54isSlow; 10-14-2020 at 06:09 PM..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com