N54Tech.com - International Turbo Racing Discussion
(#1)
Old
pyrax pyrax is offline
New Member
 
Posts: 2
Join Date: Sep 2020
Car: 2009 BMW 335i N54
Default N54 Single Turbo Overboosting (2ABC & 3100) - 09-30-2020, 04:53 PM

Hey people of N54 tech!

I also posted this on e90 post but I thought that there are more active members here!

So i just got my custom tune from Justin @ TwistedTuning and while I was getting logs for the car, I noticed under load, I kept getting the 2ABC and 3100 codes and was put into limp mode. The codes go away after being cleared, but come back after I hit WOT.

I think I am overboosting and thats what's causing the limp mode and codes. I have boost max set to 18psi and the boost safety setting set to 20pst (I have the 2.5 bar sensor), but according to my logs, Im hitting ~ +21 psi.

Before people tell me to check my wastegate plumbing and such here is some background info:
- My mac solenoid works, I hear the clicks when testing
- I have 2 Tial wastegates with 10psi springs each.
- Wastegate vacuum line plumbing is correct, as I had an issue where I wasn't hitting boost but fixed it via the lines.
- I don't have a vacuum fitting on my turbo so I made that line go to the stock vacuum location and plugged the other tube (the 2 tubes that go across the valve cover)

Here are the specifics of the build:
- Borg Warner S366 Turbo
- 2 tial wastegates
- knock-off hks bov (Yes i know, I'll get it replaced soon ): )
- Walbro 255 LPFP
- 5in Intercooler
- VSFR Chargepipe
- STOCK 2.5BAR MAP SENSOR


I'll attach the most recent log I have of the problem occurring. Any and all help will be appreciated. Thank you everyone!
Attached Files
File Type: csv P30_M6_R1_200929_150642.csv (20.9 KB, 8 views)
Reply With Quote
(#2)
Old
Ekn54 Ekn54 is offline
New Member
 
Posts: 4
Join Date: Oct 2020
Car: 135i 335i
Default 10-11-2020, 10:46 PM

Hey bud did u ever figure out what was ur issue, I am having the same problem
Reply With Quote
(#3)
Old
pyrax pyrax is offline
New Member
 
Posts: 2
Join Date: Sep 2020
Car: 2009 BMW 335i N54
Default 10-11-2020, 10:55 PM

Quote:
Originally Posted by Ekn54
Hey bud did u ever figure out what was ur issue, I am having the same problem
Hey yeah man. Since my turbo wasnt tapped with a nipple, i was using the stock positive pressure source from the twin turbos with the other source capped off. I ended up using my charge ***** meth hole and a 1/8th NPT to nipple adapter as my positive pressure source and it fixed my overboosting issue right up! Hope this helps, good luck!
Reply With Quote
(#4)
Old
Ekn54 Ekn54 is offline
New Member
 
Posts: 4
Join Date: Oct 2020
Car: 135i 335i
Default 10-12-2020, 08:00 AM

Good for u, n thanks alot for the reply, my turbo is already tapped for a vacuum line, maybe I have a leak somewhere, anyhow I appreciate ur response bud
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com