N54Tech.com - International Turbo Racing Discussion
(#1)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default Jb4 lack of boost on track with no error codes - 08-15-2020, 05:46 PM

I did a autocross lapped event which is nonstop autocross for about 10 minutes, then a 10 min break

after my first session the car was way down on boost and rhe the jb4 was unresponsive to steering wheel controlls it basically behaved like the car was never warming up and it limited boost. Like it does when the engine is cold

I popped the ECU cover off and it was hot like lava hot do these things have overheat protection?

at the end of the day we loaded up and the jb4 was just fine like there was never a problem I didn't get any error codes or anything and it started responding to the steering wheel controls again.
Reply With Quote
(#2)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-15-2020, 07:39 PM

vid from today last session. the car basically made "cold" power as of the jb4 never saw the water temp come up (mine is set to use water tempt trigger)

never saw shift light indicators or meth gauge hijack either

Lots of fun with motoring 4 masses - YouTube
Reply With Quote
(#3)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-17-2020, 07:03 AM

Video with data, looks like my steering wheel sensor was off, next event I will data log with the jb4 too

August 16, 2020 - YouTube
Reply With Quote
(#4)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-17-2020, 12:59 PM

also should note, I set the jb4 to map 0 and flashed MHD stage2+, no change at the track it still limited power to about the same as when I had jb4 map3 with backend flash

Reflashed backend back onto the ecu and set map 3 before the drive home, jb4 started responding again once the car cooled off and it's been fine

I suspect something quite communicating as the wheel commands were dead, and setting the jb4 to map 0 with the android app did not seem to work, when I connected later it was still showing map 3 again.
Reply With Quote
(#5)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 8,476
Join Date: Apr 2014
Car: E92 335XI
Default 08-17-2020, 07:20 PM

I wonder if heat is becoming an issue..

Although if you flashed to MHD & still had the issue, that’s odd too.

Do you have any logs?


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#6)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-17-2020, 08:00 PM

I have data logs from my racecapture, but it only gets limited canbus data, does not have things like boost, iat

does have water and oil temp, both never got hot
Reply With Quote
(#7)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 8,476
Join Date: Apr 2014
Car: E92 335XI
Default 08-18-2020, 12:35 PM

Quote:
Originally Posted by mega
I have data logs from my racecapture, but it only gets limited canbus data, does not have things like boost, iat

does have water and oil temp, both never got hot
Can i see those, just curious


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#8)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-18-2020, 01:35 PM

It's 38 MB I have the data loaded into track attack if you have an account on there you can view it for free it's a desktop app that's used for track analysis
Reply With Quote
(#9)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 8,476
Join Date: Apr 2014
Car: E92 335XI
Default 08-20-2020, 08:18 AM

Quote:
Originally Posted by mega
It's 38 MB I have the data loaded into track attack if you have an account on there you can view it for free it's a desktop app that's used for track analysis
I'll download that this afternoon.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#10)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-20-2020, 09:17 AM

Unfortunately there isn't a lot of engine data on the canvas twisted pair so it's really track-focused data I would love it if there was a way to pull canbus data from the JB4 and input it into my data logger I can run two canbas streams into it
Reply With Quote
(#11)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-31-2020, 04:16 PM

I have been testing and pretty much narrowed down the error to overheating jb4. It's fine until I push the car then it'll start to cut out and fail to respond.

I've removed every connection, reconnected everything and the jb4 wont respond until it cools off. It is very hot to the touch

once it gets hot the car gagues will sweep a couple of times then stop responding

My android app will connect but the gauges are all zero, nothing in data log

suggestions on what to replace? I dont want to give up on jb4 as I enjoy tweaking the backend flash myself, and use the methanol + safeties but in it's current state is is not working at all
Reply With Quote
(#12)
Old
ewicky ewicky is offline
New Member
 
Posts: 24
Join Date: Jan 2017
Car: 07 335xi, 98 A4 2.8 Quattro
Default 08-31-2020, 04:33 PM

Maybe your ECU box fan isn't working. That should keep temps under control in your sealed ECU box.

Passenger footwell area.
Reply With Quote
(#13)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 08-31-2020, 05:06 PM

that was the first thing I checked, it was dusty, but working well
Reply With Quote
(#14)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 09-07-2020, 07:01 PM

new board did not fix it, but I suspect the issue is the track data logger pulls canbus and obd2 data that is causing an issue with the jb4

hopefully I can find a solution, may have to run only ptcan (sniffing not requesting) and install a few sensors to gather the rest of the data. I was logging MAP, IAT and ignition from obd2 I may have to give up on that or give up on the jb4
Reply With Quote
(#15)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 8,476
Join Date: Apr 2014
Car: E92 335XI
Default 09-08-2020, 10:22 AM

Quote:
Originally Posted by mega
new board did not fix it, but I suspect the issue is the track data logger pulls canbus and obd2 data that is causing an issue with the jb4

hopefully I can find a solution, may have to run only ptcan (sniffing not requesting) and install a few sensors to gather the rest of the data. I was logging MAP, IAT and ignition from obd2 I may have to give up on that or give up on the jb4
I was going to say, it sounds like both are fighting.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#16)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 09-08-2020, 10:39 AM

dave is there any documentation on what the jb4 pulls from the obd2 and what wires are used?

I believe I can use positaps and passively log the same data with my data logger
Reply With Quote
(#17)
Old
mega mega is offline
Junior Member
 
Posts: 39
Join Date: Aug 2008
Car: 135i
Default 09-13-2020, 06:26 PM

ordered a new board last week, it did not fix the problem.

3rd session out the jb4 started to cut out, it woudl sweep the gagues and work for a half a lap then freeze again.

gauges were stuck pegged for a bit, then stuck zeroed out, car acted like map0 and eventually limp mode.

removed ecu cover and finished the day, it did not freeze again with the cover off.

I wish I knew what the issue is, it's causing me track time and that is expensive. One of my friends also tracks a 135i and he had to remove his for the same reason.

when it freezes the app will connect but all gauges read zero and it wont log or check the engine codes.
Reply With Quote
(#18)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 8,476
Join Date: Apr 2014
Car: E92 335XI
Default 09-15-2020, 09:58 AM

Quote:
Originally Posted by mega
ordered a new board last week, it did not fix the problem.

3rd session out the jb4 started to cut out, it woudl sweep the gagues and work for a half a lap then freeze again.

gauges were stuck pegged for a bit, then stuck zeroed out, car acted like map0 and eventually limp mode.

removed ecu cover and finished the day, it did not freeze again with the cover off.

I wish I knew what the issue is, it's causing me track time and that is expensive. One of my friends also tracks a 135i and he had to remove his for the same reason.

when it freezes the app will connect but all gauges read zero and it wont log or check the engine codes.
Email me-

Sales@burgertuning.com

Include logs please


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com