N54Tech.com - International Turbo Racing Discussion
(#151)
Old
Oilphase Oilphase is offline
New Member
 
Posts: 9
Join Date: Apr 2012
Car: 335i sedan
Default 11-03-2013, 03:20 AM

Quote:
Originally Posted by jacobniell
Is it just me or is this not for the IPhone as mentioned in the beginning?
still under process check post 146 to 150
(#152)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-03-2013, 04:37 PM

Quote:
Originally Posted by N54mike
Terry only uses the ground tx and rx lines. I'll take a look at the ble mini. You'll have to source the 5v from either the stock dme harness (on of the 5v sensor reference pins) or tap into the JB's 12v signal and regulate and filter it down to 5v.
Ahh. Thank you. Missed this reply somehow. I just found out that I may be able to a USB OTG setup as well since the BLE Mini has a usb serial interface.

I'll still need to wire in for power though.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#153)
Old
_ink's Avatar
_ink _ink is offline
Senior Member
 
Posts: 530
Join Date: Nov 2012
Car: 335i DCT
Default 11-03-2013, 10:58 PM

how do you update this on a MAC? Just delete and reinstall the latest link?

When i go to the "About JB4 App" it shows 1.1.(1)

Is that the latest?
(#154)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-03-2013, 11:02 PM

Quote:
Originally Posted by _ink
how do you update this on a MAC? Just delete and reinstall the latest link?

When i go to the "About JB4 App" it shows 1.1.(1)

Is that the latest?
When you drag the JB4 app into the Applications folder it should ask you to overwrite it. To be sure, goto the Applications folder and delete whatever JB4 version is there. Then just drag in the newest. I added a new text field to the "User Adjustment" page that shows the build version. 1.0.3 is the newest.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#155)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-04-2013, 06:15 PM

First post is updated with a new video.

The iPhone can finally communicate with the JB4!! Been working on this for a bit so I'm excited to finally get some success. I'll release a beta once I make sure everything works all good and stuff.

The plan right now is to start with a few displays, code reading/deletion, and saving a log file.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#156)
Old
Cynical Cynical is offline
Junior Member
 
Posts: 302
Join Date: May 2011
Car: 335i
Default 11-04-2013, 09:17 PM

for some reason I can connect? osx 10.9
(#157)
Old
jtrejo jtrejo is offline
Junior Member
 
Posts: 315
Join Date: Jan 2013
Car: 535 2008
Default 11-04-2013, 09:20 PM

mine works perfect
(#158)
Old
Cynical Cynical is offline
Junior Member
 
Posts: 302
Join Date: May 2011
Car: 335i
Default 11-04-2013, 09:23 PM

Quote:
Originally Posted by Cynical
for some reason I can connect? osx 10.9
yea i had a selection error for the usb . works now
(#159)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-04-2013, 09:36 PM

Quote:
Originally Posted by musc
Did some logging tonight. The green works good but it would be cool if when we hit the space bar again to stop it the text bar would turn red. Other than that things are still working good!
Glad to hear it. In the version I'm about to post, the red color is reserved for errors, green is logging, and white means not logging and just displaying a message of some kind. If it becomes absolutely necessary, we can throw in another color, but it's usually good practice to have certain colors reserved for certain events.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#160)
Old
Peter @ Pure's Avatar
Peter @ Pure Peter @ Pure is offline
Demigod
 
Posts: 1,688
Join Date: Aug 2013
Car: F20 M135i
Default 11-04-2013, 10:04 PM

Quote:
Originally Posted by dmacpro91
First post is updated with a new video.

The iPhone can finally communicate with the JB4!! Been working on this for a bit so I'm excited to finally get some success. I'll release a beta once I make sure everything works all good and stuff.

The plan right now is to start with a few displays, code reading/deletion, and saving a log file.
Very very nice :-) as soon as you release let me know what hardware i need to buy. Keep up the good work.
(#161)
Old
musc's Avatar
musc musc is offline
 
Posts: 770
Join Date: Jan 2008
Car: 335is DCT
Default 11-04-2013, 10:39 PM

Great work! The iPhone interface looks very promising!


335is DCT
(#162)
Old
_ink's Avatar
_ink _ink is offline
Senior Member
 
Posts: 530
Join Date: Nov 2012
Car: 335i DCT
Default 11-05-2013, 06:27 AM

Quote:
Originally Posted by dmacpro91
When you drag the JB4 app into the Applications folder it should ask you to overwrite it. To be sure, goto the Applications folder and delete whatever JB4 version is there. Then just drag in the newest. I added a new text field to the "User Adjustment" page that shows the build version. 1.0.3 is the newest.
Awesome thanks! So im doing it right.

Quote:
Originally Posted by dmacpro91
First post is updated with a new video.

The iPhone can finally communicate with the JB4!! Been working on this for a bit so I'm excited to finally get some success. I'll release a beta once I make sure everything works all good and stuff.

The plan right now is to start with a few displays, code reading/deletion, and saving a log file.
OMG i cant wait for this!! Just recently, I got a code and because i live in an apartment its not always convenient to go up the elevator, get my laptop and come back down... This will eliminate all that!!

Interested in becoming an Aussie Beta Tester!
(#163)
Old
Oilphase Oilphase is offline
New Member
 
Posts: 9
Join Date: Apr 2012
Car: 335i sedan
Default 11-05-2013, 11:45 AM

Quote:
Originally Posted by dmacpro91
First post is updated with a new video.

The iPhone can finally communicate with the JB4!! Been working on this for a bit so I'm excited to finally get some success. I'll release a beta once I make sure everything works all good and stuff.

The plan right now is to start with a few displays, code reading/deletion, and saving a log file.
That's good start looking forward to see the final app !!
(#164)
Old
2Times's Avatar
2Times 2Times is offline
Junior Member
 
Posts: 70
Join Date: Oct 2013
Car: 08 E92 335xi
Default 11-06-2013, 07:06 AM

Man you're smart. I wish I knew how to do this stuff, I'd offer to help
(#165)
Old
musc's Avatar
musc musc is offline
 
Posts: 770
Join Date: Jan 2008
Car: 335is DCT
Default 11-08-2013, 12:23 AM

I did do some more logging with the latest version and noted an error. I was plugged in and was driving around logging. I was still warming the car up so I decided to stop that log and start another. While I was logging the left lower text box said Logging started and was highlighted green. When I pressed the space bar, the logging stopped but the text bar didn't change and remained green with the same text. I could tell it was stopped because my RPMs weren't moving. I hit again to start a fresh log and it still stayed green and the logging resumed.

I decided to stop and restart it and the next time when I stopped it it changed to no color and said something like plotting 298 of 298 or something along those lines. Any reason why it may not be showing that it is stopped consistently? I usually just like to look over and see the green color for active and no color (or red, orange etc) for inactive. Thanks for all your hardwork on this! I think we should get Terry or Russell to make this a sticky. I am sure there are a lot of mac users out there that would use this.


335is DCT
(#166)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-08-2013, 08:59 AM

Quote:
Originally Posted by musc
I did do some more logging with the latest version and noted an error. I was plugged in and was driving around logging. I was still warming the car up so I decided to stop that log and start another. While I was logging the left lower text box said Logging started and was highlighted green. When I pressed the space bar, the logging stopped but the text bar didn't change and remained green with the same text. I could tell it was stopped because my RPMs weren't moving. I hit again to start a fresh log and it still stayed green and the logging resumed.

I decided to stop and restart it and the next time when I stopped it it changed to no color and said something like plotting 298 of 298 or something along those lines. Any reason why it may not be showing that it is stopped consistently? I usually just like to look over and see the green color for active and no color (or red, orange etc) for inactive. Thanks for all your hardwork on this! I think we should get Terry or Russell to make this a sticky. I am sure there are a lot of mac users out there that would use this.
Ah. There might be a bug between stopping logging and updating the status bar. When you stop logging it should say all that "Plotting x of y" stuff in white. I'll look into it again. And yea, I'm glad I could give back to the community a bit, hopefully once everything is all finished they will sticky it.

I've been mainly working on the iPhone stuff the past few days so I haven't gotten a chance to mess with the OS X version much, but I'll be taking another look today.

As an update on the iPhone side, I have a decent speed display, boost gauge, rpm gauge, and gear gauge currently working. Also code reading and deletion is working. I'm not a graphic artist so it might not be the prettiest thing in the world, but it will work.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#167)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 11-08-2013, 09:03 AM

Quote:
Originally Posted by dmacpro91
As an update on the iPhone side, I have a decent speed display, boost gauge, rpm gauge, and gear gauge currently working. Also code reading and deletion is working. I'm not a graphic artist so it might not be the prettiest thing in the world, but it will work.
Maybe some of us could help with the graphics?
(#168)
Old
Trickcruiser's Avatar
Trickcruiser Trickcruiser is offline
Senior Member
 
Posts: 525
Join Date: Oct 2009
Car: 335i
Default 11-08-2013, 09:21 AM

Depending on what you need, I would be very happy to help you with graphics. I make my living in the design field.


(#169)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 11-08-2013, 09:25 AM

I don't make a living in the field yet, but am a graphic design major at KU.
Actually working on an iPhone application for a school project right now :D
(#170)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-08-2013, 09:39 AM

Some help with the graphics would be great.

Here is a list of graphic pieces and sizes if needed (dimensions are in pixels):
icon - 1024x1024
Gauges - Big enough so the text is easy to read
Connect button
Disconnect button
Read Codes button
Delete Codes button
Close button

Here are links to screenshots of what I have so far.

Image 1

Image 2

The design is still very early.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#171)
Old
Trickcruiser's Avatar
Trickcruiser Trickcruiser is offline
Senior Member
 
Posts: 525
Join Date: Oct 2009
Car: 335i
Default 11-08-2013, 09:56 AM

The N54 community is very refreshing to me! You just don't see people helping each other out like this all the time anymore.

Wang,
Please let me know if your going to tackle this. My time is a bit limited so I do not want to duplicate efforts. If you do not have time, I will start putting something together in the next few days as time allows.


(#172)
Old
alexim's Avatar
alexim alexim is offline
Junior Member
 
Posts: 113
Join Date: Feb 2012
Car: 1M
Default 11-08-2013, 10:19 AM

Cannot thank you enough for this... OS X and iOS apps are a huge help for us Mac users.. Too bad my car is in the shop for now... Will test and donate soon as I get the car back.. Thanks again!!!


(#173)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-11-2013, 07:10 PM

Quote:
Originally Posted by alexim
Cannot thank you enough for this... OS X and iOS apps are a huge help for us Mac users.. Too bad my car is in the shop for now... Will test and donate soon as I get the car back.. Thanks again!!!
You're welcome.

Everyone please check the updated notes in the first post pertaining to firmware updates.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#174)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 11-11-2013, 07:28 PM

BLE Mini and plug for JB4 wire with a cheap diy enclosure (I'm still looking for a nice enclosure, but this works for now).




BLE Mini end and USB end side-by-side.


Eventually I'll get a list of parts for a kit so you can either buy the stuff yourselves or through me. The diy will be straightforward but essentially, cut the usb end off about 7 inches before the plug, strip some wires, solder a few points, done. Then you can switch from your the adapter to the usb end on the fly.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#175)
Old
psmitty95's Avatar
psmitty95 psmitty95 is offline
Junior Member
 
Posts: 82
Join Date: Jun 2012
Car: 09 335i xDrive 6spd
Default 11-13-2013, 05:32 PM

If this gets made into a working iphone/ipad app that can log and clear/read codes that would be amazing


< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: JB4 + MHD, Doc Race ST, Pure 6266, AD-Eng PI/Mounts, Fuel-It st. 3, Custom Exhaust, Tuned by TwistedTuning
More Pictures: Build Thread /// Dyno Soon to Come
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com