View Single Post
(#5)
Old
andrew85 andrew85 is offline
Junior Member
 
Posts: 46
Join Date: Aug 2019
Car: E92 335i
Default 09-05-2019, 04:29 AM

If you could have a look at the updated logs that would be great and really appreciated. I've now spent about 10 days with the front mount, wastegate rattle fix (adjusted rods) and 3" *** less ***** on top of the original mods. The surging is still there. Oh, also replaced bank 1 02 sensor, which has smoothed the AFRs out a little.

I'll post 3 logs, the first one was just after the extra mods (first drive). It's map 2 running BP Ultimate 98 fuel. I think the car feels best on this map. On BP98 map 5 felt sluggish. However, the surging is least noticeable.

The second 2 are a few runs on an e20 mix on map 5, to see what the JB4 can auto tune to. I did quite a few logs on e20 as i am concerned about LPFP. It was pulling timing on cylinder one when under high load. So wot from low rpm, full boost you can clearly see the timing on that cylinder is low. This only showed up after e20. However map 5 is starting to come to life after 5-6 hard pulls. Still not as aggressive as map 2 on 98, but its feeling like a tuned car, not so quite as flat, like it did on 98 in map 5. The second map 5 log, its a slightly more gentle application of throttle to reduce low rpm load and i can't see the cyl 1 timing drop. That last pull is not as long either.

I have got the full bug with this car now (cos who needs a retirement fund anyway). LPFP pump is ordered and should be here soon. As well as a flex sensor to properly monitor e85 content and i'd like to push this current setup as far as stock turbos will go. If i can get a couple of months out of them before upgrading ill be very happy.

I'm starting to think the surging i'm feeling is the map pulling timing under high load conditions. If i ease the throttle on it pulls like a train, so 4th gear 3000rpm 20% throttle it feels like 500hp, but if i try and load the turbos like i would my Evo, say 60-70% throttle the n54 just doesn't feel aggressive it feels slower than 20% throttle acceleration. The Evo is a 4G63 Evo 6 tuned to around 320awhp and feels so much more exciting than the N54 (it does have much shorter gear ratios which play a factor but the Evo responds better to being loaded up). A highway roll the N54 would take the evo but the N54 just feels so flat. The other thing tainting my opinion is my other 2 cars ive spent most of my time in lately is a lightly tuned Megane Rs250 and an e60 M5. The megane, evo and M5 all have so much character to the engines as the rpms build.

The thing that is bugging me is, it wont really spin the wheels rolling the power on at low speeds (20-30kph) and i'm running really ****ty cheap tyres at the moment. I was kind of hoping to get a low end aggressive pull in the tuned n54 like to do in the e60 m5. That naughtly loss of traction in 1st and 2nd just isn't there. I have removed gear 1 and 2 boost limits as well, to see if that brought it to life, but it wont load up and break loose.

If the logs look good i'll get the LPFP upgrade done and play with some higher octane. Would running the Race BEF help with low end power delivery. I would love any advice on how to get more out of the current setup. Inlets were going to be next on the list, but i think i'll wait till i can do the turbo upgrade.

Thanks again and sorry for the story, just trying to paint a picture of what i'm feeling and why. The community around tuning these things is nothing short of amazing.
Attached Files
File Type: csv 2019-08-24 11_36_33_Map-2.csv (44.4 KB, 44 views)
File Type: csv 2019-09-05 18_57_30_Map-5.csv (18.7 KB, 46 views)
File Type: csv 2019-09-05 18_53_33_Map-5.csv (21.2 KB, 51 views)
Reply With Quote