View Single Post
(#2363)
Old
Payam @ BMS's Avatar
Payam @ BMS Payam @ BMS is offline
Super Moderator
 
Posts: 5,092
Join Date: Oct 2013
Car: e90 335i
Default 07-11-2019, 02:06 PM

Quote:
Originally Posted by P4RTYH4RTY
I recently uninstalled then reinstalled my JB4, and now it feels like there is a lag until 4K rpm. It feels a lot like VTEC; not much going on until after 4K, even at WOT. Iíll usually start my pulls in 2nd gear @ 3k rpm. I donít remember it feeling like this the first time around with the JB4. Did I just forget, or is this normal?
Can you get a log so we can check it out? What map and fuel are you using?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote