View Single Post
(#1)
Old
pyrax pyrax is offline
New Member
 
Posts: 2
Join Date: Sep 2020
Car: 2009 BMW 335i N54
Default N54 Single Turbo Overboosting (2ABC & 3100) - 09-30-2020, 04:53 PM

Hey people of N54 tech!

I also posted this on e90 post but I thought that there are more active members here!

So i just got my custom tune from Justin @ TwistedTuning and while I was getting logs for the car, I noticed under load, I kept getting the 2ABC and 3100 codes and was put into limp mode. The codes go away after being cleared, but come back after I hit WOT.

I think I am overboosting and thats what's causing the limp mode and codes. I have boost max set to 18psi and the boost safety setting set to 20pst (I have the 2.5 bar sensor), but according to my logs, Im hitting ~ +21 psi.

Before people tell me to check my wastegate plumbing and such here is some background info:
- My mac solenoid works, I hear the clicks when testing
- I have 2 Tial wastegates with 10psi springs each.
- Wastegate vacuum line plumbing is correct, as I had an issue where I wasn't hitting boost but fixed it via the lines.
- I don't have a vacuum fitting on my turbo so I made that line go to the stock vacuum location and plugged the other tube (the 2 tubes that go across the valve cover)

Here are the specifics of the build:
- Borg Warner S366 Turbo
- 2 tial wastegates
- knock-off hks bov (Yes i know, I'll get it replaced soon ): )
- Walbro 255 LPFP
- 5in Intercooler
- VSFR Chargepipe
- STOCK 2.5BAR MAP SENSOR


I'll attach the most recent log I have of the problem occurring. Any and all help will be appreciated. Thank you everyone!
Attached Files
File Type: csv P30_M6_R1_200929_150642.csv (20.9 KB, 17 views)
Reply With Quote