N54Tech.com - International Turbo Racing Discussion
Go Back   N54Tech.com - International Turbo Racing Discussion > Search Forums
Reload this Page Search Results
Showing results 1 to 6 of 6 Search: Posts Made By: Metanoia
Forum: Support & Log Review 10-08-2019, 08:43 PM
Replies: 1
Views: 322
Posted By Metanoia
JB4 switches to Map 4 on WOT - please help

Hello N54Tech team - hoping for some help troubleshooting. I have a 2008 335xi, running the JB4 Map 1 + BEF and the car has been running great on map 1 for over a year. However, recently, I have been...
Forum: General Tech Support, Tuning Advice, Logs, and Help Me Posts 09-16-2019, 09:06 PM
Replies: 4
Views: 1,208
Posted By Metanoia
New Logs to an old post :-)

Hello N54Tech team. Since last posting, I have installed the pump BEF, and the car has been running great on map 1 for over a year. However, recently, I have been experiencing some issues that I was...
Forum: General Tech Support, Tuning Advice, Logs, and Help Me Posts 07-23-2018, 08:02 PM
Replies: 4
Views: 1,208
Posted By Metanoia
Hi Dave. Thanks for the advice, and the welcome!...

Hi Dave. Thanks for the advice, and the welcome! I've spent a fair amount of time reading this forum but haven't posted much... still much to learn. BTW, saw your 10.9 post on BB - nicely done!
...
Forum: General Tech Support, Tuning Advice, Logs, and Help Me Posts 07-22-2018, 12:36 PM
Replies: 4
Views: 1,208
Posted By Metanoia
JB4 Switches to Map 4 during WOT – Troubleshooting Support Requested

Hello. I have a 2008 N54 powered BMW 335xi with BMS DCI, JB4 G5 ISO, ER charge pipe, Forge DV’s with yellow springs (15-23lbs) manual transmission, and use Shell 91 fuel. The vehicle has about 59,000...
Forum: General Tech Support, Tuning Advice, Logs, and Help Me Posts 11-19-2017, 05:29 PM
Replies: 9
Views: 2,211
Posted By Metanoia
Thanks for the input, guys. I'll check the...

Thanks for the input, guys.

I'll check the belts/pulleys. As for plugs, I replaced with OEM Bosch Plugs (3 tip, pre-gapped) and torqued to 18 ft-lbs. I do have the engine cover off, the ticking...
Forum: General Tech Support, Tuning Advice, Logs, and Help Me Posts 11-19-2017, 12:03 PM
Replies: 9
Views: 2,211
Posted By Metanoia
I just installed my JB4, new coil packs, and new...

I just installed my JB4, new coil packs, and new spark plugs and am experiencing the same sort of noise (a ticking while the engine is running). Trying to figure it out and am wondering what could...
Search took 0.00 seconds.

 
Forum Jump



vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com