N54Tech.com - International Turbo Racing Discussion
Go Back   N54Tech.com - International Turbo Racing Discussion > Search Forums
Reload this Page Search Results
Showing results 1 to 25 of 63 Search: Posts Made By: notabenex
Forum: Mercedes C250, C300, C43, AMG 10-10-2019, 08:31 PM
Replies: 99
Views: 9,912
Posted By notabenex
You should read the whole thread

You should read the whole thread
Forum: Mercedes C250, C300, C43, AMG 10-09-2019, 08:45 AM
Replies: 99
Views: 9,912
Posted By notabenex
So. can I send my jb4 back to you and get refund,...

So. can I send my jb4 back to you and get refund, no credits, what would I do with credits?
If you really have only 4-5 not working units from 250 it would be nice to do it.

I am not going to...
Forum: Mercedes C250, C300, C43, AMG 10-08-2019, 05:16 AM
Replies: 99
Views: 9,912
Posted By notabenex
Exactly what was happening to me, ezatnova and...

Exactly what was happening to me, ezatnova and other users on mbworld forum who was PMing me... I was assuming that JB4 for my C63 would be good as I hear from BMW friends.. its not.. When it was in...
Forum: Mercedes C250, C300, C43, AMG 09-15-2019, 01:40 PM
Replies: 323
Views: 70,008
Posted By notabenex
This is exactly how my story started... fingers...

This is exactly how my story started... fingers crossed
Forum: Mercedes C250, C300, C43, AMG 09-15-2019, 12:23 PM
Replies: 99
Views: 9,912
Posted By notabenex
Black foam is packaging from dealer who gave it...

Black foam is packaging from dealer who gave it to me in that

Purple wire I think is from BT module, need to check.

No reply from Terry or anyone from BMS, what to do now? Should I send the...
Forum: Mercedes C250, C300, C43, AMG 09-13-2019, 10:14 PM
Replies: 99
Views: 9,912
Posted By notabenex
I had fully functional 2017 C63, since I...

I had fully functional 2017 C63, since I installed JB4 I had problems.. after few days first misfire then CEL's, rough idle, sometimes weird behavior of rpms.. it was not right since I installed it....
Forum: Mercedes C250, C300, C43, AMG 09-01-2019, 10:20 PM
Replies: 99
Views: 9,912
Posted By notabenex
probably coil pack is dead? CEL and rough idle,...

probably coil pack is dead? CEL and rough idle, even now on map 0
Forum: Mercedes C250, C300, C43, AMG 08-16-2019, 07:26 AM
Replies: 323
Views: 70,008
Posted By notabenex
+1 I have the same solution and it works well

+1 I have the same solution and it works well
Forum: Mercedes C250, C300, C43, AMG 08-04-2019, 07:49 AM
Replies: 323
Views: 70,008
Posted By notabenex
Congrats to your install. How is smoothnes? On...

Congrats to your install. How is smoothnes? On 4th gear is it smooth from 3500 rpm to redline? No hesistation?
Forum: Mercedes C250, C300, C43, AMG 07-25-2019, 12:34 AM
Replies: 99
Views: 9,912
Posted By notabenex
Well its behaving same way in sport+. I heard few...

Well its behaving same way in sport+. I heard few users had problems with corrosion on PCB, but my issue is present since install so probably PCB is OK.

Any other things to try? Thanks
Forum: Mercedes C250, C300, C43, AMG 07-22-2019, 08:51 PM
Replies: 99
Views: 9,912
Posted By notabenex
I am doing these tests in comfort mode, maybe its...

I am doing these tests in comfort mode, maybe its cutting torque to make everything "easier to drive"? I dont think it happens in sport+, will test it today..Since my car is DD i drive in comfort 90%...
Forum: Mercedes C250, C300, C43, AMG 07-21-2019, 09:15 AM
Replies: 99
Views: 9,912
Posted By notabenex
Here is the log.. Map1 at first and then map2 ...

Here is the log.. Map1 at first and then map2

Terry or Payam could you please check it? thanks
Forum: Mercedes C250, C300, C43, AMG 07-20-2019, 12:18 AM
Replies: 99
Views: 9,912
Posted By notabenex
Will do that tomorrow.

Will do that tomorrow.
Forum: Mercedes C250, C300, C43, AMG 07-19-2019, 07:40 AM
Replies: 99
Views: 9,912
Posted By notabenex
It would be nice if Terry od Payam will help to...

It would be nice if Terry od Payam will help to solve this. thats correct
Forum: Mercedes C250, C300, C43, AMG 07-18-2019, 11:07 AM
Replies: 99
Views: 9,912
Posted By notabenex
yeeeah enjoying it C63 W205 JB4 map 2 on Vimeo...

yeeeah enjoying it C63 W205 JB4 map 2 on Vimeo (https://vimeo.com/348879382)
Forum: Mercedes C250, C300, C43, AMG 07-18-2019, 12:45 AM
Replies: 99
Views: 9,912
Posted By notabenex
So happy update, after towing the car to MB...

So happy update, after towing the car to MB dealer they checked codes and realized that spark plugs were not correctly installed (previously went to my friend to do that....), so they took them out,...
Forum: Mercedes C250, C300, C43, AMG 07-14-2019, 10:52 AM
Replies: 99
Views: 9,912
Posted By notabenex
Today on highway, map0, total loss of power, CEL...

Today on highway, map0, total loss of power, CEL car in neutral, shaking rattling.. was ready to tow it to dealer but after restart I went slowly home.. Going to dealer and also removing JB4.... this...
Forum: Mercedes C250, C300, C43, AMG 07-13-2019, 01:46 AM
Replies: 99
Views: 9,912
Posted By notabenex
So I went to friendly Mercedes dealer, they did...

So I went to friendly Mercedes dealer, they did xentry base diag and found no CEL s saved. probably my chinese obd erased them well..

I have screenshots with 0308 which should be misfire on...
Forum: Mercedes C250, C300, C43, AMG 07-12-2019, 10:30 PM
Replies: 99
Views: 9,912
Posted By notabenex
yes.

yes.
Forum: Mercedes C250, C300, C43, AMG 07-12-2019, 08:44 AM
Replies: 99
Views: 9,912
Posted By notabenex
So problems again. Got CEL, erased and very early...

So problems again. Got CEL, erased and very early after that misfire.. and again CEL any suggestions before I go back to stock? Terry?
Forum: Mercedes C250, C300, C43, AMG 07-10-2019, 03:02 AM
Replies: 99
Views: 9,912
Posted By notabenex
changed spark plugs for new oem ones. on map 0...

changed spark plugs for new oem ones. on map 0 idle seems fine

rpms problem is still here, only with jb4 on. no CEL at the moment

C63 jb4 map1 problem on Vimeo C63 jb4 map1 problem on Vimeo...
Forum: Mercedes C250, C300, C43, AMG 07-09-2019, 08:15 AM
Replies: 323
Views: 70,008
Posted By notabenex
changed spark plugs for new oem ones. still the...

changed spark plugs for new oem ones. still the same

C63 jb4 map1 problem on Vimeo (https://vimeo.com/347098631)

SORRY WRONG THREAD PLEASE MOVE TO HELP WITH MY JB4

attached log with this...
Forum: Mercedes C250, C300, C43, AMG 07-08-2019, 09:04 PM
Replies: 99
Views: 9,912
Posted By notabenex
Thanks Terry. Queerion is if I need to go to...

Thanks Terry.
Queerion is if I need to go to the dealer to check this code. I can erase this CEL with obd and 3rd party app. I hope changing spark plugs will help.
Forum: Mercedes C250, C300, C43, AMG 07-08-2019, 12:19 PM
Replies: 99
Views: 9,912
Posted By notabenex
today got CEL after few minutes of driving. idle...

today got CEL after few minutes of driving. idle is rough. it seems like car has more vibrations. changing spark plugs tomorrow so fingers crossed.
Forum: Mercedes C250, C300, C43, AMG 06-29-2019, 10:48 AM
Replies: 99
Views: 9,912
Posted By notabenex
OK now I have latest beta version of the app....

OK now I have latest beta version of the app. Will do some testing after holidays
Search took 0.01 seconds.

 
Forum Jump



vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com