N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   N55 (https://www.n54tech.com/forums/forumdisplay.php?f=16)
-   -   Dct M4 Flywheel Installation (https://www.n54tech.com/forums/showthread.php?t=54833)

Stoolz 09-01-2018 02:47 PM

Dct M4 Flywheel Installation
 
Guys, my car has been plagued by an issue ever since my M4 flywheel went in, well there's certainly been other bumps in the road but I'm pretty certain the latest coincided with my flywheel replacement.
My question is can the swap been done incorrectly??
It seems like maybe my crank angle sensor is involved with the issue.
I dont have my original fw it was binned by the installerand the car is in a different shop now.

Cheers!

Terry @ BMS 09-01-2018 09:37 PM

What codes, exactly?

Stoolz 09-01-2018 10:52 PM

Weird codes that dont make sense, ecu fueling and knock but logs show all is fine and the car isn't actually knocking.
We have now swapped the crank angle sensor and the problem is actually worse. I think it's open circuit code (but it isn't open circuit and the wiring harness looks fine. I'm the Aussie dude who emailed you, we decided to push my car off a cliff lol!

Ferrora66 09-18-2018 01:58 AM

I installed the Mfactory flywheel on my n55 last week. I used to experience the random misfires at high rpm before installing the flywheel. Since I've installed the flywheel, my car has been misfiring a lot earlier (around 4500rpm) at any boost level past 22psi. I've also been experiencing drastic timing drops, not sure what's causing that. I'm not sure if the flywheel is to blame for all this but my car was definitely in a better position before the flywheel swap. I am running a gtx35 turbo.

jturboawd 09-18-2018 05:11 AM

I’m running s55 flywheel dct no knock or codes.

houtan 09-18-2018 06:35 AM

Quote:

Originally Posted by Ferrora66 (Post )
I installed the Mfactory flywheel on my n55 last week. I used to experience the random misfires at high rpm before installing the flywheel. Since I've installed the flywheel, my car has been misfiring a lot earlier (around 4500rpm) at any boost level past 22psi. I've also been experiencing drastic timing drops, not sure what's causing that. I'm not sure if the flywheel is to blame for all this but my car was definitely in a better position before the flywheel swap. I am running a gtx35 turbo.

Have you contacted mfactory? What tune are you running?

Ferrora66 09-18-2018 12:43 PM

Wanted to know if anyone is experiencing the same issue with the mfactory flywheel before I contact them. Running jb4 with custom mhd backend

JacquesN55 09-19-2018 01:07 AM

I just rather got the m4 dct flywheel

Stoolz 09-19-2018 04:36 AM

Quote:

Originally Posted by Ferrora66 (Post )
I installed the Mfactory flywheel on my n55 last week. I used to experience the random misfires at high rpm before installing the flywheel. Since I've installed the flywheel, my car has been misfiring a lot earlier (around 4500rpm) at any boost level past 22psi. I've also been experiencing drastic timing drops, not sure what's causing that. I'm not sure if the flywheel is to blame for all this but my car was definitely in a better position before the flywheel swap. I am running a gtx35 turbo.

It looks like the M4 fw after inspection is installed correctly and not the issue. My car is driving me nuts.

JacquesN55 09-19-2018 05:02 AM

Maybe those stiffer mounts

Stoolz 09-19-2018 05:59 PM

Quote:

Originally Posted by JacquesN55 (Post )
Maybe those stiffer mounts

Yeah it's possible mate

houtan 09-19-2018 06:31 PM

Do you have issues if you run the stock flash with no jb4?

Stoolz 09-19-2018 11:31 PM

Quote:

Originally Posted by houtan (Post )
Do you have issues if you run the stock flash with no jb4?

I have the issue no matter what, even completely stock. No jb4 no mhd. With jb4 i could make a 1 psi map 6 and still have the problem.
I spoke with my mechanic, even tho hes at his give up point he doesn't believe its my engine or trans mounts.

Ferrora66 09-20-2018 02:46 AM

Why donít you send the car to the agents in stock form. They might be able to pick up the fault

Stoolz 09-20-2018 02:02 PM

Quote:

Originally Posted by Ferrora66 (Post )
Why don’t you send the car to the agents in stock form. They might be able to pick up the fault

Yes, airbag recall needs doing, I think its my only option. Edit, ..but i called the shop to send it to bmw, they've ordered a whole new wiring harness already, going to try that first.

houtan 10-01-2018 01:18 PM

any luck?

JacquesN55 10-01-2018 01:21 PM

Any luck

Stoolz 10-02-2018 12:59 AM

They got the injector harness accidentally instead of the actual ecu harness. My life story really.

Stoolz 11-10-2018 01:33 PM

Update, cars been at dealer, showed a vanos motor code, they replaced it plus the entire wiring harness. No good. Dealer gives up, thinks it might be ecu but weve already done that way back, car being sent back to my local shop to look like a barn find for a while again. :(

JacquesN55 11-11-2018 03:00 AM

Anyways. I installed my m4 flywheel and can now run 26 psi to 7000rpm no missfires on my GTX3576R on my e82 n55 dct. Thank you Pure

JacquesN55 11-11-2018 03:01 AM

Still running the bms Pump flash with low timming.

Stoolz 11-11-2018 04:00 AM

Quote:

Originally Posted by JacquesN55 (Post )
Still running the bms Pump flash with low timming.

That's awesome news mate.
What kinda power are you puting down?

JacquesN55 11-11-2018 04:11 AM

600hp buddy. But im at 5500ft elevation

Stoolz 11-11-2018 09:56 PM

Quote:

Originally Posted by JacquesN55 (Post )
600hp buddy. But im at 5500ft elevation

That must be one hell of a fun car to drive

JacquesN55 11-12-2018 12:34 AM

Yes it is very. Timming still low. Busy with more timming.


All times are GMT -7. The time now is 06:48 AM.


Copyright © 2007 - 2019, N54tech.com