JB4tech.com - International Turbo Tuning Discussion

JB4tech.com - International Turbo Tuning Discussion (https://www.jb4tech.com/forums/index.php)
-   N63, N63TU (https://www.jb4tech.com/forums/forumdisplay.php?f=57)
-   -   x5 n63 JB4 installed and now i have questions (https://www.jb4tech.com/forums/showthread.php?t=60836)

87beamer 01-30-2020 02:27 PM

x5 n63 JB4 installed and now i have questions
 
Hey Guys,

So...loving the JB4 after i finally got it installed. Ive got a couple general questions and then a more specific one.

Ok, for starters, noticing on my logs that is shows e series n55 in my logs as well as 6cylMode? making sure this is the norm?

Also, im not showing any ignition values at all...and my fp_h values go from 3/4 to 8/9 on WOT....my buddy has an n54 and he doesnt see those numbers like that at all. I know comparing oranges to mangos....but still, another just checking question.


Lastly, I installed the jb4 and now twice after beating on it....in D doing 70 mhp and cruise ive thrown the 2D59. Ive looked in to it a bit and im not seeing any fixes on it that are clear......really deferring to someone with more experience with this. I can throw some logs up if you like but unfortunately i wasnt logging when the 2D59 popped. I Traction light, 4x4 light and the brake light lit orange...and i had to shut the car off in order to get it fully sorted out after clearing the code

ive got me newb flame suit on as well so you wont hurt my feelings ;)

Payam @ BMS 01-31-2020 12:23 PM

If you have a log you should post it up, that would be the most helpful for us.

N63 will only have ign value for cyl 1. Can't compare other motors, everything is completely different.

l1nk3d 02-19-2020 10:14 PM

8 Attachment(s)
I also had this same thing happen. I just installed my JB4 a few days ago. Brand new plugs, coils, turbo rebuild, repaired a vacuum leak (possibly another small one but extremely minor).

I was cruising on the highway accelerating moderately to 80mph, then as soon as I hit 80 had a completely loss of power had to pull over and restart. This consistently replicates on Map 1 DS & D. Map 0 & 4 are unaffected. I don't think the JB4 was logging when the loss of power occurred but I have logs up to that point.

My logs also show N55 E which seems odd to me. Would love to get some guidance here.

One thing I forgot to mention, the second time this happened, after switching to map 4, I got a 30FF code which hasn't happened since rebuilding the turbos and replacing the coils/plugs.

I also have an 2012 X5 50i N63 if that wasn't obvious. I'm also wondering if there is an updated firmware or something, but I don't know where to look. My JB4 came with no paperwork at all, just the unit in a box labeled E70/71.

Terry @ BMS 02-20-2020 11:29 AM

Update to the BETA android app so logs combine together, most of these have no real full throttle in them so not much to look at.

N55 E is correct for code reading on your model.

l1nk3d 02-20-2020 10:50 PM

Wow, I didn't even realize there was another version of the app. I have that now. I'll make some runs tomorrow and see what happens. I pulled the heat shield off the turbos this evening and noticed that one of the E-clips on my driver side waste gate flapper had popped off. I replaced that and took it for a drive. I didn't get the 80MPH issue this time but I'm not getting any boost now. 0-5 PSI at full throttle.

I got back late so I haven't checked things out. I need to check all my vacuum lines, but I'm thinking I may have a bad vacuum pump. Open to ideas though.

I'll check things out tomorrow with the beta app and let you know what happens. Thanks!

l1nk3d 02-22-2020 10:07 AM

So I think I screwed up my JB4 now. I tried downloading the latest firmware from the app and I.think chose the wrong one. How can I get back to what the unit was shipped with? E70 N63.

Edit: I tried the X5 firmware from this post but it's still not working F Chassis N63 JB4 - N54Tech.com - International Turbo Racing Discussion JB4_E_X5_1B.hex

Terry @ BMS 02-22-2020 02:44 PM

Updated the database for platform 18 firmware.

l1nk3d 02-22-2020 07:38 PM

2 Attachment(s)
Wow, that's awesome! Thanks Terry. Great service and on a Saturday too!

So I got it working but before I did I disconnected the JB4 and noticed I wasn't having any boost issues (or at least seemingly so). Upon getting it working again, it the truck seems a little more sluggish and the boost gauge in the app is only showing little to no boost. It almost seems like 50% throttle produces more power.

This is my first tuner so I'm just learning what all these read outs mean. I'm hoping it's just a setting that I'm not seeing.

Also, just a little beta testing note about the app, when I switch maps I have to disconnect and reconnect to the JB4 for the display to update.

Also, verified vacuum appears to be stable and tested all lines for leaks and found none. I still need to check for boost leaks but I'm fairly confident I don't have any as it was producing boost previously.

Terry @ BMS 02-23-2020 02:06 PM

Any fault codes stored? e.g. is it in limp mode?

l1nk3d 02-23-2020 06:00 PM

Quote:

Originally Posted by Terry @ BMS (Post )
Any fault codes stored? e.g. is it in limp mode?

No fault codes, no limp mode. The car seems fine, outside of the rough acceleration (missing), and lack of boost.

l1nk3d 02-23-2020 09:20 PM

Does it matter which TMAP each connection is plugged in to, driver side vs. pass.?

Terry @ BMS 02-25-2020 04:45 PM

No that won't have any effect on this specific model.

Does the car run normally on map0?

l1nk3d 03-11-2020 07:13 PM

2 Attachment(s)
Quote:

Originally Posted by Terry @ BMS (Post )
No that won't have any effect on this specific model.

Does the car run normally on map0?

Sorry for the delay in getting a response to you here Terry, I've been tied up traveling for work.

Over the past couple of weeks I have been doing extensive troubleshooting on this thing. I replaced all of the vacuum lines with new thick wall silicone. Found and resolved an issue with the vacuum pump check valve (diaphragm).
  1. The vacuum lines I initially used to replace the factory ones were thin walled and were collapsing on themselves under full vac. Resolved this with new thick wall silicone.
  2. The vacuum pump check valve diaphragm came off and clogged the vacuum port supplying vacuum to the system. This was resolved.

Those two issues resolved my lack of boost (e.g. 0 PSI)

Unfortunately, I'm back to having the original issues now.
  1. Cruising on the highway between 60-80 MPH using Map 1 and moderately accelerating causes the car to go into full limp mode no power, idle RPM, forcing me to pull over to the shoulder power off the car and power it back on. There is a 2D59 code which appears to be related to torque curves? I think?
  2. The above also happens when using Map 4.
  3. The above does not happen on Map 0.
  4. When using any map 0, 1, 4 acceleration at lower RPMs is rough like a mild vibration with a periodic feeling of the engine missing.
  5. On maps 0, 1, & 4 the maximum boost I have seen is ~10PSI however I seem to be more consistently getting around 4-7 PSI.
  6. At one point yesterday I felt like the car wanted to produce a significant amount more boost and it started to build but then just dropped sharply like it up-shifted but I was still in the same gear. I was doing around 40MPH trying to accelerate.
  7. Every now and then under hard acceleration I get an Engine Malfunction notification with no limp mode or codes and it goes away on its own. (Not really and issue but I want to mention it)

One thing to note is that with the JB4 completely disconnected, the car drives fine. (I haven't confirmed this since upgrading the vacuum hoses but prior to that it was driving fine with no hesitation or boost issue, nor the vibration under acceleration.

I also did a pressure test on my boost side today. The passenger side easily holds pressure up to 20~25PSI and slowly bleeds it off. The Driver's side I can't get over 10PSI and it bleeds off much faster. I can hear both bleeding into the intake so I think that the valves are just open on the driver's side, not that there is an actual leak. I checked the clamps between the inter coolers just to be sure and they are tight.

I'm at a loss here. I can live with only being able to use Map 1 under hard acceleration, but it isn't producing anymore boost than stock now, and I've only had it spike to 17 PSI one time very briefly just before shifting to the next gear and dropping off, and that was before I resolved all the vacuum issues. Now I can't get over 10-11PSI. Any help would be greatly appreciated.

EDIT: I forgot to mention I've been disabling DSC and TC to avoid any issues there. If I leave it on even on Map 0 it breaks loose on hard take offs and flashes (as it should). But my thinking was that this might help the 2D59 codes when highway cruising but it didn't.

Also, is it possible there could be a problem with the maps? perhaps Map 1 was reset somehow? I don't know how to check what the settings are from the logs, is that even possible or would I need a USB connection and laptop to even customize it?


All times are GMT -7. The time now is 05:43 PM.


Copyright 2007 - 2022, JB4tech.com