N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   Mercedes C250, C300, C43, AMG (https://www.n54tech.com/forums/forumdisplay.php?f=38)
-   -   Terry Please Help! What am i doing wrong? (https://www.n54tech.com/forums/showthread.php?t=62308)

gimmefunk 06-13-2020 01:05 AM

Terry Please Help! What am i doing wrong?
 
**SOLVED! ****

CHECKING RAINBOW HARNESS WITH VOLTMETER I FOUND RED WIRE WAS BROKEN BUT STILL IN SHRINK.. RESOLDERED GOOD TO GO!

Sorry I have never posted to any forum before but i need advice/help!!

C300, installed jb4 with only rainbow ribbon, with bluetooth. I have included the very first logs, as well as the very last logs. There just is NO BOOST when jb4 is installed. doesnt matter which map. In fact, i kept getting p0237 code, which meant Turbocharger/Supercharger Boost Sensor 'A' Circuit Low.

After going back and forth, flashing the different firmwares, etc. I gave up and ordered a new TMAP. It arrived and the turbo without the jb4 would work. I would get through the ODBII -0.7 readings until i would boost and it would jump as high as 2.0 . Then back to -0.7. but at least the boost worked.

After i installed JB4 and map1 then 2, there was no boost and without the JB4 the car is back to sluggish. Is my JB4 broken somehow? Please advise

Also at first boost2 did have values but that disappeared. now neither boost or boost2 have any values and the AIF(?) goes nuts up and down irratically

gimmefunk 06-13-2020 01:13 AM

Logs
 
8 Attachment(s)
oops forgot logs!

VipinLJ 06-13-2020 02:15 PM

Are all the plugs plugged in tight? When I first installed mine on my 330i, one of the plugs was loose though it looked tight. Car had no boost at all. It even threw an error code. Rechecked connections, tightened it and everything was back to normal.

Philly_tee 03-29-2021 09:10 PM

@gimmefunk ugh, I’m having the same issues right now. No boost on my c400 only when I hammer it then the boost comes on for a second or so. Logs are showing 0 target and then going up very slowly. I’m going to reconnect wires, double check and reinstall. If that doesn’t work I’ll uninstall and use a multimeter on every wire.

You replaced the entire red wire on the harness?

Terry @ BMS 04-03-2021 03:18 PM

If you have a wiring issue you'll have a CEL that never clears and car will be stuck in limp mode.


All times are GMT -7. The time now is 02:18 AM.


Copyright 2007 - 2020, N54tech.com