N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   N54 (https://www.n54tech.com/forums/forumdisplay.php?f=3)
-   -   Second O ring on throttlebody/chargepipe? (https://www.n54tech.com/forums/showthread.php?t=54929)

Ballistic 09-08-2018 01:10 AM

Second O ring on throttlebody/chargepipe?
 
Hi all,

I installed my chargepipe + Tial BOV (unpainted 10psi spring) on my N54 yesterday. Connected the Tial with a 1/4 line directly to a new vacuum connection on the manifold.

I now have a whistle when boosting. It starts at about 4psi and is pretty loud almost all the way through the RPM band.

During removal of throttlebody+manifold, I found an O ring right under where the thottle body is supposed to be (it was laying on the hard to unclip electronics box)

I have no place for this O ring as i have not seen it before and i cannot place it anywhere.
It is not the O ring in the charge pipe, i already moved that over.

The only place they are talking about 2 O rings in the charge pipe: https://f30.bimmerpost.com/forums/sh....php?t=1236747
But this is for an F30 while i have an E91 N54.

I did not reinstall this ring. Could this be causing the whistle? Throttle body connection looks solid. It should be either this, or the Tial valve not closing fully.

Payam @ BMS 09-08-2018 05:13 PM

Only 1 O ring should be on CP to Throttle body.

mojo20032004 09-09-2018 09:51 AM

Maybe it got dropped by accident. Same size o ring is used for the oil filter cap

Ballistic 09-10-2018 01:44 AM

Thanks for the verification. I also asssume it was there by accident.
I used a single O ring and replaced the Tial valve with a new one. No more whistle :)

Case closed.


All times are GMT -7. The time now is 01:45 PM.


Copyright 2007 - 2018, N54tech.com