N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   N63, N63TU (https://www.n54tech.com/forums/forumdisplay.php?f=57)
-   -   Jb4 problems. N63 (https://www.n54tech.com/forums/showthread.php?t=64777)

Alexe70 03-20-2021 01:27 PM

Jb4 problems. N63
 
I just installed my jb4 and ********* on my 2013 x5 50i. N63 engine.

My problem is on the jb4 app, only my boost gauge works. Rpm, afr, coolant.. etc.. don't work. Also will not boost over 10psi on any map. I downloaded all the newest firmware for e70 n63 but nothing changes.
Any help would be great.

SR1975 03-22-2021 05:00 AM

I experience the same issue. Unfortunately the n63 is the black sheep of the jb4 family and the X5 50i is the black sheep of the black sheep!!! I found loading one of the non X5 n63 firmware updates allows most of the gauges and data logging to work such as afr, intake temps, timing, etc. I could never get anything other then map1 to work however. I'll check which firmware I am using and report back later today.

Alexe70 03-22-2021 09:01 AM

Quote:

Originally Posted by SR1975 (Post )
I experience the same issue. Unfortunately the n63 is the black sheep of the jb4 family and the X5 50i is the black sheep of the black sheep!!! I found loading one of the non X5 n63 firmware updates allows most of the gauges and data logging to work such as afr, intake temps, timing, etc. I could never get anything other then map1 to work however. I'll check which firmware I am using and report back later today.


Go figure lol. There is another firmware download that says n63 x5/x6 OBD2. I haven't tried it yet. The firmware that I downloaded was the e70 n63 and nothing works on that.

Alexe70 03-22-2021 05:41 PM

Update. I downloaded the x5x6 n63 obd2 firmware. All the gauges work now. But can't tell any power difference from map 1 or map 2. Boost gets to 11 psi on map 1. But nothing higher on map 2 or 3. Getting there I guess lol.

Steve @ BMS/Fuel-It! 03-23-2021 11:00 AM

upload a log and we'll look it over. ;)

Alexe70 03-25-2021 04:23 PM

Quote:

Originally Posted by Steve @ BMS/Fuel-It! (Post )
upload a log and we'll look it over. ;)

Do I need to do logs with jb4 disabled? Or one for each map?

Steve @ BMS/Fuel-It! 03-26-2021 10:09 AM

I'd start with a log of map 1 and then we can go from there. ;)

Alexe70 03-29-2021 07:51 AM

Quote:

Originally Posted by Steve @ BMS/Fuel-It! (Post )
I'd start with a log of map 1 and then we can go from there. ;)

I got it boosting and running much stronger. My problem is wastegate arm and flappers a wore out. I adjusted wastegate arms and am getting quicker spool and more boost. Now my problem is my battery dies super fast like overnight. When I disabled the jb4 battery is fine. The jb4 seems to not let the car go to sleep. Any info on this?

Alexe70 03-31-2021 02:23 PM

Any info on the battery issue?

Anzafin 03-31-2021 11:51 PM

Quote:

Originally Posted by Alexe70 (Post )
Any info on the battery issue?

Check the Active sound from the JB4 folder and set it OFF and see if it helps any.

Alexe70 04-02-2021 07:11 AM

Does the x5 even have a dash menu? I can't get the bc button to do anything.

Alexe70 04-02-2021 08:38 AM

Quote:

Originally Posted by Anzafin (Post )
Check the Active sound from the JB4 folder and set it OFF and see if it helps any.

My bc button won't let me get into the dash menu. Does the x5 even have it?

Alexe70 04-21-2021 04:46 AM

Any info on why my bc button won't let me get into the dash menu? I need to turn off my active sound. I think that's what's killing my battery.

Steve @ BMS/Fuel-It! 04-21-2021 11:23 AM

Still don't see a log, we'll need that to assist with this. ;)

Alexe70 04-27-2021 07:11 PM

1 Attachment(s)
Quote:

Originally Posted by Steve @ BMS/Fuel-It! (Post )
Still don't see a log, we'll need that to assist with this. ;)

Here is a log on stage 2

Steve @ BMS/Fuel-It! 04-28-2021 09:44 AM

Log looks fine thus far...unfortunately this is an E chassis and as such there isn't much more you can do. :(

Alexe70 04-28-2021 01:44 PM

Quote:

Originally Posted by Steve @ BMS/Fuel-It! (Post )
Log looks fine thus far...unfortunately this is an E chassis and as such there isn't much more you can do. :(


How do I get active control turned off? I can't have the jb4 turned on without killing my battery.

Steve @ BMS/Fuel-It! 04-29-2021 10:07 AM

To be honest, I'm not sure on that platform. I'd suggest emailing support@burgertuning.com for assistance with that. This is a pretty old platform that isn't supported so I'm not sure what the options are. Sorry :(

SR1975 04-29-2021 02:50 PM

Quote:

Originally Posted by Alexe70 (Post )
How do I get active control turned off? I can't have the jb4 turned on without killing my battery.

I loaded the same firmware you did (was just using the f series as it was the only thing working with the ob2 at the time) and have experienced the same thing. It will kill the battery overnight. I doubt we will see a fix anytime soon besides me and you, there a probably two other E70 n63 jb4 users so not alot of incentive for Burger to jump on it right away.

A good work around is to simply unplug the jb4 ob2 connector when you park. Its a bit of a pain but does the trick and won't kill the battery now. I will be wiring up a switch soon to make it easier and recommend you do the same. Will probably combine it with a pass-through ob2 connector so I don't have to fumble around with the jb4 when connecting a scanner or laptop.

SR1975 04-29-2021 02:56 PM

Quote:

Originally Posted by Alexe70 (Post )
How do I get active control turned off? I can't have the jb4 turned on without killing my battery.

I loaded the same firmware you did (was just using the f series as it was the only thing working with the ob2 at the time) and have experienced the same thing. It will kill the battery overnight. I doubt we will see a fix anytime as soon besides me and you, there a probably two other E70 n63 jb4 users so not alot of incentive for Burger to jump on it right away.

A good work around is to simply unplug the jb4 ob2 connector when you park. Its a bit of a pain but does the trick and won't kill the battery now. I will be wiring up a switch soon to make it easier and recommend you do the same. Will probably combine it with a pass-through ob2 connector so I don't have to fumble around with the jb4 when connecting a scanner or laptop. I would recommend you do it too.

On the plus side with this new firmware and access to map2, knocked out my best 0-60 to date of 3.9 seconds. It was hitting 17, psi (I have a ESS Stage 1 flash that takes it to about 12psi). Not to bad for a 9 year old 170k mile orginal engine SUV. Making a custom intake now as the stock is a joke so I can take to 24psi or break something trying��. N20 tmaps and meth injection will b installed at th same time to support it.

Steve @ BMS/Fuel-It! 04-30-2021 09:16 AM

Unfortunately this is such a small and old platform, there isn't a test vehicle to do any further development on. :(

Z_god203 07-03-2021 09:44 AM

Any updates?

Besides that I can’t get the jb4 to read check engine codes I have a code for 02s because I’m running *** but the jb4 won’t read them.
Also is there anyway to turn off the check engine for light for 02s?

mrfiander3212 07-16-2021 06:29 AM

This is very disapointing to me since i just purchased my jb4 a few months ago. If there is no support for us why are they still selling for the E chasis.

Steve @ BMS/Fuel-It! 07-16-2021 09:31 AM

Quote:

Originally Posted by Z_god203 (Post )
Any updates?

Besides that I canít get the jb4 to read check engine codes I have a code for 02s because Iím running *** but the jb4 wonít read them.
Also is there anyway to turn off the check engine for light for 02s?

If outside the US, you can enable passive delete.

Quote:

Originally Posted by mrfiander3212 (Post )
This is very disapointing to me since i just purchased my jb4 a few months ago. If there is no support for us why are they still selling for the E chasis.

The JB4 still does it's thing, we just aren't doing any additional development with this platform.

Z_god203 07-16-2021 10:16 AM

Quote:

Originally Posted by Steve @ BMS/Fuel-It! (Post )
If outside the US, you can enable passive delete.



The JB4 still does it's thing, we just aren't doing any additional development with this platform.

How do you enable the passive Delete?


All times are GMT -7. The time now is 04:32 AM.


Copyright © 2007 - 2020, N54tech.com