N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   Lexus, Maserati, Alfa, Jeep, Diesel, McLaren, and other new applications (https://www.n54tech.com/forums/forumdisplay.php?f=42)
-   -   JB4 for Maserati Ghibli (https://www.n54tech.com/forums/showthread.php?t=53912)

Whooopasss 10-25-2018 11:43 AM

Thanks for the reply. I have worked with vargas turbo rebuilding a few turbo units for my other cars. I was not aware if he has a AWD dyno. Let me email him.

Ok I am sold, will be placing the order shortly.

One more clarification

do I buy all of these?

1. Maserati JB4 BETA
2. Optional JB4 Wireless Mobile Connect Kit
3. BMS Data Cable

Payam @ BMS 10-25-2018 11:58 AM

Quote:

Originally Posted by Whooopasss (Post )
Thanks for the reply. I have worked with vargas turbo rebuilding a few turbo units for my other cars. I was not aware if he has a AWD dyno. Let me email him.

Ok I am sold, will be placing the order shortly.

One more clarification

do I buy all of these?

1. Maserati JB4 BETA
2. Optional JB4 Wireless Mobile Connect Kit
3. BMS Data Cable

Ahh, Vargas does not have an AWD system.

1- Yes
2/3 Depends how you want to log your car. The most popular is 2 so you can log via phone or tablet.

Whooopasss 10-25-2018 12:42 PM

Ordered and done! Thanks!

Whooopasss 11-06-2018 01:16 PM

Just installed my JB4 on the ghibli,. the rear connector was a pain in the ass.. took my 30 min to just do that. The wire via the steering rack was easy. I was able to see via the app that it is defaulted to Map1. I will do a few runs later this week and log it so I can post it here. I am on 91 OCT btw.

I dint like the recomended location for the jb4 which was right next to the radiator reservoir. I felt that it would heat up as the coolant heats up. So i ended up placing the jb4 right next to the ecu. Secured it with cable ties and put back to cover for a stock look. I also figured it is the safest place from water or moisture since the ecu is right there.

Car started fine, and app is getting all data.. no check engine lights!

Btw: i was worried that the jb4 will come in a cheap case.. boy i was dead wrong!! the case is solid and with a good weight! I think it is aluminum secured by 4 screws.. if you throw this at someone and hits them in the head, it can cause a lot of damage!

Terry @ BMS 11-06-2018 05:08 PM

Haha yes it's a good build quality. Can be used as a deadly weapon if needed but a lot more fun under the hood. :)

Whooopasss 11-11-2018 07:59 AM

I wanted to provide a feedback on jb4 map 1 so far. There is a real hugh improvement over stock. I hit redline quicker as well as the car upshifts to the next gear a lot quicker due to the quick rise of the rpm. It is a lot more fun to drive now. I keep checking for any codes and so far, after driving the car a total of 300miles in 1 day (south san jose-san ramon- concord-napa-gayserville-santa rosa-petaluma-sausoiito-berkey-okland-sunnyvale-san jose) with very occasional flat our redline runs, car has no codes what so ever. Car Pulls very strong compared to stock. This is on 91 oct. i was not able to log anything as i was having lots of fun driving. I hope i can do log run and a dyno session soon. Is it worth it? Absolutly! With the flexibility it has, as well as being set to map1 and the performance improvement at map1 only, yes it is worth it. Glad i made the purchase!

Whooopasss 11-13-2018 02:23 PM

4 Attachment(s)
Logs with 3rd gear pull and 91 oct

Payam @ BMS 11-14-2018 10:39 AM

1 Attachment(s)
Looks like the car is moving! Very good logs man.

Whooopasss 11-14-2018 11:08 AM

should I try other maps?

Merwan8888 11-25-2018 04:55 PM

Maserati ghibli limp mode
 
I’ve had my jb4 in my 2014 ghibli for 2 months now and earlier the car went into limp mode , once I plugged out the obd connector the car got out of it and every time when I plug it back on it does it again. Anybody know what this is .?

Whooopasss 11-25-2018 07:28 PM

must be a loose connection or a bad unit perhaps?.. before I installed mine, I used my multi meter to make sure each connector is secured and connected from both ends.. from the connector itself to the male connector on the board. I checked each one. this is due to the comment from the other member who said that he was getting no boost at times. I suspected a loose wire so I double checked mine. That way, if I get an issue, I know it is not the wiring.. so far so good!.

Merwan8888 11-25-2018 08:39 PM

Quote:

Originally Posted by Whooopasss (Post )
must be a loose connection or a bad unit perhaps?.. before I installed mine, I used my multi meter to make sure each connector is secured and connected from both ends.. from the connector itself to the male connector on the board. I checked each one. this is due to the comment from the other member who said that he was getting no boost at times. I suspected a loose wire so I double checked mine. That way, if I get an issue, I know it is not the wiring.. so far so good!.

Checked every connector everythingís fine, no luck anybody else know why?

Terry @ BMS 11-25-2018 09:39 PM

Quote:

Originally Posted by Merwan8888 (Post )
Iíve had my jb4 in my 2014 ghibli for 2 months now and earlier the car went into limp mode , once I plugged out the obd connector the car got out of it and every time when I plug it back on it does it again. Anybody know what this is .?

Ah must be a faulty OBDII! Can happen from time to time. Just email us, we'll send another one. :)

Whooopasss 11-27-2018 01:36 AM

Terry, is it safe to try other maps?

HollywoodHogan 11-27-2018 09:10 PM

Can you guys clarify:

1. The original post says 50whp/50wtq gain. The graph shows ~350 hp for a Base. Is that wheel hp or crank? If its whp, that seems high for a base no?

2. Does the JB4 delete or erase CEL if we have down sport cats or removed cats?

Payam @ BMS 11-27-2018 11:00 PM

Quote:

Originally Posted by HollywoodHogan (Post )
Can you guys clarify:

1. The original post says 50whp/50wtq gain. The graph shows ~350 hp for a Base. Is that wheel hp or crank? If its whp, that seems high for a base no?

2. Does the JB4 delete or erase CEL if we have down sport cats or removed cats?

Wheel hp, could be factory freak.

No, that would be illegal.

diesel3443 11-28-2018 08:32 AM

Following. I have been thinking about getting rid of my 335i for the Ghibli. I was pumped to see that you guys already have developed a JB4 for it :D

diesel3443 11-28-2018 08:37 AM

Have you guys tested with ethanol yet? Curious to see the numbers.

Payam @ BMS 11-28-2018 09:57 AM

Quote:

Originally Posted by diesel3443 (Post )
Have you guys tested with ethanol yet? Curious to see the numbers.

I know a few customers have been messing with ethanol blends. Fuel system can take it and logs look awesome. Jb4 is a must for the Ghibli.

Whooopasss 11-28-2018 10:08 AM

Payam @ BMS missed my question about trying other map aside from map1 on the ghibli?

Payam @ BMS 11-28-2018 12:54 PM

Quote:

Originally Posted by Whooopasss (Post )
Payam @ BMS missed my question about trying other map aside from map1 on the ghibli?

Sorry man! From what I saw in your last log on 91 and map 1 it looked okay. Go ahead and try map 2 and get me some logs. Do you have access do any e85?

Whooopasss 11-28-2018 12:56 PM

yes we do.. its about a mile from my house.. what did you have in mind?

nitrobass24 12-27-2018 04:10 PM

2 Attachment(s)
Got mine installed today and wow, this car is woke AF now. Even on Map 1 its a huge increase in performance.

Here is a few logs from Map 1.

Terry @ BMS 12-27-2018 05:51 PM

Log looks good! But crank it up to full throttle! :)

nitrobass24 12-28-2018 12:17 PM

Lol, yea need to find some open highway. Dallas during rush hour is no fun :)


All times are GMT -7. The time now is 05:04 AM.


Copyright © 2007 - 2020, N54tech.com