N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   N63, N63TU (https://www.n54tech.com/forums/forumdisplay.php?f=57)
-   -   JB4 Issues (https://www.n54tech.com/forums/showthread.php?t=62442)

Mandrow7 06-24-2020 08:11 PM

JB4 Issues
 
Have a 2011 550i XDrive, just installed JB4 and ******* dpís. Iím getting codes about running too lean which I assume is the *****, but I thought the JB4 auto-cleared codes? Also, getting drivetrain malfunction on stage 1 or 2. Just put new plugs, maybe a little better but same thing. Have coils on the way, jus tlooking to see if there s anything else to check or something in case coils dont fix it either?

Terry @ BMS 06-25-2020 08:47 AM

1) The JB4 won't auto clear codes, passive delete is disabled in the USA for emissions purposes. Can be enabled outside the USA. App uses GPS to verify.
2) You should not have any codes other than *** efficiency. Those are the only faults that could be auto cleared anyway. Any other codes indicate an issue which must be resolved.

Mandrow7 06-25-2020 10:38 PM

So the efficiency codes talking about being too lean and lambda probes, ignore them? Also a couple side questions: 1-does the “current mods” section change the tune at all based on whats in there, or what’s the section for? 2-what would be the recommended spark gap if just ctless dp’s and tune? Possibly e30? And would double platinum plugs be ok? Thanks

Terry @ BMS 06-26-2020 11:15 AM

Anything about too lean is likely a problem you need to fix. If you need more specific advice post the exact code numbers and descriptions.

For the gap we suggest 0.022"

Mandrow7 06-26-2020 01:30 PM

20A502
210901
118702
128401
118602
120708
140401
I also had a couple that were just “000000”, no description. I will change the plug gap to .022, they’re at .027 right now. Im also installing coils after work. Will ******* dp’s cause those leans codes or are my 02s bad do you think?

Terry @ BMS 06-26-2020 01:39 PM

You can lookup the descriptions here: BMW Fault Code Lookup - BMWFaultCodes

Mandrow7 06-28-2020 08:38 AM

With ******* *********, should I be getting lean/rich codes, or does that mean my sensors are bad?

SINasTER 06-28-2020 09:20 AM

Quote:

Originally Posted by Mandrow7 (Post )
Have a 2011 550i XDrive, just installed JB4 and ******* dpís. Iím getting codes about running too lean which I assume is the *****, but I thought the JB4 auto-cleared codes? Also, getting drivetrain malfunction on stage 1 or 2. Just put new plugs, maybe a little better but same thing. Have coils on the way, jus tlooking to see if there s anything else to check or something in case coils dont fix it either?

Change your MAP sensors and clean your MAF sensors also, had the same symptoms and that was my problem.

I get a rich mixture cel now but I think itís related to my new intake since I started getting those codes right after I installed them. PITA though and trying to get help but no answer yet...

Mandrow7 06-28-2020 10:51 AM

As of now with new coils and plugs, im getting the 20A502 code still which I think is a turbo coolant pump issue which I think is a recall on my car, and then those lean/rich codes. I wasnt sure if the ctlss dp’s were causing the codes and my o2’s are fine, or if my o2’s were bad?

Mandrow7 06-30-2020 10:48 AM

As of now on stage 1, I get drivetrain malfunction on full throttle and no CEL pops. The only stored codes are that coolant pump one above and some lean codes


All times are GMT -7. The time now is 08:03 PM.


Copyright © 2007 - 2020, N54tech.com