N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   Support & Log Review (https://www.n54tech.com/forums/forumdisplay.php?f=44)
-   -   JB4 W/ MHD BEF Boost Problem (https://www.n54tech.com/forums/showthread.php?t=58758)

GreenE92Matt 07-12-2019 04:38 PM

JB4 W/ MHD BEF Boost Problem
 
Hey guys. I live in Houston Texas where it is hot as balls. I just got my E92 335i back from a shop that did a turbo swap from stock to MMP 1K turbos. They also did relocated inlets and a silicone outlet. With that being said I myself did a MHD BEF Stage 2+ on the car and I am running it on Map 5. Some pulls go up to the full target 18 psi of boost but sometimes it gets limited to 10 psi then sometimes 8psi.. the pulls are done always the same.. a 3-4 pull. Could this be the JB4/MHD? Would it be a boost leak? Anyone experience this before?

Thanks

Haynpunch 07-12-2019 05:51 PM

Quote:

Originally Posted by GreenE92Matt (Post )
Hey guys. I live in Houston Texas where it is hot as balls. I just got my E92 335i back from a shop that did a turbo swap from stock to MMP 1K turbos. They also did relocated inlets and a silicone outlet. With that being said I myself did a MHD BEF Stage 2+ on the car and I am running it on Map 5. Some pulls go up to the full target 18 psi of boost but sometimes it gets limited to 10 psi then sometimes 8psi.. the pulls are done always the same.. a 3-4 pull. Could this be the JB4/MHD? Would it be a boost leak? Anyone experience this before?

Thanks

Post a proper log in the Support section

Rushan 07-13-2019 02:18 AM

You are running map5 on the JB4 with MHD stage 2? Not sure if I understand it correctly but for using JB4 in map 5 you would need the BMS MHD flash depend on you fuel rather than the MHD stage 2,

Except if you are using the JB4 only as passive and you switched your JB4 connections to run the 4/3 menu but I dont think you should also be on map5.

Anyways a proper log can show more details

Dave @ BMS/Fuel-It! 07-15-2019 12:41 PM

Quote:

Originally Posted by GreenE92Matt (Post )
Hey guys. I live in Houston Texas where it is hot as balls. I just got my E92 335i back from a shop that did a turbo swap from stock to MMP 1K turbos. They also did relocated inlets and a silicone outlet. With that being said I myself did a MHD BEF Stage 2+ on the car and I am running it on Map 5. Some pulls go up to the full target 18 psi of boost but sometimes it gets limited to 10 psi then sometimes 8psi.. the pulls are done always the same.. a 3-4 pull. Could this be the JB4/MHD? Would it be a boost leak? Anyone experience this before?

Thanks

Odd / confusing.

Are you running JB4 + a BEF? or JB4 installed w. an OTS MHD Map?

Proper setup would be installing the latest / proper JB4 firmware & Then installing the HYBRID BEF for your new turbos...

I would start by double checking what you have installed currently & if it is not what i mentioned above- correcting / switching, and then posting a proper log in MAP 1


All times are GMT -7. The time now is 08:36 AM.


Copyright 2007 - 2020, N54tech.com