N54Tech.com - International Turbo Racing Discussion

N54Tech.com - International Turbo Racing Discussion (https://www.n54tech.com/forums/index.php)
-   JB4 Mobile (https://www.n54tech.com/forums/forumdisplay.php?f=58)
-   -   JB4 Mobile for Apple and Android Smart Phone Support (https://www.n54tech.com/forums/showthread.php?t=21742)

Myaddiction 08-07-2015 09:42 AM

Quote:

Originally Posted by Dmac @ BMS/DMD (Post )
I've been using this app build for a while now and haven't experienced this issue once. Have any N54 users experienced this with the most recent update?

Did this issue only start for you all with the most recent app update? Did anything else change before this issue started?

Edit: Here's a test to try. When the gauges stop refreshing, start a log, wait a minute, then stop the log. Email me that log, jb4connectkit@gmail.com.

Ok, will do.

DVAPower 08-07-2015 01:38 PM

Quote:

Originally Posted by Alex! (Post )
+1

Any chances to do a batch of rev2?

I have a new Rev2 which is as yet unused, I would be happy to trade for a Rev3.

Dave

rocky335i 08-07-2015 03:50 PM

How can i upload a new jb4 firmware with the jb4 app?
I have the the firmware in my email not sure how to extract it and send it to the app to upload it

oorlando 08-08-2015 01:19 PM

Is there something wrong with the JB4 app? The gauges keep freezing

Dmac @ BMS/DMD 08-08-2015 01:24 PM

Quote:

Originally Posted by fea30boy (Post )
Tried what you said to do, on iPhone worked but on IPad still not showing .csv preview

I'll test it on my iPad later tonight.

Quote:

Originally Posted by rocky335i (Post )
How can i upload a new jb4 firmware with the jb4 app?
I have the the firmware in my email not sure how to extract it and send it to the app to upload it

Save the hex file to your device then use something like ES File Explorer to copy the hex file to /sdcard/JB4 Mobile Data/Firmware

Quote:

Originally Posted by oorlando (Post )
Is there something wrong with the JB4 app? The gauges keep freezing

Please provide a full support request with the information suggested in the first post.

Dmac @ BMS/DMD 08-08-2015 01:37 PM

First post updated with Rev 3 N54 install video.

Dmac @ BMS/DMD 08-08-2015 01:38 PM

All iOS users who are having the issue with the gauges not refreshing, email me your iTunes email address so I can add you to my beta list. JB4ConnectKit@gmail.com

oorlando 08-08-2015 08:06 PM

Quote:

Originally Posted by Dmac @ BMS/DMD (Post )
I'll test it on my iPad later tonight.



Save the hex file to your device then use something like ES File Explorer to copy the hex file to /sdcard/JB4 Mobile Data/Firmware



Please provide a full support request with the information suggested in the first post.

Sorry.

Device: Galaxy Tab A 8.0
OS: not sure, I'm not android user
Engine type: N54 E Series
App build: not sure where to check. I'm apple not android
Problem experienced: same problem the gauges are freezing and lagging. I restarted the tablet, and checked for updates. Problem still present

mave198 08-09-2015 11:12 AM

Been having trouble last couple of days trying to connect to the JB4 with the android app. It would connect for a few seconds, long enough to read codes, then the connection would be lost and it would say serial port not available. Disconnecting the cable and re trying results in error connecting to JB4 please try again.

Its not my phone or OTG cable because I connect to the ECU with MHD just fine and all the time.

Bad USB cable? Serial port on JB4 fried or app not functioning?

Thanks for any suggestions.

ganque 08-10-2015 01:06 PM

Subbed to keep updated when the JB4 Connect Kit is back in stock.

Dmac @ BMS/DMD 08-11-2015 01:39 PM

Quote:

Originally Posted by oorlando (Post )
Sorry.

Device: Galaxy Tab A 8.0
OS: not sure, I'm not android user
Engine type: N54 E Series
App build: not sure where to check. I'm apple not android
Problem experienced: same problem the gauges are freezing and lagging. I restarted the tablet, and checked for updates. Problem still present

Now this is confusing as none of the connection code changed in the last updates, especially with Android. Can you snap a short video showing the lag then freezing?

Quote:

Originally Posted by mave198 (Post )
Been having trouble last couple of days trying to connect to the JB4 with the android app. It would connect for a few seconds, long enough to read codes, then the connection would be lost and it would say serial port not available. Disconnecting the cable and re trying results in error connecting to JB4 please try again.

Its not my phone or OTG cable because I connect to the ECU with MHD just fine and all the time.

Bad USB cable? Serial port on JB4 fried or app not functioning?

Thanks for any suggestions.

Hmm, is the usb port on your device loose at all? Do your cables move much while connected?


Quote:

Originally Posted by ganque (Post )
Subbed to keep updated when the JB4 Connect Kit is back in stock.

Just send an email to orders@jb4connectkit.com to get on the waiting list.

katsooba 08-11-2015 04:32 PM

Dmac hi,

is there any way to display coolant temps?
on the N55 the JB4 can read coolant temps, 2-6 watertemp on fuel hijack
so i am sure you could program a display to show it?

Dmac @ BMS/DMD 08-11-2015 06:07 PM

Quote:

Originally Posted by ***sooba (Post )
Dmac hi,

is there any way to display coolant temps?
on the N55 the JB4 can read coolant temps, 2-6 watertemp on fuel hijack
so i am sure you could program a display to show it?

If it's just a FUD value, that will display under FP_L. You'd just need the appropriate FUD value in the user adjustment settings page.

alexx 08-13-2015 03:32 PM

hey guys
just wondering if anyones picked up a cheap android tablet that has the bluetooth low energy to be able to run the JB4 software.
thanks

tc535i 08-13-2015 03:34 PM

Quote:

Originally Posted by alexx (Post )
hey guys
just wondering if anyones picked up a cheap android tablet that has the bluetooth low energy to be able to run the JB4 software.
thanks

android requires the OTG cable, I haven't heard of anybody running bluetooth (but would be VERY interested!)

alexx 08-13-2015 03:57 PM

donnie told me that with the new rev3 kits you can use an android tablet as long as it has bluetooth low energy.

Dmac @ BMS/DMD 08-14-2015 02:35 PM

You definitely can use the bluetooth kits with an Android device as long as that device supports Bluetooth Low Energy.

tc535i 08-14-2015 02:54 PM

Quote:

Originally Posted by Dmac @ BMS/DMD (Post )
You definitely can use the bluetooth kits with an Android device as long as that device supports Bluetooth Low Energy.

:happy

deltalima0 08-14-2015 10:51 PM

Is the latest firmware 31 supported? I loaded it and connected and it will do nothing no gauges unable to read codes you name it not working.

Dmac @ BMS/DMD 08-15-2015 11:09 AM

Quote:

Originally Posted by deltalima0 (Post )
Is the latest firmware 31 supported? I loaded it and connected and it will do nothing no gauges unable to read codes you name it not working.

I'll load it up on my bench setup and test here in a little bit, but I wouldn't think it'd be incompatible. Anyone else on firmware 31 using the app?

nyt 08-15-2015 12:15 PM

Quote:

Originally Posted by deltalima0 (Post )
Is the latest firmware 31 supported? I loaded it and connected and it will do nothing no gauges unable to read codes you name it not working.

close the app completely (swipe away in task list) and restart it.

works fine here

billj457 08-15-2015 02:32 PM

Quote:

Originally Posted by Dmac @ BMS/DMD (Post )
I'll load it up on my bench setup and test here in a little bit, but I wouldn't think it'd be incompatible. Anyone else on firmware 31 using the app?

Yup, I updated to 31 via the app and have been running it without a single problem.

x99percent 08-15-2015 02:54 PM

Couple of feature requests for the Android version:
- Make the app respect the device's orientation preference. Currently, if my device is locked to portrait, this app will still rotate if the device is turned.
- I saw the reasoning behind disabling the back button earlier in the thread... can it be made an option to re-enable the button?

Thanks in advance!

rleroy4298 08-15-2015 08:37 PM

Quote:

Originally Posted by Dmac @ BMS/DMD (Post )
I'll load it up on my bench setup and test here in a little bit, but I wouldn't think it'd be incompatible. Anyone else on firmware 31 using the app?

Is PID Gain within the App, the same as Menu 12 on the Steering Wheel Controls (Duty Cycle)? ...just wanted to confirm as defaults for each are identical at 25, I believe. If this is the case, these two items are no longer syncing now that I have ISO31 & your App (eg I increased Menu 12 on the Steering Wheel Controls to 28, however, 25 still remains under PID Gain in the App).

Anyways, I may just have these two parameters mixed up, but in case they are in fact the same, I just wanted to let you know of this issue.

Cynical 08-15-2015 09:19 PM

Quote:

Originally Posted by deltalima0 (Post )
Is the latest firmware 31 supported? I loaded it and connected and it will do nothing no gauges unable to read codes you name it not working.

This is a bug ive noticed for a while with the app. Goto settings and force quit the app then reopen


All times are GMT -7. The time now is 01:18 PM.


Copyright 2007 - 2020, N54tech.com