N54Tech.com - Your Source for International Turbo BMW Racing Discussion
(#1)
Old
bulletrs's Avatar
bulletrs bulletrs is offline
Junior Member
 
Posts: 66
Join Date: Oct 2016
Car: M235i '15
Default H&R Sports springs popping sound - 05-12-2017, 05:10 AM

My dealer installed H&R sports springs for me on my '15 M235i with adaptive suspension. Now the car makes a popping sound on the frontleftside when turning the wheel on standstill or while parking.

My BMW dealer has swapped the complete suspension on the frontleft side but the popping is still there. According to them it is probably the frontleft spring causing the issue, it is definately properly assembled. The frontleft spring also seems to be a little higher in measurement (4mm). Don't know if that could cause it.

What do you guys think could be the problem?


2015 F22 M235i N55 EWG | M Performance | 18" VMR710 | Pure Stage 2 Turbo | Pure High Flow Inlet | Bootmod3 BEF | BMS JB4 + FF & EWG Wires | BMS Performance Intake | BMS Methkit | GFB DV+ T9356 | N20 TMAP | NGK SILZKBR8D8S 0,5mm | Wagner DownP | Wagner EVO2 Performance Intercooler | VRSF Chargepipe | M Performance Exhaust | Aral 102 Fuel

100-200kph: 7.55s
1/4 mile: 11.93s @ 125mph
Reply With Quote
(#2)
Old
LessIsMore's Avatar
LessIsMore LessIsMore is offline
Inner Circle Member
 
Posts: 381
Join Date: Aug 2012
Car: 2009 535i Sport SAT
Default 06-29-2017, 10:33 AM

hard to say.

strut mounts, strut not tightened back into the hub clamp, ball joint not bad or loose ...


2009 535i Sport
JB4 G5 | MHD E85 Hybrid BEF | VTT GC Lites | VTT Inlets | VTT Outlet | VRSF 3" D-P's | VRSF 7" FMIC | Fuel-It Stage 2 LPFP | Fuel-It TBI | BMS DCI | ER CP | Forge DV's | 3.5 Bar TMAP | RB PCV | Koni FSD | 15mm Rear Spacers
Reply With Quote
(#3)
Old
zort zort is offline
Junior Member
 
Posts: 158
Join Date: Jun 2016
Car: e90 335i
Default 09-21-2017, 06:02 AM

Crap I just went through this exact issue and was able to solve the problem. Lowered the car on springs and developed a popping sound when turning either moving on at a stand still. Sounded like a spring binding. Frustrated and knowing I needed rear shocks I did full coilovers the next year along upper mounts. Same issue.

Just did my clutch and when the car was on the ramp I asked the shop to have a look -
It was the shield just above the steering ends . Just found it after two years.

I bet you this is your problem.. well hopefully.


-B
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2017, N54tech.com